Bug 239925 - Applications using KCategorizedView freezes when scrollbar appears
Summary: Applications using KCategorizedView freezes when scrollbar appears
Status: RESOLVED DUPLICATE of bug 213068
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: SVN
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-28 23:02 UTC by Kristjan Ugrin
Modified: 2010-06-03 00:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
example of freezed app and KCategorizedView (65.34 KB, image/png)
2010-05-28 23:02 UTC, Kristjan Ugrin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kristjan Ugrin 2010-05-28 23:02:13 UTC
Created attachment 47437 [details]
example of freezed app and KCategorizedView

Version:           SVN (using Devel) 
OS:                Linux

When a KCategorizedView is used in an aplication window and that has a scrollbar due too many items, wholle app will freeze.

Reproducible: Always

Steps to Reproduce:
For e.g. plasma-desktop from 4.5beta1:
- lock widgets
- right click on system tray
- select system tray settings entry from menu
- if not, select display section. If that category has a scrollbar, plasma-dekstop will freeze

Amarok:
- click menu: tools -> script manager
- if you have many scripts that will require scrollbar to list them, amarok will freeze

Both aplications were tested on stable 4.4.4 and upcoming 4.5beta1. Amarok is from git. Problem is desktop-wide.

Actual Results:  
Application freeze
Comment 1 Andreas Kuhl 2010-05-30 12:23:39 UTC
I can confirm this also happens with plasma tray settings, which also implements KCategorizedView.
Comment 2 Christoph Feck 2010-06-03 00:46:49 UTC

*** This bug has been marked as a duplicate of bug 213068 ***