Bug 239106 - Text in distributed format not shown
Summary: Text in distributed format not shown
Status: RESOLVED UPSTREAM
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords: reproducible
: 239470 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-13 16:32 UTC by Lassi Nieminen
Modified: 2011-04-09 16:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
msword test document used to open in kword (21.00 KB, application/msword)
2009-08-13 16:32 UTC, Lassi Nieminen
Details
screenshot of the document in kword (146.07 KB, image/png)
2009-08-13 16:36 UTC, Lassi Nieminen
Details
screenshot of the document in MS Word 2003 (77.94 KB, image/png)
2009-08-13 16:37 UTC, Lassi Nieminen
Details
screenshot of the document in kword - 1026239 (225.56 KB, image/x-png)
2009-09-22 14:22 UTC, Lassi Nieminen
Details
pyodconverter converted testdata (25.99 KB, application/x-zip-compressed)
2010-02-28 11:11 UTC, Lassi Nieminen
Details
koconverter converted testdata (3.63 KB, application/x-zip-compressed)
2010-02-28 11:11 UTC, Lassi Nieminen
Details
pyodconverter converted testdata opened in koffice screenshot (127.67 KB, image/png)
2010-02-28 11:11 UTC, Lassi Nieminen
Details
koconverter converted testdata opened in openoffice (126.75 KB, image/png)
2010-02-28 11:12 UTC, Lassi Nieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-05-28 02:51:29 UTC


---- Reported by lassi.ta.nieminen@nokia.com 2009-08-13 17:32:04 +0300 ----

Created an attachment
msword test document used to open in kword

SOFTWARE VERSION:
  Kubuntu 9.04
  Koffice (svn version 1007302)
  Test document (MS Word 2003): msword_2003_format_distributed_text.doc

STEPS LEADING TO THE PROBLEM:
  1. Open the attached document in MS Word 2003.
  2. Open the same document in KOffice.
  3. Observe the first page of the document.

EXPECTED OUTCOME:
  Text in distributed format should be shown in the first page of the
  document.
  see attachment format_distributed_text_msword_2003.png

ACTUAL OUTCOME:
  Text is not shown in the first page of the document.
  Blank page is shown.
  see attachment format_distributed_text_kword_svn_1007302.png

FREQUENCY:
  Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-13 17:36:32 +0300 ----

Created an attachment
screenshot of the document in kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-08-13 17:37:20 +0300 ----

Created an attachment
screenshot of the document in MS Word 2003



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-09-09 16:01:46 +0300 ----

Since KOffice revision 1021513, this document does not crash kword anymore.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-09-22 15:20:05 +0300 ----

Text is shown in the document but not in distributed format.
Attaching the screenshot.
Reopening.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-09-22 15:22:55 +0300 ----

Created an attachment
screenshot of the document in kword - 1026239



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-11-25 16:13:54 +0200 ----

This format is called "justified" and not distributed, and it does work in KWord already.  However, there is a page break inserted between the title and the main text.



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-04 10:35:26 +0200 ----

Reassigning bugs from Thomas to Lassi



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-28 12:11:00 +0200 ----

Created an attachment
pyodconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-28 12:11:20 +0200 ----

Created an attachment
koconverter converted testdata



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-28 12:11:43 +0200 ----

Created an attachment
pyodconverter converted testdata opened in koffice screenshot



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-02-28 12:12:59 +0200 ----

Created an attachment
koconverter converted testdata opened in openoffice

Observation (1096327): None of the converted testdata works correctly. KO loaded OO converted data shows empty page.



--- Bug imported by faure@kde.org 2010-05-28 02:51  ---

This bug was previously known as _bug_ 132992.

Imported an attachment (id=44115)
Imported an attachment (id=44116)
Imported an attachment (id=44117)
Imported an attachment (id=44118)
Imported an attachment (id=44119)
Imported an attachment (id=44120)
Imported an attachment (id=44121)
Imported an attachment (id=44122)
Comment 1 swathi 2010-12-05 11:47:42 UTC
*** Bug 239470 has been marked as a duplicate of this bug. ***
Comment 2 Sebastian Sauer 2011-01-13 20:20:43 UTC
Seems the bug was that we inserted an empty page in front of the text. This is fixed with ba1c0c880432a6eddaa810e78ee370b53a9ae7c8 now and the text is displayed as expected.
Comment 3 swathi 2011-02-28 15:11:13 UTC
Tested in git commit 604c1940e690f2d163db9083abf7fb58e3f4b1fe.
Still text in the first page is not displaying in distributed format.
Comment 4 Camilla Boemann 2011-04-09 16:48:24 UTC
Since Qt doesn't support condensed it doesn't help for the filter to produce it either