Bug 239036 - Can't bind keyboard shortcuts in the form Meta+Shift+x
Summary: Can't bind keyboard shortcuts in the form Meta+Shift+x
Status: RESOLVED DUPLICATE of bug 197548
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.4
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
Depends on:
Reported: 2010-05-27 19:00 UTC by David Frey
Modified: 2010-05-28 12:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description David Frey 2010-05-27 19:00:51 UTC
I tried to bind Meta+Shift+1 as the keyboard shortcut for kwin to perform "Window to desktop 1".  It shows up as Meta+! and nothing happens when I press Meta+Shift+1.

I also tried binding Meta+Tab and Meta+Shift+Tab to "Walk through windows" and "Walk through windows (reverse)" respectively.  The key binding former works correctly, but the latter does not.  When I do not have "Meta+Shift+Tab" bound and I press that combination, it seems to be passed through to the application as Shift+Tab.  For Example, in Chrome browser, it is tabbing me to the previous text area in this bug report.  When I do have it bound, the cursor no longer switches to the previous text field, but the key bind also doesn't perform the "Walk through windows (reverse)" action.
Comment 1 Christoph Feck 2010-05-28 12:50:59 UTC

*** This bug has been marked as a duplicate of bug 197548 ***