Bug 238887 - Kile crashed after cutting and subsequent text deletion with backspace
Summary: Kile crashed after cutting and subsequent text deletion with backspace
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: part (show other bugs)
Version: 0.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-26 15:04 UTC by Fabian Rost
Modified: 2010-05-31 13:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Rost 2010-05-26 15:04:13 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I did cut the text for including a figure that was near the end of a certain tex file. Some % symbols and some empty lines remained. I attempted to delete those simply using backspace, Kile crashed 3 times when I tried.
Then I cutted the text, inserted it a a different position and then deleted the lines at the end of the file. Worked fine.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#7  0x0229b94c in KateLayoutCache::viewLine (this=0xae783f8, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#8  0x02309922 in KateViewInternal::viewLineOffset (this=0xae77d08, virtualCursor=..., offset=0, keepX=false) at ../../kate/view/kateviewinternal.cpp:1351
#9  0x0230cdd5 in KateViewInternal::makeVisible (this=0xae77d08, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:663
#10 0x0230d5f0 in KateViewInternal::updateCursor (this=0xae77d08, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#11 0x0230e3eb in KateViewInternal::editEnd (this=0xae77d08, editTagLineStart=112, editTagLineEnd=112, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#12 0x022ecc69 in KateView::editEnd (this=0xac94908, editTagLineStart=112, editTagLineEnd=112, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#13 0x02254b04 in KateDocument::editEnd (this=0xae49b70) at ../../kate/document/katedocument.cpp:977
#14 0x0225bdac in KateDocument::removeText (this=0xae49b70, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#15 0x0225db7d in KateDocument::backspace (this=0xae49b70, view=0xac94908, c=...) at ../../kate/document/katedocument.cpp:2906
#16 0x023020e1 in KateViewInternal::doBackspace (this=0xae77d08) at ../../kate/view/kateviewinternal.cpp:854
#17 0x022ef66c in KateView::backspace (this=0xac94908) at ../../kate/view/kateview.cpp:2295
#18 0x022f4dd4 in KateView::qt_metacall (this=0xac94908, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbfe472f8) at ./kateview.moc:373
#19 0x0320cc9a in QMetaObject::metacall (object=0xac94908, cl=QMetaObject::ReadProperty, idx=90, argv=0xbfe472f8) at kernel/qmetaobject.cpp:237
#20 0x0321b3d5 in QMetaObject::activate (sender=0xaf07ba0, m=0x1b58d58, local_signal_index=1, argv=0xbfe472f8) at kernel/qobject.cpp:3293
#21 0x01229bd9 in QAction::triggered (this=0xaf07ba0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x0122bdcc in QAction::activate (this=0xaf07ba0, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x0122d698 in QAction::event (this=0x96e00d8, e=0x0) at kernel/qaction.cpp:1181
#24 0x06732d63 in KAction::event (this=0xaf07ba0, event=0xbfe47818) at ../../kdeui/actions/kaction.cpp:129
#25 0x012304dc in QApplicationPrivate::notify_helper (this=0x960eb10, receiver=0xaf07ba0, e=0xbfe47818) at kernel/qapplication.cpp:4300
#26 0x0123705e in QApplication::notify (this=0xbfe4870c, receiver=0xaf07ba0, e=0xbfe47818) at kernel/qapplication.cpp:3704
#27 0x0681ef2a in KApplication::notify (this=0xbfe4870c, receiver=0xaf07ba0, event=0xbfe47818) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x03207a3b in QCoreApplication::notifyInternal (this=0xbfe4870c, receiver=0xaf07ba0, event=0xbfe47818) at kernel/qcoreapplication.cpp:704
#29 0x0127234d in QCoreApplication::sendEvent (this=0x960ebbc, e=0xbfe47c94) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x960ebbc, e=0xbfe47c94) at kernel/qshortcutmap.cpp:879
#31 0x0127415e in QShortcutMap::tryShortcutEvent (this=0x960ebbc, o=0xae77d08, e=0xbfe47c94) at kernel/qshortcutmap.cpp:364
#32 0x01238e43 in QApplication::notify (this=0xbfe4870c, receiver=0xae77d08, e=0xbfe47c94) at kernel/qapplication.cpp:3746
#33 0x0681ef2a in KApplication::notify (this=0xbfe4870c, receiver=0xae77d08, event=0xbfe47c94) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x03207a3b in QCoreApplication::notifyInternal (this=0xbfe4870c, receiver=0xae77d08, event=0xbfe47c94) at kernel/qcoreapplication.cpp:704
#35 0x012312be in QCoreApplication::sendSpontaneousEvent (receiver=0xae77d08, event=0x96e00d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0xae77d08, event=0x96e00d8) at kernel/qapplication.cpp:5279
#37 0x012ead90 in QKeyMapper::sendKeyEvent (keyWidget=0xae77d08, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#38 0x012ed2f5 in QKeyMapperPrivate::translateKeyEvent (this=0x963a8a0, keyWidget=0xae77d08, event=0xbfe4835c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x012c0757 in QApplication::x11ProcessEvent (this=0xbfe4870c, event=0xbfe4835c) at kernel/qapplication_x11.cpp:3394
#40 0x012f060a in x11EventSourceDispatch (s=0x96119a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x0497f5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x049832d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x049834b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x032335d5 in QEventDispatcherGlib::processEvents (this=0x95f1c60, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x012f0135 in QGuiEventDispatcherGlib::processEvents (this=0x95f1c60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x03206059 in QEventLoop::processEvents (this=0xbfe48654, flags=) at kernel/qeventloop.cpp:149
#47 0x032064aa in QEventLoop::exec (this=0xbfe48654, flags=...) at kernel/qeventloop.cpp:201
#48 0x0320a69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x01230577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x081f7af3 in _start ()

Reported using DrKonqi
Comment 1 Michel Ludwig 2010-05-30 23:16:07 UTC
Forwarding to KatePart. This could be a duplicate of 200796.
Comment 2 Dominik Haumann 2010-05-31 13:51:57 UTC
fixed in kde 4.4.4

*** This bug has been marked as a duplicate of bug 226409 ***