Bug 238394 - Kile crashes when cuting a paragraph and then pressing backspace
Summary: Kile crashes when cuting a paragraph and then pressing backspace
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: part (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-21 14:20 UTC by Sebastian Geiger
Modified: 2010-05-22 23:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Geiger 2010-05-21 14:20:27 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I used Ctrl+X to cut out the last paragraph in a file and then pressed backspace multiple times to remove the trailing newlines. then kile crashed

The crash can be reproduced every time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f9ba6921e2a in KateLayoutCache::viewLine (this=0x457a5f0, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007f9ba69849b3 in KateViewInternal::viewLineOffset (this=0x45798a0, virtualCursor=..., offset=0, keepX=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:1351
#8  0x00007f9ba69878ab in KateViewInternal::makeVisible (this=0x45798a0, c=..., endCol=-1, force=false, center=<value optimized out>, calledExternally=false)
    at ../../kate/view/kateviewinternal.cpp:663
#9  0x00007f9ba6988009 in KateViewInternal::updateCursor (this=0x45798a0, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007f9ba6988c39 in KateViewInternal::editEnd (this=0x45798a0, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007f9ba68e0d11 in KateDocument::editEnd (this=0x456a370) at ../../kate/document/katedocument.cpp:977
#12 0x00007f9ba68e7aa6 in KateDocument::removeText (this=0x456a370, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:821
#13 0x00007f9ba68e961a in KateDocument::backspace (this=0x456a370, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2906
#14 0x00007f9ba696ea5c in KateView::backspace (this=0x4570590) at ../../kate/view/kateview.cpp:2295
#15 0x00007f9ba6973bbd in KateView::qt_metacall (this=0x4570590, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff36327140) at ./kateview.moc:373
#16 0x00007f9bb83afe3f in QMetaObject::activate (sender=0x4679420, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f9bb8d0b032 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f9bb8d0d0ab in QAction::activate (this=0x4679420, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007f9bb8d0e9b7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007f9bb9ba1f3d in KAction::event (this=0x0, event=0x7fff363277b0) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007f9bb8d1122c in QApplicationPrivate::notify_helper (this=0xf437c0, receiver=0x4679420, e=0x7fff363277b0) at kernel/qapplication.cpp:4300
#22 0x00007f9bb8d176fb in QApplication::notify (this=0x7fff36328d60, receiver=0x4679420, e=0x7fff363277b0) at kernel/qapplication.cpp:4183
#23 0x00007f9bb9c77526 in KApplication::notify (this=0x7fff36328d60, receiver=0x4679420, event=0x7fff363277b0) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f9bb839d06c in QCoreApplication::notifyInternal (this=0x7fff36328d60, receiver=0x4679420, event=0x7fff363277b0) at kernel/qcoreapplication.cpp:704
#25 0x00007f9bb8d4ce86 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff36327db0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff36327db0) at kernel/qshortcutmap.cpp:879
#27 0x00007f9bb8d4ec97 in QShortcutMap::tryShortcutEvent (this=0xf438e8, o=<value optimized out>, e=0x7fff36327db0) at kernel/qshortcutmap.cpp:364
#28 0x00007f9bb8d19268 in QApplication::notify (this=0x7fff36328d60, receiver=0x45798a0, e=0x7fff36327db0) at kernel/qapplication.cpp:3746
#29 0x00007f9bb9c77526 in KApplication::notify (this=0x7fff36328d60, receiver=0x45798a0, event=0x7fff36327db0) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f9bb839d06c in QCoreApplication::notifyInternal (this=0x7fff36328d60, receiver=0x45798a0, event=0x7fff36327db0) at kernel/qcoreapplication.cpp:704
#31 0x00007f9bb8dbc16a in QKeyMapper::sendKeyEvent (keyWidget=0x45798a0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f9bb8dbe6f0 in QKeyMapperPrivate::translateKeyEvent (this=0xf814c0, keyWidget=0x45798a0, event=<value optimized out>, grab=32) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f9bb8d95904 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff36328980) at kernel/qapplication_x11.cpp:3394
#34 0x00007f9bb8dc1882 in x11EventSourceDispatch (s=0xf47010, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f9bb43d08c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007f9bb43d4748 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007f9bb43d48fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007f9bb83c6513 in QEventDispatcherGlib::processEvents (this=0xf1e570, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007f9bb8dc146e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f9bb839b992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f9bb839bd6c in QEventLoop::exec (this=0x7fff36328cb0, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f9bb839faab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00000000005f21f2 in _start ()

Reported using DrKonqi
Comment 1 Michel Ludwig 2010-05-22 16:44:03 UTC
This is a problem with KatePart, which has most likely been fixed already for KDE 4.5.
Comment 2 Dominik Haumann 2010-05-22 23:49:07 UTC
Fixed in KDE 4.5.

*** This bug has been marked as a duplicate of bug 226409 ***