Bug 238177 - The nepomuk annotator "resorceeditor" crashed when started
Summary: The nepomuk annotator "resorceeditor" crashed when started
Status: RESOLVED NOT A BUG
Alias: None
Product: nepomuk
Classification: Unclassified
Component: general (show other bugs)
Version: 4.4
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-19 15:02 UTC by sfietkonstantin
Modified: 2012-05-26 01:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sfietkonstantin 2010-05-19 15:02:13 UTC
Application: resourceeditor (0.1)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.4-desktop-1mnb i686
Distribution: "Mandriva Linux 2010.1"

-- Information about the crash:
The resource editor crashed when started. I saw briefly a window with my nepomuk metadata, and the crash happens.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: ResourceEditor (resourceeditor), signal: Segmentation fault
[KCrash Handler]
#6  QModelIndex (this=0x8911a78, child=...) at ../../src/corelib/kernel/qabstractitemmodel.h:65
#7  QSortFilterProxyModel::parent (this=0x8911a78, child=...) at itemviews/qsortfilterproxymodel.cpp:1619
#8  0xb675de23 in QModelIndex::parent (this=0x5) at /usr/lib/qt4/include/QtCore/qabstractitemmodel.h:389
#9  0xb67e10b8 in KCategorizedView::Private::categoryForIndex (this=0x89119c0, index=...) at /usr/src/debug/kdelibs-4.4.3/kdeui/itemviews/kcategorizedview.cpp:372
#10 0xb67e7442 in KCategorizedView::visualRect (this=0x8947370, index=...) at /usr/src/debug/kdelibs-4.4.3/kdeui/itemviews/kcategorizedview.cpp:603
#11 0xb67e17bb in KCategorizedView::leaveEvent (this=0x8947370, event=0xbf827a5c) at /usr/src/debug/kdelibs-4.4.3/kdeui/itemviews/kcategorizedview.cpp:1006
#12 0xb6e67671 in QWidget::event (this=0x8947370, event=0xbf827a5c) at kernel/qwidget.cpp:8132
#13 0xb7273f05 in QFrame::event (this=0x8947370, e=0xbf827a5c) at widgets/qframe.cpp:557
#14 0xb7311644 in QAbstractScrollArea::event (this=0x8947370, e=0xbf827a5c) at widgets/qabstractscrollarea.cpp:989
#15 0xb73c224c in QAbstractItemView::event (this=0x8947370, event=0xbf827a5c) at itemviews/qabstractitemview.cpp:1546
#16 0xb73de783 in QListView::event (this=0x8947370, e=0xbf827a5c) at itemviews/qlistview.cpp:1624
#17 0xb6e06f1c in QApplicationPrivate::notify_helper (this=0x87f3bc8, receiver=0x8947370, e=0xbf827a5c) at kernel/qapplication.cpp:4300
#18 0xb6e0dde8 in QApplication::notify (this=0x8947370, receiver=0x8947370, e=0xbf827a5c) at kernel/qapplication.cpp:4265
#19 0xb6809618 in KApplication::notify (this=0xbf828420, receiver=0x8947370, event=0xbf827a5c) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:302
#20 0xb652ba9e in QCoreApplication::notifyInternal (this=0xbf828420, receiver=0x8947370, event=0xbf827a5c) at kernel/qcoreapplication.cpp:704
#21 0xb6e0cc41 in sendEvent (enter=0x898e320, leave=0x8927de0) at ../../src/corelib/kernel/qcoreapplication.h:215
#22 QApplicationPrivate::dispatchEnterLeave (enter=0x898e320, leave=0x8927de0) at kernel/qapplication.cpp:2615
#23 0xb6e0d802 in QApplicationPrivate::sendMouseEvent (receiver=0x898e320, event=0xbf827b90, alienWidget=0x898e320, nativeWidget=0xbf8283fc, buttonDown=0xb776c038, lastMouseReceiver=..., spontaneous=
    true) at kernel/qapplication.cpp:2945
#24 0xb6e9b13a in QETWidget::translateMouseEvent (this=0xbf8283fc, event=0xbf82809c) at kernel/qapplication_x11.cpp:4368
#25 0xb6e9a704 in QApplication::x11ProcessEvent (this=0xbf828420, event=0xbf82809c) at kernel/qapplication_x11.cpp:3379
#26 0xb6ec8088 in x11EventSourceDispatch (s=0x87f6df8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#27 0xb5df7cbe in g_main_dispatch (context=0x87f5ea0) at gmain.c:1960
#28 IA__g_main_context_dispatch (context=0x87f5ea0) at gmain.c:2513
#29 0xb5dfb9f8 in g_main_context_iterate (context=0x87f5ea0, block=<value optimized out>, dispatch=1, self=0x87f3e30) at gmain.c:2591
#30 0xb5dfbb9e in IA__g_main_context_iteration (context=0x87f5ea0, may_block=1) at gmain.c:2654
#31 0xb65585c1 in QEventDispatcherGlib::processEvents (this=0x87f3b68, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#32 0xb6ec7bda in QGuiEventDispatcherGlib::processEvents (this=0x87f3b68, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb652a0fd in QEventLoop::processEvents (this=0xbf828354, flags=) at kernel/qeventloop.cpp:149
#34 0xb652a549 in QEventLoop::exec (this=0xbf828354, flags=...) at kernel/qeventloop.cpp:201
#35 0xb652e6d0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#36 0xb6e06fc4 in QApplication::exec () at kernel/qapplication.cpp:3579
#37 0x08049798 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-06-01 12:50:33 UTC
Thanks for the bug report! Looks like it might be related to bug 237479.
Comment 2 Vishesh Handa 2012-05-26 01:59:04 UTC
Too old. 

Plus, AFAIK, the resourceditor isn't ready to be released.