Bug 237966 - KWrite Crashes upon deleting text block
Summary: KWrite Crashes upon deleting text block
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-17 21:01 UTC by Bucky
Modified: 2010-05-17 23:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bucky 2010-05-17 21:01:17 UTC
Application: kwrite (4.4.2 (KDE 4.4.2))
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.11-99.fc12.i686.PAE i686
Distribution: "Fedora release 12 (Constantine)"

-- Information about the crash:
Selected a bunch of text, from about the middle to the end, and pressed the Backspace button. KWrite crashed.

Could not trigger it again.

 -- Backtrace:
Application: KWrite (kwrite), signal: Segmentation fault
[KCrash Handler]
#6  0x0321fa36 in KateLineLayout::viewLineCount (this=0x0) at /usr/src/debug/kdelibs-4.4.2/kate/render/katelinelayout.cpp:173
#7  0x0321caa3 in KateLayoutCache::lastViewLine (this=0xa1f2820, realLine=49) at /usr/src/debug/kdelibs-4.4.2/kate/render/katelayoutcache.cpp:469
#8  0x03283e0d in KateViewInternal::viewLineOffset (this=0xa0772d0, virtualCursor=..., offset=45, keepX=false) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:1359
#9  0x032872b5 in KateViewInternal::makeVisible (this=0xa0772d0, c=..., endCol=25, force=false, center=false, calledExternally=false)
    at /usr/src/debug/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:666
#10 0x03287b40 in KateViewInternal::updateCursor (this=0xa0772d0, newCursor=..., force=true, center=false, calledExternally=false) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:1914
#11 0x03287c3c in KateViewInternal::editEnd (this=0xa0772d0, editTagLineStart=49, editTagLineEnd=49, tagFrom=true) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:3399
#12 0x03268d6a in KateView::editEnd (this=0xa0b6e00, editTagLineStart=49, editTagLineEnd=49, tagFrom=true) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateview.cpp:1602
#13 0x031d8554 in KateDocument::editEnd (this=0xa077680) at /usr/src/debug/kdelibs-4.4.2/kate/document/katedocument.cpp:977
#14 0x0327030e in KateView::removeSelectedText (this=0xa0b6e00) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateview.cpp:1774
#15 0x031e17db in KateDocument::backspace (this=0xa077680, view=0xa0b6e00, c=...) at /usr/src/debug/kdelibs-4.4.2/kate/document/katedocument.cpp:2830
#16 0x0327d3b2 in KateViewInternal::doBackspace (this=0xa0772d0) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:854
#17 0x0326be3c in KateView::backspace (this=0xa0b6e00) at /usr/src/debug/kdelibs-4.4.2/kate/view/kateview.cpp:2295
#18 0x03270b94 in KateView::qt_metacall (this=0xa0b6e00, _c=InvokeMetaMethod, _id=51, _a=0xbfe5c758) at /usr/src/debug/kdelibs-4.4.2/i686-redhat-linux-gnu/kate/kateview.moc:373
#19 0x005ec5db in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x005fb4af in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#21 0x010cb9ba in QAction::triggered (this=0xa05a2b8, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x010cd34c in QAction::activate (this=0xa05a2b8, event=Trigger) at kernel/qaction.cpp:1255
#23 0x010ce508 in QAction::event (this=0xa05a2b8, e=0xbfe5cc78) at kernel/qaction.cpp:1181
#24 0x06d2b4f4 in KAction::event (this=0xa05a2b8, event=0xbfe5cc78) at /usr/src/debug/kdelibs-4.4.2/kdeui/actions/kaction.cpp:129
#25 0x010d11cc in QApplicationPrivate::notify_helper (this=0x9a01398, receiver=0xa05a2b8, e=0xbfe5cc78) at kernel/qapplication.cpp:4300
#26 0x010d79f6 in QApplication::notify (this=0xbfe5db58, receiver=0xa05a2b8, e=0xbfe5cc78) at kernel/qapplication.cpp:3704
#27 0x06dfb7cb in KApplication::notify (this=0xbfe5db58, receiver=0xa05a2b8, event=0xbfe5cc78) at /usr/src/debug/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:302
#28 0x005e7c03 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0x01109d9d in sendEvent (this=0x9a01444, e=0xbfe5d0f4) at ../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x9a01444, e=0xbfe5d0f4) at kernel/qshortcutmap.cpp:879
#31 0x0110bce7 in QShortcutMap::tryShortcutEvent (this=0x9a01444, o=0xa0772d0, e=0xbfe5d0f4) at kernel/qshortcutmap.cpp:364
#32 0x010d95a2 in QApplication::notify (this=0xbfe5db58, receiver=0xa0772d0, e=0xbfe5d0f4) at kernel/qapplication.cpp:3746
#33 0x06dfb7cb in KApplication::notify (this=0xbfe5db58, receiver=0xa0772d0, event=0xbfe5d0f4) at /usr/src/debug/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:302
#34 0x005e7c03 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x010d1f0f in sendSpontaneousEvent (receiver=0xa0772d0, event=0xbfe5d0f4) at ../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0xa0772d0, event=0xbfe5d0f4) at kernel/qapplication.cpp:5279
#37 0x0117a39e in QKeyMapper::sendKeyEvent (keyWidget=0xa0772d0, grab=false, type=KeyPress, code=16777219, modifiers=..., text=..., autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=
    65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#38 0x0117c749 in QKeyMapperPrivate::translateKeyEvent (this=0x9a2ba48, keyWidget=0xa0772d0, event=0xbfe5d7bc, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x01152d57 in QApplication::x11ProcessEvent (this=0xbfe5db58, event=0xbfe5d7bc) at kernel/qapplication_x11.cpp:3399
#40 0x0117f99a in x11EventSourceDispatch (s=0x9a045a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x00ea0fb8 in g_main_dispatch (context=0x9a03890) at gmain.c:1960
#42 IA__g_main_context_dispatch (context=0x9a03890) at gmain.c:2513
#43 0x00ea48e8 in g_main_context_iterate (context=0xd67eb0, block=1, dispatch=1, self=0x9a015e0) at gmain.c:2591
#44 0x00ea4a14 in IA__g_main_context_iteration (context=0x9a03890, may_block=1) at gmain.c:2654
#45 0x0060fe46 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x0117f586 in QGuiEventDispatcherGlib::processEvents (this=0x99eb370, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x005e62da in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x005e661a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x005e8ce7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#50 0x010d1278 in QApplication::exec () at kernel/qapplication.cpp:3579
#51 0x0093f723 in kdemain (argc=2, argv=0xbfe5deb4) at /usr/src/debug/kdebase-4.4.2/apps/kwrite/kwritemain.cpp:691
#52 0x0804864c in main (argc=2, argv=0xbfe5deb4) at /usr/src/debug/kdebase-4.4.2/i686-redhat-linux-gnu/apps/kwrite/kwrite_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-05-17 23:06:17 UTC

*** This bug has been marked as a duplicate of bug 226409 ***