Bug 237943 - incomplete sources incompatible versions build fails
Summary: incomplete sources incompatible versions build fails
Status: RESOLVED WORKSFORME
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2010-05-17 16:44 UTC by Jeff Barry
Modified: 2018-10-27 02:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Barry 2010-05-17 16:44:17 UTC
Version:           latest kde 443 (using KDE 4.4.3)
Compiler:          cc (GCC) 4.3.3 
OS:                Linux
Installed from:    Compiled From Sources

Hi,

Is is too much to ask that when you release a version of KDE that (1) you include *ALL* of the sources needed for a complete build, (2) verify that those sources are the proper versions, (3) that you verify that the build works on a CLEAN machine which is not full of some developer's unknown versions of God-knows-what components, and (4) that you follow your own, public build instructions when verifying the build works?

I've been trying to build KDE 4.4.3 from scratch.  I downloaded the files you specified and followed the various versions of HOW-TO-BUILD-KDE notes which can be found under the KDE website.

This has been an exercise in total frustration.  The files you give for building KDE are missing things all over the place, and when we go and get them its a pure shot in the dark as to whether we'll get a compatible version.  I've finally given up trying.

Components which should have been included in the 4.4.3 file set but which are not: Qt-kde, soprano, phonon, attica, akonadi, and probably others which I didn't get to yet.  I had to dig sources out of other places like kdesupport/ and other websites.  Why is kdesupport not part of the advertised set of downloads, for example?

Developers sometimes forget that not everyone is a developer.  There ARE people like me out here who want to use your product but do not have years of experience working with your product, so we neither know the tricks nor know who to contact for new tricks.

Having just one person verify the files, versions, instructions, and the build BEFORE you release would save countless hours for people all over the world who are trying to use your product.

Jeff Barry
Comment 1 Christoph Feck 2010-05-19 00:10:12 UTC
> Why is kdesupport not part of the advertised set of downloads, for example?

kdesupport is not part of a KDE release, because kdesupport components have their own release cycle (just like extragear). I am reassigning to KDE web team to decide if there need to be document improvements in mentioned HOWTO files.
Comment 2 Ingo Malchow 2012-12-13 16:03:21 UTC
What howto files is this referring to? AFAIK all such documentation should be on techbase, which is a wiki and free to edit for anyone to add missing/wrong information
Comment 3 Andrew Crouthamel 2018-09-24 02:10:54 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Andrew Crouthamel 2018-10-27 02:15:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!