Bug 237817 - Font with german special sign cannot be read under KDE 4.x
Summary: Font with german special sign cannot be read under KDE 4.x
Status: RESOLVED DUPLICATE of bug 165044
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-16 13:56 UTC by EgLe
Modified: 2015-05-03 11:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Testfile (Directory and Textfile inside) (322 bytes, application/zip)
2010-05-17 18:38 UTC, EgLe
Details
Directory after decrunch (55.55 KB, image/png)
2010-08-14 16:01 UTC, EgLe
Details
with KDE-Tools you can not change into the directoy, or change the Name or delete the directory (107.98 KB, image/png)
2010-08-14 16:05 UTC, EgLe
Details
So it look like with Nautilus (Gnome FileManager) (72.20 KB, image/png)
2010-08-14 16:10 UTC, EgLe
Details
Inti the Directory with Nautilus (66.08 KB, image/png)
2010-08-14 16:14 UTC, EgLe
Details
rename the File with Nautilus (65.67 KB, image/png)
2010-08-14 16:18 UTC, EgLe
Details
Now i can open the File under KDE 4.x (49.05 KB, image/png)
2010-08-14 16:24 UTC, EgLe
Details
nautlius installation on KDE as workaround... (244.99 KB, image/png)
2010-08-14 16:48 UTC, EgLe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description EgLe 2010-05-16 13:56:23 UTC
Version:            (using KDE 4.4.3)
OS:                Linux
Installed from:    Unspecified Linux

Hallo,
ich schreibe das hier auf Deutsch da ich leider kein (kaum) Englisch kann.
Evtl. findet sich ja jemand der dies Übersetzen würde?

Folgendes Problem ergibt sich unter sämtliche KDE4,x Versionen!

wurden unter Windows Verzeichnisse oder Dateinamen mit Sonderzeichen oder deutschen Umlaute versehen
kommt es sehr oft unter KDE vor das diese Dateien oder Verzeichnisse nicht gelesen, bzw. editiert werden können.

Obwohl das komplette System auf UTF8 eingestellt ist.

Sehr oft findet man dann als Lösungsvorschlag das man sich eben diese Dateien oder Verzeichnisse unter der Konsole
umbenennen soll um mittels KDE wieder zugriff zu erlangen.
Oder man sollte sich eben als Zeichencodierung das iso 8859-15 installieren bzw. auswählen.

Leider hilft dieses Problem ja nur als Workaround...

Unter KDE3.x wie auch unter Gnome ist es kein Problem solche Dateien und Verzeichnisse trotz der Sonderzeichen
auszuwählen, auszuführen und auch weiter zu verarbeiten.

Das Problem betrifft sämtliche KDE-Tools egal ob es sich um, Amarok, Krusader, Dolphin oder K3B handelt,
alle diese KDE-Tools können die genannten Daten nicht verwenden bzw. lesen.

Zur Zeit helfe ich mir damit das ich zusätzlich noch den MidnightCommander und auch Nautilus unter meinem KDE am laufen haben um bei solchen Problemdateien Verzeichnisse (auch per FTP) zugriff zu erhalten.

Da dies unter KDE 3.x genauso gut ging wie unter Gnome (nautilus) gehe ich davon aus das es sich um ein KDE4 Bug handelt.

Seltsamerweise scheint es aber die meisten KDE User nicht zu stören,
zumindest mir ist es seit erscheinen von KDE4 (Kubuntu 8.10) aufgefallen und bekannt.

http://forum.kubuntu-de.org/index.php?topic=11941.0
Comment 1 Hans-Rudi Denzler 2010-05-16 17:10:59 UTC
In openSUSE 11.2, 4.4.3 habe ich Dein Problem nicht verifizieren können. Ich habe in XP eine Datei "Üben üben" mit dem Inhalt "Üben üben" auf einem NTFS USB-Stick erstellt (ISO 8859-1). Mit dolphin, kwrite, gvim, okteta ist alles OK.
Comment 2 EgLe 2010-05-17 18:38:19 UTC
Created attachment 43670 [details]
Testfile (Directory and Textfile inside)

Hallo,

hier habe ich mal unter einem Windows 7 ein Verzeichnis erstellt mit Umlaute und innerhalb eine Textdatei geschreiben, alles mit enthaltene Umlaute.

Das ganze dann als Zip-Datei gepackt und unter Linux (mittels Krusader) entpackt.
Das Verzeichniss läßt sich nicht öffnen und kann unter KDE-Tools nicht verarbeitet werden. Auf dem gleichen Rechner ist auch die Gnomeaplikation "Nautilis) installiert, mit diesem Dateimanager der auch unter KDE aus der Konsole herraus gestartet wird habe ich Problemlos zugriff.
Comment 3 Hans-Rudi Denzler 2010-05-17 22:27:00 UTC
> gvim ?bersicht/*  funktioniert:
Hallo,

heute ist es überfüllt, dies ist ganz ärgerich.

> kwrite ?bersicht/* funktioniert nicht.
Mit dolphin lässt sicht ?bersicht nicht öffnen.
Auf der Konsole und mit wildcards (? *) funktioniert es.

> cd ?bersicht
> rm *
> cd ..
> rmdir ?bersicht
Comment 4 Hans-Rudi Denzler 2010-05-18 10:09:53 UTC
Comment #2:
If you extract the attachment in dolphin with ark the newly created folder "?bersicht" cannot be opened. Now you can create a folder "Übersicht". Copy both folders to clipboard:
> echo $(qdbus org.kde.klipper /klipper getClipboardContents)
file:///home/hrd/Downloads/%C3%9Cbersicht file:///home/hrd/Downloads/%EF%BF%BDbersicht

%C3%9C: UTF-8 Ü
%EF%BF%BD: illegal characters are converted to EF BF BD (-> Google)
Comment 5 EgLe 2010-05-18 18:45:29 UTC
Hallo,

vielen Dank für eure Hinweise bzw. Tipps wie man die Datei öffnen kann,
doch leider weiß ich das auch, ich schreib diesen Beitrag nur weil mir
selbst dieser KDE-Bug seit dem ersten erscheinen von KDE4,x aufgefallen ist.

Und ich in jedem Forum und / oder per Mail immer nur "workarounds" bekommen habe ;-)

Das Problem ist aber leider etwas größer...
Denn durch diesen Bug der sich durchs komplette KDE4.x zieht bedeutet dies das
z.B. Verzeichnisse in FTP-Server ggf. nicht geöffnet werden können.
(ich verwende dazu z.B. schon seit Langem wieder den MidnightCommander oder Nautilius)

Oder wenn Solche Dinge auf einer DVD/CD enthalten sind, streikt z.B. auch das K3B, dies ist mir z.B. mit der Amithlon-DVD geschehen als ich diese Kopieren wollte.

Bei MP3 ist es auch ganz Lustig, Amarok ignoriert natürlich solche Daten usw.
Ist also als KDE4.x User schon als Ärgerlich, vor allem wenn  man weiß das dies
unter KDE3.x kein Problem darstellt, genauso wie unter Gnome ;-)

Als weiteres Beispiel, kann ich auch nennen das ich eine MP3 mit umlauten hatte,
Konnte diese z.B. aus dem Dolphin oder Krusader nicht ausführen obwohl der VLC
als Standartplayer aktiviert ist.

Klicke ich die selbe Datei vom Dateimanager Nautilus an, startet mir der VLC
und spielt das selbe File ab, wo er zuvor noch selbst gemeckert hatte als man es mit einem KDE-Tool anklickte.

Zumindest habe ich meinen Beitrag geleistet,
ob es behoben wird oder nicht wird sich ja in Zukunft zeigen?
Comment 6 EgLe 2010-08-07 14:16:23 UTC
Hello,

in KDE 4.4.5 is this bug always include...
Comment 7 Albert Astals Cid 2010-08-10 20:23:46 UTC
You did two big mistakes:
 * Write the bug report in german
 * Assign the bug report to the kde-www product

Until you fix both of them it's really difficult anyone will be able of helping you
Comment 8 Vamp898 2010-08-11 12:47:50 UTC
Deutsch :: Englisch

Dies ist kein Bug in KDE, GNU/Linux oder sonst wo sondern ein simpler Fehler der darin besteht das Windows für die Zeichenkodierung einen Microsoft eigenen statt dem offiziellen Standard benutzt. Du hast wohl kaum eine andere Wahl als den Zeichensatz in Windows zu ändern.

::

This is no Bug in KDE, GNU/Linux or whatever, its just Windows´s fault. Windows uses the Microsoft own character encoding instead of the official standard. Your only real chance is to change the char-enc in Windows
Comment 9 EgLe 2010-08-14 08:49:05 UTC
(In reply to comment #8)
> This is no Bug in KDE, GNU/Linux or whatever, its just Windows´s fault. Windows
> uses the Microsoft own character encoding instead of the official standard.
> Your only real chance is to change the char-enc in Windows


I see you are very clever....
so then tell me this:
why it is working, under the Terminal, Gnome, and KDE3.x, but not under KDE4.x???
Yes Problem come from Microsoft, the hate Linux, but the hate the most only KDE4.x and so this is an atack only to KDE4.x....

I think what you tell me is a very big terrible Bullshit
Comment 10 Vamp898 2010-08-14 12:02:16 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > This is no Bug in KDE, GNU/Linux or whatever, its just Windows´s fault. Windows
> > uses the Microsoft own character encoding instead of the official standard.
> > Your only real chance is to change the char-enc in Windows
> 
> 
> I see you are very clever....
> so then tell me this:
> why it is working, under the Terminal, Gnome, and KDE3.x, but not under
> KDE4.x???
> Yes Problem come from Microsoft, the hate Linux, but the hate the most only
> KDE4.x and so this is an atack only to KDE4.x....
> 
> I think what you tell me is a very big terrible Bullshit

I also have the problem in GNOME/TTY/Whatever too so either you´re just not clever enough to file a proper bug (and i think you already proofed it)

The test-files you attached are also not readable for me in KDE, GNOME, XFCE, TTY and whatever but readable by WinE CMD

So the wine CMD, using the Windows standard can read the file and no of my terminals using UTF-8 can not read the files.

If i change the char-enc in my System i can read them with every Terminal.

So the problem is just that you´re neither able to setup your system correct nor you want to solve this problem. You want to get proofed that its KDE fault and not your!

But sry man this is your problem and not related to KDE in any way. Dont blame KDE for your own disability. Im sorry that i have to say it in this way but when you start to get personal im gonna too.

And it seems like you dont have the technical skill to get personal to others...

You´re just a windows hating fanboy but to tell you one thing. Windows is the best operating system for you. You proofed to everyone hear that your just to stupid to use a other OS.

And you better shouln´t reply to this thread cause you´re chances to make something better are less than 1%. This bug is not KDE related in any way and should be closed.

That it worked/works in KDE3/GNOME is Ubuntu related and not GNOME/KDE3 cause, as i said, if you compile them by source or use a real distribution they also dont work cause its a setup issue.

So write your holy master mark Shuttleworth that you hate it that he hates KDE and so dont take care about Kubuntu at all.

Your problem is setup related and not KDE. If you dont believe im excited to make a screencast where i show how GNOME/KDE/XFCE and TTY failes to show this symbols and how it works in KDE4/KDE3/XFCE/GNOME if you have a proper setup system.

Accept your own incapability and close this bug
Comment 11 EgLe 2010-08-14 16:01:12 UTC
Created attachment 50536 [details]
Directory after decrunch

After decrunch looks terribe, okay its from the Windows font, i now that.
Comment 12 EgLe 2010-08-14 16:05:04 UTC
Created attachment 50537 [details]
with KDE-Tools you can not change into the directoy, or change the Name or delete the directory

with KDE-Tools you can not change into the directoy, or change the Name
or you cannot delet them...
Comment 13 EgLe 2010-08-14 16:10:27 UTC
Created attachment 50538 [details]
So it look like with Nautilus (Gnome FileManager)

So it looks under Nautilus (Gnome File-Manager),
okay the Fonts look Terrible, but you can move into the Directory
that you can see on the next attachment.

and with Nautilus you can rename the directory, delete and more....
If this going on your Gnome not, so your Gnome Nautilus is damage..

The same is it possible under Krusader with KDE3.x
Comment 14 EgLe 2010-08-14 16:14:41 UTC
Created attachment 50539 [details]
Inti the Directory with Nautilus

Here i am into the Directoy with nautlilus...
Comment 15 EgLe 2010-08-14 16:18:52 UTC
Created attachment 50540 [details]
rename the File with Nautilus

Here i rename the File with nautilus (gnome file-manager) this is not possible
under KDE 4.x with KDE 3.x is it possible too...
Comment 16 EgLe 2010-08-14 16:24:57 UTC
Created attachment 50541 [details]
Now i can open the File under KDE 4.x

So now i can open the File under KDE 4.x after i edit all files with 
the nautilus Gnome (file-manager)...

BTW. under KDE 3.x is this also possible vs. Gnome Nautlius.

So i am sure this is a KDE 4.x Bug....
Comment 17 EgLe 2010-08-14 16:29:13 UTC
And if download a zip file from Mp3 that was create under Windows with special
fonts, is the same Problem...

Under Gnome and KDE 3.x the Filename looks terrible but you can play the files
and you can rename the files that they going to utf-8.

But under KDE 4.x is the same Problem as the textfile you can not
play, rename or delete so Mediafiles...

Also this is an KDE 4.x Bug and this Bug is in all KDE 4.x versions!
Comment 18 EgLe 2010-08-14 16:48:24 UTC
Created attachment 50550 [details]
nautlius installation on KDE as workaround...

nautlius installation on KDE as workaround...
Comment 19 Hans-Rudi Denzler 2010-08-14 17:43:27 UTC
(In reply to comment #4)
> If you extract the attachment (comment #2) in dolphin with ark the newly created folder
> "?bersicht" cannot be opened. Now you can create a folder "Übersicht". Copy
> both folders to clipboard:
> > echo $(qdbus org.kde.klipper /klipper getClipboardContents)
> file:///home/hrd/Downloads/%C3%9Cbersicht
> file:///home/hrd/Downloads/%EF%BF%BDbersicht
> 
> %C3%9C: UTF-8 Ü
> %EF%BF%BD: illegal characters are converted to EF BF BD (-> Google)

In short it would be nice if file/folder names with "illegal characters" could be renamed in dolphin.
Comment 20 Vamp898 2010-08-14 18:05:08 UTC
The easiest way to fix this problem is to watch in gconf which Ubuntu Settings causes Nautilus to work with that. The Vanilla/Unpached/Original Nautilus doesnt work with extra setup.

In my KDE 4.5 installation it works with Dolphin if i set it up and it doesnt work with Nautilus if i dont set it up

i still dont understand what the setup of the system have to do with KDE.
Comment 21 Will Entriken 2015-01-27 22:30:44 UTC
Can anyone confirm this is still an issue?
Comment 22 Christoph Feck 2015-05-03 11:22:13 UTC

*** This bug has been marked as a duplicate of bug 165044 ***