Bug 237492 - Grayscale TIFF display broken
Summary: Grayscale TIFF display broken
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Core (show other bugs)
Version: 1.2.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-13 13:22 UTC by Michal Thoma
Modified: 2012-06-27 10:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Thoma 2010-05-13 13:22:18 UTC
Version:           1.2 (using KDE 4.4.2)
OS:                Linux
Installed from:    Ubuntu Packages

While trying to display grayscale TIFF  (1 color channel, no RGB), image preview is broken. Surprisingly thumbanil is created correctly. 

The sample image saved in Adobe Photoshop CS2 is as here:

http://michal.thoma.cz/digikam/grayscale_nocompression_nolayers.tif
Comment 1 Michal Thoma 2010-05-13 13:36:21 UTC
One important new finding - it seems that the display is broken only when image has color profile. The grayscale TIFF without color profile is displayed correctly.
Comment 2 caulier.gilles 2010-05-14 07:47:53 UTC
*** Bug 237494 has been marked as a duplicate of this bug. ***
Comment 3 Michal Thoma 2010-11-23 15:38:56 UTC
This bug is apparently not duplicate as it still exist in 1.6.0. Maybe it's related to the Bug 237494 though definitely not repaired still.
Comment 4 Michal Thoma 2010-12-27 14:05:54 UTC
The bug is still there in 1.7.0

It's not only TIFF - all grayscale (one color channel) images are affected.

So to repeat what is known 

1. Take image in grayscale mode (tiff, jpeg or whatever)
2. Turn color management on.
3. Open in Digikam - Thumbnail is created well, displaying image is broken. Same with edit.

Surprisingly image can be processed through BQM with no problem. Only mode is changed from grayscale to RGB...
Comment 5 Marcel Wiesweg 2011-01-26 12:38:16 UTC
This was fixed recently. It was discussed in another bug entry which I dont find anymore. Color management code for grayscale was broken.