Bug 237271 - dolphin scroll bars - resolution too high per ( viewed area | content )
Summary: dolphin scroll bars - resolution too high per ( viewed area | content )
Status: RESOLVED DUPLICATE of bug 233163
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-11 18:00 UTC by Kenny Kruger
Modified: 2010-05-12 03:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Dolphin's Scroll Bars - Resolution Size (92.27 KB, image/jpeg)
2010-05-11 18:03 UTC, Kenny Kruger
Details
Dolphin's Scroll Bars - Directory View Comparison (100.08 KB, image/jpeg)
2010-05-11 20:04 UTC, Kenny Kruger
Details
Dolphin - Scroll Bars fixed in KDE 4.4.3 (98.10 KB, image/jpeg)
2010-05-12 03:53 UTC, Kenny Kruger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenny Kruger 2010-05-11 18:00:13 UTC
Version:           1.4 (using 4.4.2 (KDE 4.4.2), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32-22-generic-pae

Dolphin's scroll bars always appear too small (high resolution per scroll). 
The scroll bar resolution does change depending on your zoom, but I think this resolution is only based on the zoom level, not the content being viewed.

I will attach a screenshot illustrating this.
Comment 1 Kenny Kruger 2010-05-11 18:03:34 UTC
Created attachment 43479 [details]
Dolphin's Scroll Bars - Resolution Size

View the size of the scroll bars within dolphin in the image.
You can start to see the "U" Group and there is also a "V" Group after that, but then that is it. So below the 'Pictures/Projects/Public' icons there are 2 more rows.

Also note the Zoom Level which will change the resolution.

I believe this resolution should be based on the zoom level and the amount of content being shown, not only the zoom level. Or perhaps it already is but the algorithm is a bit off.
Comment 2 Kenny Kruger 2010-05-11 20:04:39 UTC
Created attachment 43484 [details]
Dolphin's Scroll Bars - Directory View Comparison

here is a snapshot to compare the dramatic difference (or similarity) between the displayed content of a window and the scroll bars.

The left side has 2 more rows of which are not shown and the right side has 25 rows (each with unique group names) and yet the scroll bar resolution is equal between the two sides.
Comment 3 Peter Penz 2010-05-11 21:32:42 UTC
Thanks for the report. This has been fixed for KDE SC 4.4.3.

*** This bug has been marked as a duplicate of bug 233163 ***
Comment 4 Kenny Kruger 2010-05-12 03:53:29 UTC
Created attachment 43500 [details]
Dolphin - Scroll Bars fixed in KDE 4.4.3

Confirmation that this has been fixed.