Bug 237260 - shortcuts for switching windows don't work with multihead
Summary: shortcuts for switching windows don't work with multihead
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: multi-screen (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 274369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-11 17:15 UTC by RSB
Modified: 2013-03-24 00:15 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RSB 2010-05-11 17:15:27 UTC
Version:            (using KDE 4.4.3)
OS:                Linux
Installed from:    openSUSE RPMs

If the kde_mulihead variable is enabled (see https://bugs.kde.org/show_bug.cgi?id=156475#c62), the shortcut for switching windows often don't work anymore. There is also the same problem if I want to switch the Virtual Desktop.

this is the konsole output of kwin (alt-tab pressed):
kwin(11233) KWin::HighlightWindowEffect::propertyNotify: Invalid window targetted for highlight. Requested: 0
kwin(11233) KWin::HighlightWindowEffect::propertyNotify: Invalid window targetted for highlight. Requested: 142607805
kwin(11233) KWin::HighlightWindowEffect::propertyNotify: Invalid window targetted for highlight. Requested: 142607807
kwin(11233) KWin::HighlightWindowEffect::propertyNotify: Invalid window targetted for highlight. Requested: 142607806
kwin(11233) KWin::HighlightWindowEffect::propertyNotify: Invalid window targetted for highlight. Requested: 142607808


KDE SC: 4.4.3 (packages from openSUSE Build Service)
Distri: openSUSE 11.2
Kernel: 2.6.31.12
Comment 1 Martin Flöser 2010-05-11 18:44:46 UTC
why do you want to use multihead? It's completely unsupported and outdated. Most graphics drivers even removed the support for multihead. If you are using an nvidia card please use TwinView, for all other vendors please use xrandr.
Comment 2 RSB 2010-05-11 21:19:41 UTC
TwinView is no solution. TwinView simulates one big screen. but I need two seperate Desktops. I have 2 LCD. One is my monitor, the other is my TV. Both LCD are on different sides of the room.

There are some facts on TwinView which seems problematic to me:
- TwinView doesn't support different resulutions.
- if you you change the Virtual Deskop, it also change the the Desktop on the other LCD. (this is maddening if you watch a movie on the other screen)
- if you open an app in TwinView-mode, you newer know if its start on the correct screen.

I don't know why multihead should be outdated. I think its the best solution for this afford and the most other desktopenviroments or windowmanager support it. Multihead-support was a long and often requested feature since the first release of KDE4 (http://aseigo.blogspot.com/2009/07/multihead.html)
Comment 3 Christoph Feck 2010-05-11 21:29:52 UTC
If you say that multihead is obsolete, then please enlighten us about the alternative.

For example I would like to use KDE with a video beamer connected, where e.g. SMPlayer runs full screen (and fully GL accelerated), while the other (primary) screen has the panel and everything else.

This worked fine in KDE 3, but not in KDE 4.
Comment 4 Martin Flöser 2010-05-23 16:38:27 UTC
(In reply to comment #3)
> If you say that multihead is obsolete, then please enlighten us about the
> alternative.
Sorry to say that I don't have an alternative and for the provided usecase I agree that for such usecases multihead is better. Unfortunately we cannot stop driver vendors to deprecate and remove the functionality :-(
Comment 5 RSB 2010-05-29 15:09:41 UTC
I can't say much about other drivers, but the nvidia driver 195.36.15 (with geforce 9600gt) still supports multihead. It works very well with kde3, fluxbox & gnome. Only kde4 have problems with multihead.
Comment 6 Thomas Lübking 2012-03-19 02:46:21 UTC
*** Bug 274369 has been marked as a duplicate of this bug. ***
Comment 7 riaasm 2012-03-19 04:04:10 UTC
I have this problem as well, with KDE 4.7.4 using Debian Unstable, as I've stated in duplicate bug 274369 and I've also described this problem in some detail. It doesn't seem like an issue with video drivers no longer supporting multihead features (nor was I aware of multihead becoming unsupported and deprecated). It seems like something is going wrong in kwin, which causes the focus to move to the second screen every time you perform certain window actions, like closing a window or alt-tab'ing, as if you clicked on the second screen, which in turn causes your next alt-tab to be performed on that second screen and certain other shortcuts to no longer be recognized (the latter of which may be a separate issue with kglobalaccel not being multihead-aware)

The duplicate bug contains more detailed information on this, including a reproduction recipe. I hope this can be fixed since it does seem like there are several people with this problem and it does diminish the usability quite a bit when you can't quickly alt-tab through your open windows.
Comment 8 Soos Gergely 2012-03-19 08:42:04 UTC
Isn't this the known issue with kglobalaccel? (See entry #4 in http://community.kde.org/Plasma/Multihead)
This bug affects me too, Alt+Tab doesn't work on the second screen, but it works sometimes on the first one. But every other global shortcut behaves in a similar way.

I would like to add, that I completely agree with RSB in comment 2 where he lists the issues with twinview, athough I have firegl and I can set different resolutions. But another issue is that I can't get my video player to sync with the secondary monitor. My laptop's display runs on 59.9Hz and my external monitor on 60.1Hz so if I watch a movie on the external monitor (which is the big one) there is a "line" travelling slowly upwards caused by the tear. So Xinerama is not for me either.
Comment 9 riaasm 2012-03-19 12:11:27 UTC
I think the known issue with kglobalaccel only makes this bug more problematic but as I see it, this bug is about the focus being moved to the second screen when you close a window, for example. If this is not the case here then bug 274369 has been incorrectly marked as a duplicate of this one because that is most definitely the problem that is reported there.
Comment 10 Soos Gergely 2012-03-19 14:18:46 UTC
I (re)started kwin from konsole to test this thing and for me(kde 4.7.4 on ubuntu 11.10) the error messages metioned in the first comment never appear. My problem is very similar to what riaasm describes in bug 274369 (which is not surprising since we both have kde4.7.4) with the exception that for me the sequence is not so regular, sometimes Alt+Tab works two times in a row.
So this issue may be indeed a different one. I don't know, maybe a developer should chip in to see the next steps.
Comment 11 Thomas Lübking 2013-03-24 00:15:26 UTC
Wit the patch you're not gonna loose the tabbox anymore but that doesn't change the fact that kglobalacceld can because of dbus only operate on one screen.

Git commit 53294ef164c3af5a08f20ff1f0de1de9bff5e5bd by Thomas Lübking.
Committed on 13/02/2013 at 00:40.
Pushed by luebking into branch 'master'.

improve multihead situation

prevents the focus being passed to the other head
manages OpenGLIsUnsafe setting per head
Related: bug 256242
REVIEW: 107853
FIXED-IN: 4.11

M  +7    -4    kwin/composite.cpp
M  +6    -37   kwin/tabbox/tabbox.cpp
M  +28   -0    kwin/workspace.cpp
M  +1    -0    kwin/workspace.h
M  +15   -0    kwin/xcbutils.h

http://commits.kde.org/kde-workspace/53294ef164c3af5a08f20ff1f0de1de9bff5e5bd