Bug 236451 - Crashes on startup after upgrading Ubuntu
Summary: Crashes on startup after upgrading Ubuntu
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-05 17:35 UTC by paul
Modified: 2010-05-24 17:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paul 2010-05-05 17:35:22 UTC
Application: knode (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Upgraded Ubuntu from 9.10 to 10.04 and knode crashes at startup, with a segmentation fault.

 -- Backtrace:
Application: KNode (knode), signal: Segmentation fault
[KCrash Handler]
#6  QDataStream::operator>> (this=0x0, i=@0xbfbac6fc) at io/qdatastream.cpp:717
#7  0x004eea24 in KMimeTypeFactory (this=0x878e968) at ../../kdecore/services/kmimetypefactory.cpp:49
#8  0x004eef4c in KSycocaFactorySingleton<KMimeTypeFactory>::self () at ../../kdecore/sycoca/ksycocafactory.h:200
#9  KMimeTypeFactory::self () at ../../kdecore/services/kmimetypefactory.cpp:91
#10 0x004f40af in KMimeType::mimeType (_name=..., options=KMimeType::ResolveAliases) at ../../kdecore/services/kmimetype.cpp:159
#11 0x0195604c in KHTMLPart::begin (this=0x867d408, url=..., xOffset=0, yOffset=0) at ../../khtml/khtml_part.cpp:2037
#12 0x002a9e92 in KNode::ArticleWidget::clear (this=0x867e040) at ../../knode/articlewidget.cpp:413
#13 0x002af7c5 in ArticleWidget (this=0x867e040, parent=0x862ef80, guiClient=0x86165d8, actionCollection=0x8462d08, isMainViewer=true) at ../../knode/articlewidget.cpp:130
#14 0x002a4156 in KNMainWidget (this=0x8641f40, client=0x86165d8, parent=0x86165a8) at ../../knode/knmainwidget.cpp:116
#15 0x0804d9e6 in KNMainWindow (this=0x86165a8, parent=0x0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../knode/knode.cpp:51
#16 0x0804e0e4 in KNApplication::newInstance (this=0xbfbad788) at ../../knode/knapplication.cpp:70
#17 0x00f6c950 in KUniqueApplicationAdaptor::newInstance (this=0x860a3a0, asn_id=..., args=...) at ../../kdeui/kernel/kuniqueapplication.cpp:454
#18 0x00f6d0b2 in KUniqueApplicationAdaptor::qt_metacall (this=0x860a3a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbacd0c) at ./kuniqueapplication_p.moc:81
#19 0x00309b34 in QDBusConnectionPrivate::deliverCall (this=0x8466db0, object=0x860a3a0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#20 0x0030addf in QDBusConnectionPrivate::activateCall (this=0x8466db0, object=0x860a3a0, flags=337, msg=...) at qdbusintegrator.cpp:809
#21 0x0030b880 in QDBusConnectionPrivate::activateObject (this=0x8466db0, node=..., msg=..., pathStartPos=16) at qdbusintegrator.cpp:1364
#22 0x0030bb1a in QDBusActivateObjectEvent::placeMetaCall (this=0x8608e10) at qdbusintegrator.cpp:1477
#23 0x00a2f3fe in QObject::event (this=0xbfbad788, e=0x8608e10) at kernel/qobject.cpp:1248
#24 0x00a1e50b in QCoreApplication::event (this=0xbfbad788, e=0x8608e10) at kernel/qcoreapplication.cpp:1533
#25 0x024ede46 in QApplication::event (this=0xbfbad788, e=0x8608e10) at kernel/qapplication.cpp:2353
#26 0x024e94dc in QApplicationPrivate::notify_helper (this=0x846b820, receiver=0xbfbad788, e=0x8608e10) at kernel/qapplication.cpp:4300
#27 0x024f005e in QApplication::notify (this=0xbfbad788, receiver=0xbfbad788, e=0x8608e10) at kernel/qapplication.cpp:3704
#28 0x00f64f2a in KApplication::notify (this=0xbfbad788, receiver=0xbfbad788, event=0x8608e10) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x00a1ea3b in QCoreApplication::notifyInternal (this=0xbfbad788, receiver=0xbfbad788, event=0x8608e10) at kernel/qcoreapplication.cpp:704
#30 0x00a21473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x844a4d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x844a4d8) at kernel/qcoreapplication.cpp:1345
#32 0x00a215dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#33 0x00a4aadf in QCoreApplication::sendPostedEvents (s=0x846fa88) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x846fa88) at kernel/qeventdispatcher_glib.cpp:276
#35 0x01eca5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x01ece2d8 in ?? () from /lib/libglib-2.0.so.0
#37 0x01ece4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00a4a5d5 in QEventDispatcherGlib::processEvents (this=0x844a080, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#39 0x025a9135 in QGuiEventDispatcherGlib::processEvents (this=0x844a080, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00a1d059 in QEventLoop::processEvents (this=0xbfbad714, flags=) at kernel/qeventloop.cpp:149
#41 0x00a1d4aa in QEventLoop::exec (this=0xbfbad714, flags=...) at kernel/qeventloop.cpp:201
#42 0x00a2169f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x024e9577 in QApplication::exec () at kernel/qapplication.cpp:3579
#44 0x0804e6b8 in main (argc=3, argv=0xbfbad894) at ../../knode/main.cpp:44

Reported using DrKonqi
Comment 1 Olivier Trichet 2010-05-24 17:15:19 UTC

*** This bug has been marked as a duplicate of bug 211401 ***