Bug 236422 - kbuildsyscoca crash after unclean shutdown
Summary: kbuildsyscoca crash after unclean shutdown
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Unclassified
Component: ksycoca (show other bugs)
Version: 1.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2010-05-05 12:44 UTC by Oliver Henshaw
Modified: 2018-10-27 02:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Henshaw 2010-05-05 12:44:45 UTC
Application: kbuildsycoca4 (1.1)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.11-99.fc12.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
Crash on login after rebooting after a powercut. Hopefully the backtrace is clear enough to identify an unhandled path.

 -- Backtrace:
Application: KBuildSycoca (kbuildsycoca4), signal: Aborted
[KCrash Handler]
#6  0x00f90416 in __kernel_vsyscall ()
#7  0x006e9a81 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x006eb34a in abort () at abort.c:92
#9  0x007273ed in __libc_message (do_abort=2, fmt=0x7f9784 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:186
#10 0x0072d7f1 in malloc_printerr (action=<value optimized out>, str=<value optimized out>, ptr=0x8b837e0) at malloc.c:6264
#11 0x00a5bd02 in operator delete (ptr=0x8b837e0) at ../../../../libstdc++-v3/libsupc++/del_op.cc:44
#12 0x001947c2 in operator= (this=0x8b8379c, other=...) at ../../src/corelib/tools/qshareddata.h:178
#13 QDateTime::operator= (this=0x8b8379c, other=...) at tools/qdatetime.cpp:2268
#14 0x0020ecd7 in QFileInfoPrivate::getFileTime (this=0x8b83810, request=ModificationTime) at io/qfileinfo.cpp:203
#15 0x0020ede9 in QFileInfo::lastModified (this=0x8b875d8) at io/qfileinfo.cpp:1232
#16 0x06b75b15 in KBuildSycoca::checkDirTimestamps (dirname=..., stamp=..., top=false) at /usr/src/debug/kdelibs-4.4.2/kded/kbuildsycoca.cpp:563
#17 0x06b75b96 in KBuildSycoca::checkDirTimestamps (dirname=..., stamp=..., top=true) at /usr/src/debug/kdelibs-4.4.2/kded/kbuildsycoca.cpp:568
#18 0x06b75edf in KBuildSycoca::checkTimestamps (timestamp=1272449653, dirs=...) at /usr/src/debug/kdelibs-4.4.2/kded/kbuildsycoca.cpp:587
#19 0x06b7a180 in kdemain (argc=3, argv=0xbffcff94) at /usr/src/debug/kdelibs-4.4.2/kded/kbuildsycoca.cpp:785
#20 0x0804862c in main (argc=3, argv=0xbffcff94) at /usr/src/debug/kdelibs-4.4.2/i686-redhat-linux-gnu/kded/kbuildsycoca4_dummy.cpp:3

Possible duplicates by query: bug 201991, bug 197520, bug 187667.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-09-12 21:35:34 UTC
This crash report is at least 3 years old and there were no further comments or status updates since then.

Therefore we believe that this crash is already fixed in recent KDE 4 versions or the backtrace is no longer applicable to the current KDE 4 sources.

If the crash still happens with a recent KDE version (4.10.5 or 4.11), please add an updated backtrace or provide steps to reproduce. For more information, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

(To prevent automatic closing of this bug in the future, please set the bug status to ASSIGNED or CONFIRMED)
Comment 2 Andrew Crouthamel 2018-09-24 02:03:42 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-27 02:15:57 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!