Bug 236237 - amarok crash [@ KEntryMap::findEntry]
Summary: amarok crash [@ KEntryMap::findEntry]
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.3.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 211973 238520 242282 243682 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-03 22:27 UTC by xxlazerburnxx
Modified: 2010-08-09 14:56 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.3.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xxlazerburnxx 2010-05-03 22:27:51 UTC
Application: amarok (2.3.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
After opening it had no sound. I closed the program and tried to open it and it gave me the crash report

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
pthread_cond_timedwait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S
[Current thread is 1 (Thread 0x7fbad56127a0 (LWP 17678))]

Thread 11 (Thread 0x7fbabcc82710 (LWP 17679)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007fbac2982081 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fbabc481710 (LWP 17680)):
#0  0x00007fbacbafce93 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x00007fbacbafd318 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fbacbafd8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fbad2f88566 in QEventDispatcherGlib::processEvents (this=0x1f642c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fbad2f5d992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fbad2f5dd6c in QEventLoop::exec (this=0x7fbabc480d50, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fbad2e67d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fbac2bde440 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#8  0x00007fbad2e6a775 in QThreadPrivate::start (arg=0x1f5f500) at thread/qthread_unix.cpp:248
#9  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fbab6b24710 (LWP 17686)):
#0  0x00007fbad261df53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=333) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbabba7b915 in ?? () from /usr/lib/xine/plugins/1.27/xineplug_ao_out_alsa.so
#2  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fbaba91f710 (LWP 17687)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbac2992e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fbab2322710 (LWP 17688)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbac2992e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fbab9d13710 (LWP 17689)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbac2992e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fbab9512710 (LWP 17690)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbac2992e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fbab7c1c710 (LWP 17693)):
#0  0x00007fbad261df53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbacbafd4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fbacbafd8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fbad2f88566 in QEventDispatcherGlib::processEvents (this=0x2c20080, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fbad2f5d992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fbad2f5dd6c in QEventLoop::exec (this=0x7fbab7c1bd70, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fbad2e67d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fbad2f3e178 in QInotifyFileSystemWatcherEngine::run (this=0x2c1f3c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbad2e6a775 in QThreadPrivate::start (arg=0x2c1f3c0) at thread/qthread_unix.cpp:248
#9  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fbaa83ac710 (LWP 17694)):
[KCrash Handler]
#5  0x00007fbad331510a in KEntryMap::findEntry(QByteArray const&, QByteArray const&, QFlags<KEntryMap::SearchFlag>) const () from /usr/lib/libkdecore.so.5
#6  0x00007fbad3311b71 in KEntryMap::getEntryOption (this=<value optimized out>, aGroup=...) at ../../kdecore/config/kconfigdata.h:403
#7  KConfig::isGroupImmutableImpl (this=<value optimized out>, aGroup=...) at ../../kdecore/config/kconfig.cpp:605
#8  0x00007fbad33178c4 in KConfigGroupPrivate (this=0x7fbaa83aba90, master=..., _group=<value optimized out>) at ../../kdecore/config/kconfiggroup.cpp:59
#9  KConfigGroup (this=0x7fbaa83aba90, master=..., _group=<value optimized out>) at ../../kdecore/config/kconfiggroup.cpp:579
#10 0x00007fbad33282aa in KSharedConfig::groupImpl (this=<value optimized out>, groupName=<value optimized out>) at ../../kdecore/config/ksharedconfig.cpp:79
#11 0x00007fbad33163ac in KConfigBase::group (this=0x1e66c70, str=<value optimized out>) at ../../kdecore/config/kconfigbase.cpp:56
#12 0x00007fbab8370340 in debugEnabled () at ../../../../../src/Debug.h:105
#13 dbgstream () at ../../../../../src/Debug.h:113
#14 debug () at ../../../../../src/Debug.h:133
#15 0x00007fbab83720e6 in ThreadInitializer (this=<value optimized out>) at ../../../../../src/collection/sqlcollection/mysql-shared/MySqlStorage.cpp:53
#16 ThreadInitializer::init (this=<value optimized out>) at ../../../../../src/collection/sqlcollection/mysql-shared/MySqlStorage.cpp:77
#17 MySqlStorage::initThreadInitializer (this=<value optimized out>) at ../../../../../src/collection/sqlcollection/mysql-shared/MySqlStorage.cpp:276
#18 0x00007fbab8372646 in MySqlStorage::query (this=0x7fbaac2c0b18, statement=...) at ../../../../../src/collection/sqlcollection/mysql-shared/MySqlStorage.cpp:112
#19 0x00007fbab7ece257 in SqlQueryMakerInternal::run (this=0x2aebd10) at ../../../../src/collection/sqlcollection/SqlQueryMakerInternal.cpp:46
#20 0x00007fbab7ecae9d in SqlWorkerThread::run (this=0x2aebf20) at ../../../../src/collection/sqlcollection/SqlQueryMaker.cpp:65
#21 0x00007fbacf4c08dd in ThreadWeaver::JobRunHelper::runTheJob (this=0x7fbaa83abd30, th=0x2aeb200, job=0x2aebf20) at ../../../threadweaver/Weaver/Job.cpp:106
#22 0x00007fbacf4c0bde in ThreadWeaver::Job::execute (this=0x2aebf20, th=0x2aeb200) at ../../../threadweaver/Weaver/Job.cpp:135
#23 0x00007fbacf4bfbcf in ThreadWeaver::ThreadRunHelper::run (this=0x7fbaa83abdc0, parent=0x2ae9f90, th=0x2aeb200) at ../../../threadweaver/Weaver/Thread.cpp:95
#24 0x00007fbacf4c0168 in ThreadWeaver::Thread::run (this=0x2aeb200) at ../../../threadweaver/Weaver/Thread.cpp:142
#25 0x00007fbad2e6a775 in QThreadPrivate::start (arg=0x2aeb200) at thread/qthread_unix.cpp:248
#26 0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#27 0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#28 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbaa7bab710 (LWP 17695)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbad2e6b72b in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x2aeadd0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2aeadd0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fbacf4bf026 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2ae9f90, th=0x2aeba90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fbacf4c16ab in ThreadWeaver::WorkingHardState::applyForWork (this=0x2ae9780, th=0x2aeba90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fbacf4bfbff in ThreadWeaver::ThreadRunHelper::run (this=0x7fbaa7baadc0, parent=0x2ae9f90, th=0x2aeba90) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fbacf4c0168 in ThreadWeaver::Thread::run (this=0x2aeba90) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fbad2e6a775 in QThreadPrivate::start (arg=0x2aeba90) at thread/qthread_unix.cpp:248
#8  0x00007fbad0a749ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fbad262a69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbad56127a0 (LWP 17678)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007fbad2e6a0e5 in thread_sleep (ti=0x7ffff6628120) at thread/qthread_unix.cpp:398
#2  0x00007fbad2e6a250 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:424
#3  0x00007fbac2c05b8a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#4  0x00007fbacfe4a846 in ?? () from /usr/lib/libphonon.so.4
#5  0x00007fbad257d262 in __run_exit_handlers (status=1) at exit.c:78
#6  *__GI_exit (status=1) at exit.c:100
#7  0x00007fbad3949558 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:734
#8  0x00007fbad5126288 in KApplication::xioErrhandler (this=0x7ffff6629620, dpy=0x1e97ca0) at ../../kdeui/kernel/kapplication.cpp:408
#9  0x00007fbad1bd17fe in _XIOError () from /usr/lib/libX11.so.6
#10 0x00007fbad1bd9355 in ?? () from /usr/lib/libX11.so.6
#11 0x00007fbad1bd9c07 in _XEventsQueued () from /usr/lib/libX11.so.6
#12 0x00007fbad1bb12da in XFlush () from /usr/lib/libX11.so.6
#13 0x00007fbad392891f in QWidget::setCursor (this=0x411f990, cursor=...) at kernel/qwidget.cpp:4799
#14 0x00007fbad3cdc940 in QLineEditPrivate::init (this=<value optimized out>, txt=...) at widgets/qlineedit_p.cpp:185
#15 0x00007fbad3ce060f in QLineEdit (this=0x411f990, parent=0x4113be0) at widgets/qlineedit.cpp:266
#16 0x00007fbad51fc6c9 in KLineEdit (this=0x7ffff66280a4, parent=0x189) at ../../kdeui/widgets/klineedit.cpp:206
#17 0x00007fbad4a69179 in LineEdit (this=0x7ffff66280a4, parent=0x189) at ../../src/widgets/LineEdit.cpp:25
#18 0x00007fbad4a778c0 in SearchWidget::init (this=0x4113b50, parent=<value optimized out>, advanced=false) at ../../src/widgets/SearchWidget.cpp:65
#19 0x00007fbad4a77c9a in SearchWidget (this=0x4113b50, parent=0x4112610, caller=0x4112610, advanced=true) at ../../src/widgets/SearchWidget.cpp:41
#20 0x00007fbad4a33952 in FileBrowser (this=0x4112610, name=<value optimized out>, parent=0x0) at ../../src/browsers/filebrowser/FileBrowser.cpp:41
#21 0x00007fbad496d363 in MainWindow::init (this=0x2300970) at ../../src/MainWindow.cpp:346
#22 0x00007fbad496edf2 in MainWindow (this=0x2300970) at ../../src/MainWindow.cpp:182
#23 0x00007fbad493b9ef in App::continueInit (this=0x7ffff6629620) at ../../src/App.cpp:681
#24 0x00007fbad494015b in App (this=0x7ffff6629620) at ../../src/App.cpp:212
#25 0x0000000000408778 in main (argc=1, argv=0x7ffff662b598) at ../../src/main.cpp:235

Possible duplicates by query: bug 233500, bug 211973.

Reported using DrKonqi
Comment 1 Sven Krohlas 2010-05-04 09:33:13 UTC
That crash is somewhere in KConfig/KEntryMap.
Comment 2 Oswald Buddenhagen 2010-05-04 22:48:23 UTC
why is everyone so eager to assign their bugs to kdelibs? (yes, that's a rhetorical question.)
please valgrind the problem and make a minimal test case. so far i can only see some memory corruption, which can come from anywhere.
Comment 3 Oswald Buddenhagen 2010-05-04 22:49:36 UTC
*** Bug 211973 has been marked as a duplicate of this bug. ***
Comment 4 Mikko C. 2010-05-22 20:25:24 UTC
*** Bug 238520 has been marked as a duplicate of this bug. ***
Comment 5 Myriam Schweingruber 2010-05-29 17:02:13 UTC
Is this bug reproducible or does it only crash once? Please also check if your installation is correct. I can't reproduce this here, using Amarok 2.3-git on Kubuntu 10.04 with KDE SC 4.4.3
Comment 6 Myriam Schweingruber 2010-06-24 10:50:02 UTC
Closing for lack of feedback. Feel free to reopen if you can reproduce this with Amarok 2.3.1 or later.
Comment 7 Myriam Schweingruber 2010-07-05 22:09:30 UTC
*** Bug 243682 has been marked as a duplicate of this bug. ***
Comment 8 Myriam Schweingruber 2010-08-09 14:56:46 UTC
*** Bug 242282 has been marked as a duplicate of this bug. ***