Bug 235858 - System monitor crash
Summary: System monitor crash
Status: RESOLVED DUPLICATE of bug 235855
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-30 23:42 UTC by Joe
Modified: 2010-05-18 18:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe 2010-04-30 23:42:29 UTC
Application: ksysguard (4.4.2 (KDE 4.4.2))
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
most likely same crash as other reports

The crash can be reproduced every time.

 -- Backtrace:
Application: System Monitor (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f774ae6b760 (LWP 3291))]

Thread 2 (Thread 0x7f7732c66710 (LWP 3306)):
#0  0x00007f7747e58f53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f774481e4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f774481e8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f7749460566 in QEventDispatcherGlib::processEvents (this=0x24665e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f7749435992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f7749435d6c in QEventLoop::exec (this=0x7f7732c65db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f774933fd59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f7749416178 in QInotifyFileSystemWatcherEngine::run (this=0x2465a70) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7749342775 in QThreadPrivate::start (arg=0x2465a70) at thread/qthread_unix.cpp:248
#9  0x00007f77490b29ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f7747e6569d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f774ae6b760 (LWP 3291)):
[KCrash Handler]
#5  0x00007f773cc961d9 in ListView::answerReceived (this=0x2345080, id=<value optimized out>, answer=<value optimized out>) at ../../../ksysguard/gui/SensorDisplayLib/ListView.cc:159
#6  0x00007f773c53ad52 in KSGRD::SensorAgent::processAnswer (this=0x216f490, buf=<value optimized out>, buflen=<value optimized out>) at ../../../../ksysguard/gui/ksgrd/SensorAgent.cc:184
#7  0x00007f773c54242e in KSGRD::SensorShellAgent::msgRcvd (this=0x216f490) at ../../../../ksysguard/gui/ksgrd/SensorShellAgent.cc:91
#8  0x00007f773c543218 in KSGRD::SensorShellAgent::qt_metacall (this=0x216f490, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8ca3bd70) at ./SensorShellAgent.moc:78
#9  0x00007f7749449e3f in QMetaObject::activate (sender=0x215eb90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x5) at kernel/qobject.cpp:3293
#10 0x00007f77493d671a in QProcessPrivate::_q_canReadStandardOutput (this=0x21793b0) at io/qprocess.cpp:887
#11 0x00007f77493d6af9 in QProcess::qt_metacall (this=0x215eb90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8ca3bf70) at .moc/release-shared/moc_qprocess.cpp:107
#12 0x00007f774a8d4a38 in KProcess::qt_metacall (this=0x7fff8ca3b860, _c=2359539624, _id=64, _a=0x5) at ./kprocess.moc:69
#13 0x00007f7749449e3f in QMetaObject::activate (sender=0x2176a60, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x5) at kernel/qobject.cpp:3293
#14 0x00007f7749495c6e in QSocketNotifier::activated (this=0x7fff8ca3b860, _t1=16) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#15 0x00007f7749450fb3 in QSocketNotifier::event (this=0x2176a60, e=0x7fff8ca3c620) at kernel/qsocketnotifier.cpp:317
#16 0x00007f77485d322c in QApplicationPrivate::notify_helper (this=0x205aab0, receiver=0x2176a60, e=0x7fff8ca3c620) at kernel/qapplication.cpp:4300
#17 0x00007f77485d96fb in QApplication::notify (this=0x205a9e0, receiver=0x2176a60, e=0x7fff8ca3c620) at kernel/qapplication.cpp:4183
#18 0x00007f774997e526 in KApplication::notify (this=0x205a9e0, receiver=0x2176a60, event=0x7fff8ca3c620) at ../../kdeui/kernel/kapplication.cpp:302
#19 0x00007f774943706c in QCoreApplication::notifyInternal (this=0x205a9e0, receiver=0x2176a60, event=0x7fff8ca3c620) at kernel/qcoreapplication.cpp:704
#20 0x00007f77494608ca in QCoreApplication::sendEvent (source=0x205e550) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 socketNotifierSourceDispatch (source=0x205e550) at kernel/qeventdispatcher_glib.cpp:110
#22 0x00007f774481a8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f774481e748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f774481e8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f7749460513 in QEventDispatcherGlib::processEvents (this=0x1fef140, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f774868346e in QGuiEventDispatcherGlib::processEvents (this=0x7fff8ca3b860, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f7749435992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f7749435d6c in QEventLoop::exec (this=0x7fff8ca3c880, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f7749439aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x00007f773ccc1743 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../ksysguard/gui/ksysguard.cc:582
#31 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=1, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#32 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#33 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#34 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 235855.

Possible duplicates by query: bug 235855.

Reported using DrKonqi
Comment 1 Lubos Lunak 2010-05-18 18:05:48 UTC

*** This bug has been marked as a duplicate of bug 235855 ***