Bug 235799 - Kwrite crashed when trying do mark words
Summary: Kwrite crashed when trying do mark words
Status: RESOLVED DUPLICATE of bug 200858
Alias: None
Product: kate
Classification: Unclassified
Component: kwrite (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-30 11:57 UTC by Christopher Yeleighton
Modified: 2010-04-30 14:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Yeleighton 2010-04-30 11:57:55 UTC
Application that crashed: kwrite
Version of the application: 4.3.5 (KDE 4.3.5) "release 0"
KDE Version: 4.3.5 (KDE 4.3.5) "release 3"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.12-0.2-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
I was trying to mark and remove some words I accidentally pasted.  The document was C++ source code.  Kwrite crashed.

 -- Backtrace:
Application: KWrite (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at /usr/src/debug/kdelibs-4.3.5/kate/render/katelinelayout.cpp:173
#6  0x00007f0da021e08a in KateLayoutCache::viewLine (this=0x9a48d0, realCursor=...) at /usr/src/debug/kdelibs-4.3.5/kate/render/katelayoutcache.cpp:392
#7  0x00007f0da021e661 in KateLayoutCache::textLayout (this=0x9a48d0, realCursor=...) at /usr/src/debug/kdelibs-4.3.5/kate/render/katelayoutcache.cpp:334
#8  0x00007f0da02715d9 in KateViewInternal::makeVisible (this=0x966120, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at /usr/src/debug/kdelibs-4.3.5/kate/view/kateviewinternal.cpp:684
#9  0x00007f0da0271c99 in KateViewInternal::updateCursor (this=0x966120, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at /usr/src/debug/kdelibs-4.3.5/kate/view/kateviewinternal.cpp:1876
#10 0x00007f0da02762dd in KateViewInternal::mousePressEvent (this=0x966120, e=0x7fff40c88e40) at /usr/src/debug/kdelibs-4.3.5/kate/view/kateviewinternal.cpp:2539
#11 0x00007f0dae29fcd6 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007f0dae2512ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#13 0x00007f0dae2583c1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#14 0x00007f0daee4c016 in KApplication::notify (this=0x7fff40c8ae00, receiver=0x966120, event=0x7fff40c88e40) at /usr/src/debug/kdelibs-4.3.5/kdeui/kernel/kapplication.cpp:302
#15 0x00007f0db0468ddc in QCoreApplication::notifyInternal (this=0x7fff40c8ae00, receiver=0x966120, event=0x7fff40c88e40) at kernel/qcoreapplication.cpp:610
#16 0x00007f0dae257c90 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib64/libQtGui.so.4
#17 0x00007f0dae2bdcfe in ?? () from /usr/lib64/libQtGui.so.4
#18 0x00007f0dae2bcd9a in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#19 0x00007f0dae2e4b6c in ?? () from /usr/lib64/libQtGui.so.4
#20 0x00007f0dad19adee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f0dad19e7b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f0dad19e8e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f0db04913a3 in QEventDispatcherGlib::processEvents (this=0x618810, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#24 0x00007f0dae2e431e in ?? () from /usr/lib64/libQtGui.so.4
#25 0x00007f0db0467712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#26 0x00007f0db0467ae4 in QEventLoop::exec (this=0x7fff40c8aca0, flags=) at kernel/qeventloop.cpp:201
#27 0x00007f0db0469c99 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0x00007f0da590705d in kdemain () from /usr/lib64/libkdeinit4_kwrite.so
#29 0x0000000000406f88 in launch (argc=3, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=24, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4bd "0") at /usr/src/debug/kdelibs-4.3.5/kinit/kinit.cpp:715
#30 0x0000000000407c80 in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.3.5/kinit/kinit.cpp:1207
#31 0x0000000000408131 in handle_requests (waitForPid=0) at /usr/src/debug/kdelibs-4.3.5/kinit/kinit.cpp:1400
#32 0x0000000000408e02 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/kdelibs-4.3.5/kinit/kinit.cpp:1839
Warning: the current language does not match this frame.
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Jonathan Thomas 2010-04-30 14:58:57 UTC

*** This bug has been marked as a duplicate of bug 200858 ***