Bug 235696 - Scanning stale and orphaned songs on iPod Nano 2G results in song duplication.
Summary: Scanning stale and orphaned songs on iPod Nano 2G results in song duplication.
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Collections/iPod iPhone (show other bugs)
Version: 2.3.1-GIT
Platform: unspecified Linux
: VHI major with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-29 10:30 UTC by Hakan Bayindir
Modified: 2011-12-20 11:05 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hakan Bayindir 2010-04-29 10:30:15 UTC
Version:           2.3.0 (using 4.3.4 (KDE 4.3.4), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32-3-686-bigmem

When I scan my iPod Nano 2G for stale and duplicate songs, every song in my iPod duplicates. The difference between duplicate and original songs is original songs have covers but duplicates don't (They appear like they are initially uploaded without covers. Not like having a space for cover and missing cover.)

Additional Notes:
- I cross manage my iPod between iTunes (Mac) and amarok with a ratio of %2 to %98 (iTunes - Amarok)
- I produced the bug once, and can try to reproduce if someone requests it. I just can't reproduce it before submitting a bug (which I usually do) because it's really pain to fill an iPod with amarok (which wonderfully manages my collection) due to bug #218152. But I want to re-iterate: If I get any requests of reproducing, will do ASAP.
- As usual, it's a vanilla amarok 2.3.0 bundled with debian and without any add-ons

How to reproduce:
1- Open amarok
2- Connect your ipod
3- Your system will detect it. Mount your iPod. Amarok will mount it too.
4- Scan for stale and orphans from media browser (IIRC it's under the wrench icon on the header of the iPod entry)
5- Wait until it completes.
6- Amarok will report that it added some songs to database (number is equal to the songs in the device)
7- You'll see duplicate entries on the media browser.
8- Unmount your iPod believing that it's a minor bug.
9- Take a look at your ipod song list from any perspectives (compilations doesn't count because compilations doesn't work due to a bug) and see every song is duplicated.
10 - You reproduced the bug, congrats :)

Expected behavior:
1- Open amarok
2- Connect your ipod
3- Your system will detect it. Mount your iPod. Amarok will mount it too.
4- Scan for stale and orphans from media browser (IIRC it's under the wrench icon on the header of the iPod entry)
5- Wait until it completes.
6- Amarok shall not find any stale and orphaned under normal conditions or find right amount of stale and orphaned songs and add to your database.
Comment 1 Matěj Laitl 2010-06-12 15:39:05 UTC
I can confirm the bug with Amarok git v2.3.1-198-g999ec04 and iPod Nano 2G 2GB.
Comment 2 Myriam Schweingruber 2010-06-12 16:02:59 UTC
Setting to confirmed.
Comment 3 Johannes Obermayr 2010-07-05 21:44:25 UTC
Higher priority.

If you click on it your iPod gets more or less unusable:
1. Covers on iPod itself do not work
2. All entries are two, three, four, (how often you try it) times on the iPod (then try playing an album -> it is like "repeat" ... times)

I think I translate it in German like "Make duplicate entries on iPod and destroy using covers on iPod itself" until it is fixed.

Another temporary fix could be disabling it ...

Also should the highly awaited fix include some algorithms for fixing (removing) the unuseful entries and a dialog box should display the changes and ask whether they should be written to the iPod or not. (So the user can interfere in last minute after review ...)
Comment 4 JPoncelet.C 2010-07-11 13:14:34 UTC
Bug confirmed with Ipod Classic 80gb (xb029)
Comment 5 Xavier Corredor Llano 2010-10-20 22:42:49 UTC
Confirm this bug with my Ipod Nano Video 8Gb.
Comment 6 Sergey Ivanov 2010-11-11 10:42:25 UTC
It should be fixed now. Check with latest git revision.