Bug 235671 - All tags no longer shown when the "Tags already assigned" button is clicked
Summary: All tags no longer shown when the "Tags already assigned" button is clicked
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Tags-Engine (show other bugs)
Version: 1.2.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-28 23:10 UTC by Russell Harrison
Modified: 2022-01-22 17:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russell Harrison 2010-04-28 23:10:51 UTC
Version:           1.2.0 (using KDE 4.4.2)
Compiler:          gcc
OS:                Linux (i686) release 2.6.32.11-99.fc12.i686.PAE
Installed from:    Fedora RPMs

The previous behavior when clicking the "Tags already assigned" button in the "Caption/Tags" tab would show all of the tags that had been assigned to the selected images.  The tags tree was fully expanded only showing tags applied to the selction.  This made reviewing my tagging changes very easy especially when asigning multiple tags found through the search box.

Now when I click the button it will only show me the highest level tags assigned. To see if other tags have been assigned I now need to expand each top level tag which shows both the assigned and unassigned children of that tag.  This basically requires manual inspection of all child tags to ensure that the proper ones are selected.

Also, if there is text in the search box clicking the "Tags already assigned" button will only show tags matching the text in the search box.  While this behavior is understandable and not unexpected I personally preferred the former behavior which was to show all tags assigned to the selected items.
Comment 1 Russell Harrison 2010-04-28 23:32:03 UTC
My apologies, submitted the bug twice by accident.

*** This bug has been marked as a duplicate of bug 235666 ***
Comment 2 caulier.gilles 2022-01-22 17:26:35 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=235666