Bug 235482 - crashes when renaming file on samba drive (almost always)
Summary: crashes when renaming file on samba drive (almost always)
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-26 21:11 UTC by alberich
Modified: 2010-08-06 20:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alberich 2010-04-26 21:11:31 UTC
Version:           1.3 (using KDE 4.3.5)
Compiler:          gcc version 4.4.1 [gcc-4_4-branch revision 150839] (SUSE Linux) Using built-in specs. Target: x86_64-suse-linux Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.4 --enable-ssp --disable-libssp --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib64 --with-system-zlib --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --program-suffix=-4.4 --enable-linux-futex --without-system-libunwind --with-arch-32=i586 --with-tune=generic --build=x86_64-suse-linux
OS:                Linux
Installed from:    openSUSE RPMs

Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.5 (KDE 4.3.5) "release 0"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.12-0.2-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
<Adding the extension of a pdf-file stored on a samba drive. The file was previously stored using okular. Okular, however, did not correctly add the file extension.>

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f5dbec5d900 in QUrl::QUrl(QUrl const&) () from /usr/lib64/libQtCore.so.4
#6  0x00007f5dbfe75929 in KUrl::KUrl(KUrl const&) () from /usr/lib64/libkdecore.so.5
#7  0x00007f5dc1cf2820 in KFileItem::url() const () from /usr/lib64/libkio.so.5
#8  0x00007f5dc1ce1684 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib64/libkio.so.5
#9  0x00007f5dc1991e10 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib64/libkfile.so.4
#10 0x00007f5dc1995b52 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib64/libkfile.so.4
#11 0x00007f5dc19967c5 in KFilePreviewGenerator::Private::updateIcons(QModelIndex const&, QModelIndex const&) () from /usr/lib64/libkfile.so.4
#12 0x00007f5dc1996ea7 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkfile.so.4
#13 0x00007f5dbecbbfbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#14 0x00007f5dbecf2037 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&) () from /usr/lib64/libQtCore.so.4
#15 0x00007f5dc1ce0d44 in ?? () from /usr/lib64/libkio.so.5
#16 0x00007f5dc1ce2b0a in KDirModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkio.so.5
#17 0x00007f5dbecbbfbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#18 0x00007f5dc1cc5525 in KDirLister::refreshItems(QList<QPair<KFileItem, KFileItem> > const&) () from /usr/lib64/libkio.so.5
#19 0x00007f5dc1cc63cb in KDirLister::Private::emitItems() () from /usr/lib64/libkio.so.5
#20 0x00007f5dc1cd933d in ?? () from /usr/lib64/libkio.so.5
#21 0x00007f5dc1cd9a84 in ?? () from /usr/lib64/libkio.so.5
#22 0x00007f5dbecbbfbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#23 0x00007f5dc1ce4177 in OrgKdeKDirNotifyInterface::FileRenamed(QString const&, QString const&) () from /usr/lib64/libkio.so.5
#24 0x00007f5dc1ce42b4 in OrgKdeKDirNotifyInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkio.so.5
#25 0x00007f5dbfb4cb78 in ?? () from /usr/lib64/libQtDBus.so.4
#26 0x00007f5dbfb5416f in ?? () from /usr/lib64/libQtDBus.so.4
#27 0x00007f5dbecb62d9 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007f5dbf1372ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#29 0x00007f5dbf13e57e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f5dc0421016 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007f5dbeca6ddc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#32 0x00007f5dbeca79ea in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f5dbeccf803 in ?? () from /usr/lib64/libQtCore.so.4
#34 0x00007f5dba7f0dee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f5dba7f47b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f5dba7f48e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f5dbeccf3a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f5dbf1ca31e in ?? () from /usr/lib64/libQtGui.so.4
#39 0x00007f5dbeca5712 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#40 0x00007f5dbeca5ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f5dbeca7c99 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#42 0x0000000000439505 in _start ()

An https://bugs.kde.org berichten
Comment 1 Nicolas L. 2010-08-06 20:10:10 UTC

*** This bug has been marked as a duplicate of bug 211525 ***