Bug 235256 - Scrolling is unsensitive (and scrollbar too short) in KCategorizedView
Summary: Scrolling is unsensitive (and scrollbar too short) in KCategorizedView
Status: RESOLVED DUPLICATE of bug 233163
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-24 13:08 UTC by Dion Moult
Modified: 2010-04-24 18:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dion Moult 2010-04-24 13:08:16 UTC
Version:            (using KDE 4.4.2)
OS:                Linux
Installed from:    Gentoo Packages

for certain applications such as Dolphin the scrollbar is unnaturally short even though there isn't much to scroll. As a result when I scroll with either my mouse or touchpad, even though the scrollbar moves a fair bit, the items in the window are only scrolled a small amount. Increasing the "lines to scroll by" in system settings does not help. Note that in other apps like Quassel or Firefox scrollbars work fine and are scrolled by the right amount.

I understand it's a bit hard to imagine what I described so perhaps this screenshot should help -(http://upload.failnation.com/files/1/snapshot1.png)  as you can see there are only 21 items yet the scrollbar is already very short as though there were many items. When scrolling, that scrollbar moves the amount it should _if_ there were many items, but since there are only 21, the window only scrolls a small amount. So I would be scrolling again and again and I would only move a small distance.

Let's not confuse this with "slow" scrolling, scrolling is responsive, just not sensitive.

This seems to only occur in KCategorizedView users, such as in Dolphin icon view and in the system settings start page. It is brought about by this fix towards another bug in GetHotNewStuff: http://websvn.kde.org/?revision=1104321&view=revision
Comment 1 Dion Moult 2010-04-24 18:03:52 UTC

*** This bug has been marked as a duplicate of bug 233163 ***