Bug 235125 - Make it possible to preview files in different applications
Summary: Make it possible to preview files in different applications
Status: CLOSED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-23 00:40 UTC by
Modified: 2011-06-20 04:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2010-04-23 00:40:28 UTC
Version:           2.14 (using 4.4.2 (KDE 4.4.2), Mandriva Linux release 2010.0 (Official) for x86_64)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.33.2-desktop-1mnb

Back in 3.5.10 i remember in ark was possible to preview files with other apps than just with the internel ark previwer, i remember for example using kwrite to edit text files, why isnt now possible?
Comment 1 Raphael Kubo da Costa 2010-04-23 00:58:03 UTC
Do you mean something like right-clicking a file and choosing "Preview with...", which would then launch the selected program and use it to preview the right-clicked file?

Or choosing a different previewer for the preview dialog?
Comment 2 2010-04-23 03:11:48 UTC
I dot remember quite well but i think it was from the configuration dialog was possible to choose what app to use to open/preview files.

It would be also good that the user could right click a file and choose what app to run a file.

It would be better if you could study other good archive managers and strt the process to put ark as a good archive manager and not just a simple one.
Comment 3 Gilboa Davara 2010-04-25 11:07:27 UTC
I second the above.
The built in-preview fails to display XML files correctly.

The ideal solution was the ability to select a preview editor by file type, but even "Preview with" right click will do.

- Gilboa
Comment 4 Raphael Kubo da Costa 2010-04-25 17:08:11 UTC
(In reply to comment #3)
> The built in-preview fails to display XML files correctly.

The XML thing isn't an Ark bug per se -- see 201162. Basically, you need to choose Kate instead of Konqueror for displaying XML files in System Settings/File Associations. I started a discussion about changing the default viewer in kde-core-devel once, but it has stalled.
Comment 5 Gilboa Davara 2010-04-27 08:28:44 UTC
Thanks for the heads-up.
Defaults aside, as the OP requested, it would have been nice if it was possible to open a file using a non-default application.

- Gilboa
Comment 6 Gilboa Davara 2010-04-27 08:30:33 UTC
P.S. The default XML editor in File Assoc is already VIM. Ark simply ignores it.

- Gilboa
Comment 7 2010-04-27 15:08:38 UTC
Ark simply should give user the option to choose to what application open selected files, and AFAIK that used to exist back in kde 3.5.10
Comment 8 Raphael Kubo da Costa 2010-04-27 15:49:05 UTC
(In reply to comment #6)
> P.S. The default XML editor in File Assoc is already VIM. Ark simply ignores
> it.
> 
> - Gilboa

I suppose you've chosen VIM in the General tab in file associations, right? Make sure Konqueror (khtmlpart) isn't the first option in the Embedding tab.
Comment 9 Gilboa Davara 2010-04-28 01:19:11 UTC
Changed the order (katepart) and I now katepart is used.
But no matter what I do, ark refuses to use VIM. (Most likely a different bug)

- Gilboa
Comment 10 Raphael Kubo da Costa 2010-04-28 01:33:32 UTC
> But no matter what I do, ark refuses to use VIM. (Most likely a different bug)

That's not a bug actually. Ark first tries to use the embeddable applications (such as khtmlpart, katepart etc) in its previewer. It is only after no suitable kpart is found that it tries to use the applications associated to that mimetype (and then the previewer will not be launched).
Comment 11 Gilboa Davara 2010-04-28 07:54:11 UTC
(I know that Bugzilla is not a support forum, but:) How can I force ark to use an external editor? (Searched the help, couldn't find a solution)
Comment 12 2010-04-28 15:40:41 UTC
In ark from kde-3.5.10 i rmemeber i could choose to with what app open files.

Dont think its that hard to search in 3.5 branch code.
Comment 13 Raphael Kubo da Costa 2010-04-28 15:46:05 UTC
> How can I force ark to use an external editor? (Searched the help, couldn't find a solution)
That's basically what this bug report is all about ;)
Comment 14 Raphael Kubo da Costa 2010-12-08 02:19:29 UTC
Changing the default assignee in the currently open Ark bug reports to me.
Comment 15 Gilboa Davara 2010-12-22 20:57:04 UTC
Any updates?
Comment 16 Raphael Kubo da Costa 2010-12-22 21:11:54 UTC
Oops, I didn't notice there's an older bug with the same wish.

Marking this one as a duplicate, and answering your question there.

*** This bug has been marked as a duplicate of bug 179066 ***