Bug 234493 - dolphin crash when disconnecting flashdrive
Summary: dolphin crash when disconnecting flashdrive
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-16 00:53 UTC by Piotr L
Modified: 2010-04-16 05:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr L 2010-04-16 00:53:28 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-21-generic i686
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x021d6829 in QUrl (this=0xbfed4bb8, other=...) at io/qurl.cpp:3936
#7  0x05d0dd89 in KUrl (this=0xbfed4bb8, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0x0027b28e in KFileItem::url (this=0xa623248) at ../../kio/kio/kfileitem.cpp:1271
#9  0x0026a75f in KDirModel::indexForItem (this=0xa5b5be0, item=...) at ../../kio/kio/kdirmodel.cpp:919
#10 0x00f02a36 in KFilePreviewGenerator::Private::orderItems (this=0xa5dea20, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#11 0x00f066bd in KFilePreviewGenerator::Private::updateIcons (this=0xa5dea20, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#12 0x00f06902 in KFilePreviewGenerator::Private::delayedIconUpdate (this=0xa5dea20) at ../../kfile/kfilepreviewgenerator.cpp:1088
#13 0x00f079a6 in KFilePreviewGenerator::qt_metacall (this=0xa5de8b8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfed4e0c) at ./kfilepreviewgenerator.moc:95
#14 0x02238263 in QMetaObject::activate (sender=0xa5dee90, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#15 0x02238ec2 in QMetaObject::activate (sender=0xa5dee90, m=0x2313904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0x02272667 in QTimer::timeout (this=0xa5dee90) at .moc/release-shared/moc_qtimer.cpp:128
#17 0x0223d9ae in QTimer::timerEvent (this=0xa5dee90, e=0xbfed52a0) at kernel/qtimer.cpp:261
#18 0x022323bf in QObject::event (this=0xa5dee90, e=0xbfed52a0) at kernel/qobject.cpp:1075
#19 0x087c0f54 in QApplicationPrivate::notify_helper (this=0x99029b8, receiver=0xa5dee90, e=0xbfed52a0) at kernel/qapplication.cpp:4056
#20 0x087c867c in QApplication::notify (this=0xbfed560c, receiver=0xa5dee90, e=0xbfed52a0) at kernel/qapplication.cpp:3603
#21 0x010f6bfa in KApplication::notify (this=0xbfed560c, receiver=0xa5dee90, event=0xbfed52a0) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x022226cb in QCoreApplication::notifyInternal (this=0xbfed560c, receiver=0xa5dee90, event=0xbfed52a0) at kernel/qcoreapplication.cpp:610
#23 0x0224f7ce in QCoreApplication::sendEvent (this=0x9905574) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x9905574) at kernel/qeventdispatcher_unix.cpp:572
#25 0x0224d0e0 in timerSourceDispatch (source=0x9905540) at kernel/qeventdispatcher_glib.cpp:165
#26 0x032f0e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x032f4730 in ?? () from /lib/libglib-2.0.so.0
#28 0x032f4863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x0224d02c in QEventDispatcherGlib::processEvents (this=0x98e4a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#30 0x08861be5 in QGuiEventDispatcherGlib::processEvents (this=0x98e4a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x02220c79 in QEventLoop::processEvents (this=0xbfed5564, flags=) at kernel/qeventloop.cpp:149
#32 0x022210ca in QEventLoop::exec (this=0xbfed5564, flags=...) at kernel/qeventloop.cpp:201
#33 0x0222353f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0x087c0dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#35 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-04-16 05:56:10 UTC
This bug is fixed in KDE 4.3.5 and later. Thanks for reporting!

*** This bug has been marked as a duplicate of bug 211525 ***