Bug 234475 - Hang opening file (attached)
Summary: Hang opening file (attached)
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 273084 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-04-15 20:36 UTC by Clemens Eisserer
Modified: 2012-11-12 12:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8


Attachments
File that causes kwrite to hang (143.43 KB, text/javascript)
2010-04-15 20:37 UTC, Clemens Eisserer
Details
sysprof profile (53.13 KB, application/x-bzip2)
2010-04-15 20:37 UTC, Clemens Eisserer
Details
sysprof screenshot (71.97 KB, image/png)
2010-04-15 20:38 UTC, Clemens Eisserer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2010-04-15 20:36:13 UTC
Version:            (using KDE 4.4.2)
OS:                Linux
Installed from:    Fedora RPMs

When opening the attached javascript-file, kwrite starts spinning in an endless loop. (sysprof-profile attached)
Comment 1 Clemens Eisserer 2010-04-15 20:37:17 UTC
Created attachment 42806 [details]
File that causes kwrite to hang
Comment 2 Clemens Eisserer 2010-04-15 20:37:46 UTC
Created attachment 42807 [details]
sysprof profile
Comment 3 Clemens Eisserer 2010-04-15 20:38:05 UTC
Created attachment 42808 [details]
sysprof screenshot
Comment 4 Christoph Cullmann 2011-06-25 16:21:35 UTC
*** Bug 273084 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Cullmann 2011-06-25 18:44:01 UTC
Kate will wrap lines longer than 1024 per default on load
that can be configured in open/save
that avoids the crashs on opening degenerated one-liner files like javascript/html messes
BUG: 234475