Bug 234472 - Dolphin crash in QUrl under high system load
Summary: Dolphin crash in QUrl under high system load
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-15 20:17 UTC by Roger Leigh
Modified: 2010-04-15 21:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Leigh 2010-04-15 20:17:45 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-4-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
Not performing any action in dolphin at the time of the crash (just clicked in the window).  The window was split into two at the time.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  QUrl (this=0x7fff922c0280, other=...) at io/qurl.cpp:3936
#6  0x000000337aaec459 in KUrl (this=<value optimized out>, _u=<value optimized out>) at ../../kdecore/io/kurl.cpp:468
#7  0x000000337c941410 in KFileItem::url (this=<value optimized out>) at ../../kio/kio/kfileitem.cpp:1271
#8  0x000000337c9303d4 in KDirModel::indexForItem (this=<value optimized out>, item=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:919
#9  0x000000337f2778f0 in KFilePreviewGenerator::Private::orderItems (this=<value optimized out>, items=<value optimized out>) at ../../kfile/kfilepreviewgenerator.cpp:1023
#10 0x000000337f27b5f2 in KFilePreviewGenerator::Private::updateIcons (this=<value optimized out>, items=<value optimized out>) at ../../kfile/kfilepreviewgenerator.cpp:508
#11 0x000000337f27b84f in KFilePreviewGenerator::Private::delayedIconUpdate (this=<value optimized out>) at ../../kfile/kfilepreviewgenerator.cpp:1088
#12 0x000000337f27c8c5 in KFilePreviewGenerator::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>)
    at ./kfilepreviewgenerator.moc:95
#13 0x0000003378366df2 in QMetaObject::activate (sender=<value optimized out>, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=<value optimized out>)
    at kernel/qobject.cpp:3112
#14 0x0000003378361353 in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1074
#15 0x00000033789d801d in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4065
#16 0x00000033789e007a in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4030
#17 0x000000337b622de6 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0000003378351c9c in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:610
#19 0x000000337837e2c6 in QCoreApplication::sendEvent (this=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (this=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:580
#21 0x000000337837a658 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#22 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#23 0x0000003376e3e6c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x0000003376e42538 in ?? () from /lib/libglib-2.0.so.0
#25 0x0000003376e426ec in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x000000337837a39c in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#27 0x0000003378a6ef1f in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#28 0x0000003378350562 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#29 0x0000003378350934 in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#30 0x0000003378352ba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#31 0x00000000004394b5 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/dolphin/src/main.cpp:94

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-04-15 21:36:24 UTC
This bug is fixed in KDE 4.3.5 and later. Thanks for reporting!

*** This bug has been marked as a duplicate of bug 211525 ***