Bug 234429 - seg fault when attempt to change tabs
Summary: seg fault when attempt to change tabs
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.3.5
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-15 12:56 UTC by hllacey
Modified: 2011-12-15 06:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hllacey 2010-04-15 12:56:20 UTC
Application that crashed: konqueror
Version of the application: 4.3.5 (KDE 4.3.5) "release 0"
KDE Version: 4.3.5 (KDE 4.3.5) "release 0"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.12-0.2-desktop i686
Distribution: "openSUSE 11.2 (i586)"

What I was doing when the application crashed:
seg fault when attempt to change tabs with about four tabs open sites were google.com wikipedia.org mail.google.com mail.yahoo.com defensetech.org

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb578c700 (LWP 6809))]

Thread 5 (Thread 0xaf547b70 (LWP 7431)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb7633d95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7693750 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb768f06e in QSemaphore::acquire(int) () from /usr/lib/libQtCore.so.4
#4  0xa4ebad6c in ?? () from /usr/lib/kde4/okularGenerator_ghostview.so
#5  0xb7692623 in ?? () from /usr/lib/libQtCore.so.4
#6  0xb762f6e5 in start_thread () from /lib/libpthread.so.0
#7  0xb762f600 in ?? () from /lib/libpthread.so.0

Thread 4 (Thread 0xaa515b70 (LWP 21136)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb7633d95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xac24c79f in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xac37f7ff in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xac24cc5d in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xb762f6e5 in start_thread () from /lib/libpthread.so.0
#6  0xb762f600 in ?? () from /lib/libpthread.so.0

Thread 3 (Thread 0xa44a0b70 (LWP 21137)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb7633d95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xac24c79f in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xac37f7ff in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xac24cc5d in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xb762f6e5 in start_thread () from /lib/libpthread.so.0
#6  0xb762f600 in ?? () from /lib/libpthread.so.0

Thread 2 (Thread 0xa4ca1b70 (LWP 21143)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6079d5e in poll () from /lib/libc.so.6
#2  0xa9465605 in ?? () from /usr/lib/libasound.so
#3  0xa94657d4 in snd_pcm_wait () from /usr/lib/libasound.so
#4  0xac67ef13 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xb762f6e5 in start_thread () from /lib/libpthread.so.0
#6  0xb762f600 in ?? () from /lib/libpthread.so.0

Thread 1 (Thread 0xb578c700 (LWP 6809)):
[KCrash Handler]
#6  0xb61cd009 in __dynamic_cast () from /usr/lib/libstdc++.so.6
#7  0xb4256e2f in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#8  0xb4265896 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#9  0xb779f864 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#10 0xb77a0585 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#11 0xb42058c5 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#12 0xb42066a4 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#13 0xb423bd23 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#14 0xb4265b8d in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#15 0xb779f864 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb77a0585 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#17 0xb77a4b25 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb77a4c5c in ?? () from /usr/lib/libQtCore.so.4
#19 0xb779951b in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#20 0xb63258fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb632d34e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#22 0xb6d64521 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#23 0xb778932e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#24 0xb77b8356 in ?? () from /usr/lib/libQtCore.so.4
#25 0xb77b5325 in ?? () from /usr/lib/libQtCore.so.4
#26 0xb5f004c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#27 0xb5f03d98 in ?? () from /usr/lib/libglib-2.0.so.0
#28 0xb5f03ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#29 0xb77b5011 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0xb63c729a in ?? () from /usr/lib/libQtGui.so.4
#31 0xb778798d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb7787dd9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0xb778a270 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#34 0xb6325774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#35 0xb42983a3 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#36 0x0804e147 in _start ()

This bug may be a duplicate of or related to bug 233140

Reported using DrKonqi
Comment 1 Dawit Alemayehu 2011-12-15 06:04:51 UTC

*** This bug has been marked as a duplicate of bug 203809 ***