Bug 234364 - Kate crash while editing a file
Summary: Kate crash while editing a file
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-14 17:54 UTC by Kay Abendroth
Modified: 2010-04-14 19:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kay Abendroth 2010-04-14 17:54:37 UTC
Version:            (using KDE 4.4.2)
OS:                Linux
Installed from:    Archlinux Packages

The file I was editing has not been saved before. I was just typing some text, deleting lines etc.


Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f001ef2a760 (LWP 7290))]

Thread 3 (Thread 0x7f0007212710 (LWP 4987)):
#0  0x00007f001d18a10c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f001d41557b in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x28ec668, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x28ec668, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f001cbad496 in QFileInfoGatherer::run (this=<value optimized out>) at dialogs/qfileinfogatherer.cpp:203
#4  0x00007f001d4145b5 in QThreadPrivate::start (arg=0x28ec658) at thread/qthread_unix.cpp:248
#5  0x00007f001d18588a in start_thread () from /lib/libpthread.so.0
#6  0x00007f001bf509ed in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0006a11710 (LWP 4988)):
#0  0x00007f001bf481c3 in poll () from /lib/libc.so.6
#1  0x00007f0018b57979 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#2  0x00007f0018b57dcc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f001d5320e6 in QEventDispatcherGlib::processEvents (this=0x467ac80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f001d507522 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f001d5078fc in QEventLoop::exec (this=0x7f0006a10de0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f001d411bb9 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f001d4e7ec8 in QInotifyFileSystemWatcherEngine::run (this=0x2ec03d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f001d4145b5 in QThreadPrivate::start (arg=0x2ec03d0) at thread/qthread_unix.cpp:248
#9  0x00007f001d18588a in start_thread () from /lib/libpthread.so.0
#10 0x00007f001bf509ed in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f001ef2a760 (LWP 7290)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/render/katelinelayout.cpp:173
#6  0x00007f000baf3b9a in KateLayoutCache::viewLine (this=0x18e39a0, realCursor=...) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/render/katelayoutcache.cpp:395
#7  0x00007f000bb56753 in KateViewInternal::viewLineOffset (this=0x4157d40, virtualCursor=..., offset=0, keepX=<value optimized out>)
    at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:1351
#8  0x00007f000bb5964b in KateViewInternal::makeVisible (this=0x4157d40, c=..., endCol=-1, force=false, center=<value optimized out>, calledExternally=false)
    at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:663
#9  0x00007f000bb59da9 in KateViewInternal::updateCursor (this=0x4157d40, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:1914
#10 0x00007f000bb5a9d9 in KateViewInternal::editEnd (this=0x4157d40, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/view/kateviewinternal.cpp:3399
#11 0x00007f000bab2b51 in KateDocument::editEnd (this=0x4304a80) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/document/katedocument.cpp:977
#12 0x00007f000bab98e6 in KateDocument::removeText (this=0x4304a80, _range=<value optimized out>, block=<value optimized out>)
    at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/document/katedocument.cpp:821
#13 0x00007f000babb45a in KateDocument::backspace (this=0x4304a80, view=<value optimized out>, c=<value optimized out>)
    at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/document/katedocument.cpp:2906
#14 0x00007f000bb4081c in KateView::backspace (this=0x43065a0) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kate/view/kateview.cpp:2295
#15 0x00007f000bb4597d in KateView::qt_metacall (this=0x43065a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff86b74a20)
    at /home/phil/kdemod/core/kdelibs/src/build/kate/kateview.moc:373
#16 0x00007f001d51b95f in QMetaObject::activate (sender=0x41bbaa0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f001c6a3852 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f001c6a58cb in QAction::activate (this=0x41bbaa0, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007f001c6a71d7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007f001d97987d in KAction::event (this=0x0, event=0x7fff86b75090) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kdeui/actions/kaction.cpp:129
#21 0x00007f001c6a995c in QApplicationPrivate::notify_helper (this=0x1141940, receiver=0x41bbaa0, e=0x7fff86b75090) at kernel/qapplication.cpp:4300
#22 0x00007f001c6aff4b in QApplication::notify (this=0x7fff86b766a0, receiver=0x41bbaa0, e=0x7fff86b75090) at kernel/qapplication.cpp:4183
#23 0x00007f001da4e2b6 in KApplication::notify (this=0x7fff86b766a0, receiver=0x41bbaa0, event=0x7fff86b75090) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:302
#24 0x00007f001d508bfc in QCoreApplication::notifyInternal (this=0x7fff86b766a0, receiver=0x41bbaa0, event=0x7fff86b75090) at kernel/qcoreapplication.cpp:704
#25 0x00007f001c6e5676 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff86b75690) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff86b75690) at kernel/qshortcutmap.cpp:879
#27 0x00007f001c6e7477 in QShortcutMap::tryShortcutEvent (this=0x1141a68, o=<value optimized out>, e=0x7fff86b75690) at kernel/qshortcutmap.cpp:364
#28 0x00007f001c6b1a93 in QApplication::notify (this=0x7fff86b766a0, receiver=0x4157d40, e=0x7fff86b75690) at kernel/qapplication.cpp:3746
#29 0x00007f001da4e2b6 in KApplication::notify (this=0x7fff86b766a0, receiver=0x4157d40, event=0x7fff86b75690) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:302
#30 0x00007f001d508bfc in QCoreApplication::notifyInternal (this=0x7fff86b766a0, receiver=0x4157d40, event=0x7fff86b75690) at kernel/qcoreapplication.cpp:704
#31 0x00007f001c75304a in QKeyMapper::sendKeyEvent (keyWidget=0x4157d40, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f001c7555a1 in QKeyMapperPrivate::translateKeyEvent (this=0x116cdd0, keyWidget=0x4157d40, event=<value optimized out>, grab=112) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f001c72ddb4 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff86b76240) at kernel/qapplication_x11.cpp:3394
#34 0x00007f001c758712 in x11EventSourceDispatch (s=0x1143f60, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f0018b53da2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0x00007f0018b57c18 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#37 0x00007f0018b57dcc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0x00007f001d532093 in QEventDispatcherGlib::processEvents (this=0x113fe30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007f001c75830e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f001d507522 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f001d5078fc in QEventLoop::exec (this=0x7fff86b76560, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f001d50b63b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00007f0011f3be1d in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /home/phil/kdemod/core/kdesdk/src/kdesdk-4.4.2/kate/app/katemain.cpp:377
#44 0x0000000000407184 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x10f8a96 "kay;1270807641;101837;6028_TIME2806422") at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kinit/kinit.cpp:717
#45 0x0000000000407afd in handle_launcher_request (sock=8, who=<value optimized out>) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kinit/kinit.cpp:1209
#46 0x00000000004081fb in handle_requests (waitForPid=0) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kinit/kinit.cpp:1402
#47 0x00000000004088d2 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at /home/phil/kdemod/core/kdelibs/src/kdelibs-4.4.2/kinit/kinit.cpp:1845
Comment 1 Dominik Haumann 2010-04-14 19:47:15 UTC
fixed for KDE 4.5.

*** This bug has been marked as a duplicate of bug 226409 ***