Bug 234087 - Plasma crashes immediately after log-in
Summary: Plasma crashes immediately after log-in
Status: RESOLVED DUPLICATE of bug 238005
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-11 21:39 UTC by Philipp Hullmann
Modified: 2010-05-18 09:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hullmann 2010-04-11 21:39:32 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2) "release 231"
Qt Version: 4.6.2
Operating System: Linux 2.6.31.12-0.2-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
Plasma crashed for the first time after unlocking a session locked with the screensaver running. After this, I logged out by killing the X server and logged in again. Plasma crashed again during session start-up (tried two times, this seems to be repeatable). Applications running were kontact and digikam. In the system tray kwallet, hpijs, the updater applet, rsibreak, kgpg. Plasmoids on the desktop are the trashcan, a folder view and the flickr plasmoid. There is an SD card full of jpegs in the card reader, so it might be trying to access that.

The crash can be reproduced every time.

 -- Backtrace:
Application: Plasma-Arbeitsfläche (kdeinit4), signal: Bus error
[Current thread is 1 (Thread 0x7f40e331f750 (LWP 8205))]

Thread 2 (Thread 0x7f40bd23a910 (LWP 8237)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f40e187c692 in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f40e1871b29 in QThreadPoolThread::run (this=0x1230f90) at concurrent/qthreadpool.cpp:140
#4  0x00007f40e187b775 in QThreadPrivate::start (arg=0x1230f90) at thread/qthread_unix.cpp:248
#5  0x00007f40e15ec65d in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00007f40e03b9e1d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f40e331f750 (LWP 8205)):
[KCrash Handler]
#5  0x00007f40e03686d2 in memcpy () from /lib64/libc.so.6
#6  0x00007f40e1e81fc7 in (anonymous namespace)::KPCMemoryDevice::writeData (this=0x22cde40, data=0x7fff1431a1b0 "", len=180) at /usr/include/bits/string3.h:52
#7  0x00007f40e1902638 in QIODevice::write (this=0x22cde40, data=0x7fff1431a150 "", maxSize=180) at io/qiodevice.cpp:1324
#8  0x00007f40e18ee6ba in QDataStream::writeRawData (this=<value optimized out>, s=0x7fff1431a1b0 "", len=180) at io/qdatastream.cpp:1353
#9  0x00007f40e18ee926 in QDataStream::writeBytes (this=0x7fff1431a600, s=0x7fff1431a150 "", len=180) at io/qdatastream.cpp:1337
#10 0x00007f40e18c3313 in operator<< (out=..., str=...) at tools/qstring.cpp:7245
#11 0x00007f40e1e7e81a in KPixmapCache::Private::writeIndexEntry (this=<value optimized out>, stream=..., key=..., dataoffset=1203454) at /usr/src/debug/kdelibs-4.4.2/kdeui/util/kpixmapcache.cpp:843
#12 0x00007f40e1f6059f in KPixmapCache::Private::writeIndex (this=0x797aa0, key=..., dataoffset=1203454) at /usr/src/debug/kdelibs-4.4.2/kdeui/util/kpixmapcache.cpp:1499
#13 0x00007f40e1f6090e in KPixmapCache::insert (this=0x6d1dd0, key=..., pix=...) at /usr/src/debug/kdelibs-4.4.2/kdeui/util/kpixmapcache.cpp:1446
#14 0x00007f40da4da58e in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x76af00) at /usr/src/debug/kdelibs-4.4.2/plasma/theme.cpp:245
#15 0x00007f40da4dff3a in Plasma::Theme::qt_metacall (this=0x6cc0c0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1431a8c0) at /usr/src/debug/kdelibs-4.4.2/build/plasma/theme.moc:111
#16 0x00007f40e198278f in QMetaObject::activate (sender=0x76e3d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f40e197f3e3 in QObject::event (this=0x76e3d0, e=0x7fff1431b050) at kernel/qobject.cpp:1212
#18 0x00007f40e0b0fe1c in QApplicationPrivate::notify_helper (this=0x67ef00, receiver=0x76e3d0, e=0x7fff1431b050) at kernel/qapplication.cpp:4300
#19 0x00007f40e0b163fb in QApplication::notify (this=0x6739c0, receiver=0x76e3d0, e=0x7fff1431b050) at kernel/qapplication.cpp:4183
#20 0x00007f40e1e42506 in KApplication::notify (this=0x6739c0, receiver=0x76e3d0, event=0x7fff1431b050) at /usr/src/debug/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:302
#21 0x00007f40e196f98c in QCoreApplication::notifyInternal (this=0x6739c0, receiver=0x76e3d0, event=0x7fff1431b050) at kernel/qcoreapplication.cpp:704
#22 0x00007f40e199c655 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#23 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:617
#24 0x00007f40e19991e8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#25 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#26 0x00007f40dcddcdee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f40dcde07b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#28 0x00007f40dcde08e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f40e1998eb3 in QEventDispatcherGlib::processEvents (this=0x61a8e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#30 0x00007f40e0bbe51e in QGuiEventDispatcherGlib::processEvents (this=0x7f40cf4dffea, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f40e196e2a2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007f40e196e67c in QEventLoop::exec (this=0x7fff1431b3a0, flags=) at kernel/qeventloop.cpp:201
#33 0x00007f40e19723cb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#34 0x00007f40d426587a in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.4.2/plasma/desktop/shell/main.cpp:112
#35 0x00000000004073b8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x409c52 "0") at /usr/src/debug/kdelibs-4.4.2/kinit/kinit.cpp:717
#36 0x0000000000408070 in handle_launcher_request (sock=9, who=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/kinit/kinit.cpp:1209
#37 0x0000000000408521 in handle_requests (waitForPid=0) at /usr/src/debug/kdelibs-4.4.2/kinit/kinit.cpp:1402
#38 0x0000000000409202 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/kinit/kinit.cpp:1845
The current source language is "auto; currently asm".

Reported using DrKonqi
Comment 1 Beat Wolf 2010-05-18 09:14:26 UTC

*** This bug has been marked as a duplicate of bug 238005 ***