Bug 233806 - I can't verify digital signature(s) in PDF files
Summary: I can't verify digital signature(s) in PDF files
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: PDF backend (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 71 votes (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-09 08:16 UTC by hellgast
Modified: 2019-01-31 19:02 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hellgast 2010-04-09 08:16:52 UTC
Version:            (using KDE 4.3.5)
OS:                Linux
Installed from:    openSUSE RPMs

It will be nice to check authenticity of digitally signed PDF documents in Okular. I can't see anything about digital signature(s) when I open signed document. Thanks.
Comment 1 Pino Toscano 2010-05-27 19:55:46 UTC
This depends on the support in poppler for that:
  https://bugs.freedesktop.org/show_bug.cgi?id=16770
Comment 2 David 2012-03-11 18:49:15 UTC
This bug is old enough, and the poppler related too.
As I red the poppler bug about this issue, it does not seem to be implemented since they appear to not want to add crypto software dependencies.
So, can it be done in okular in other way?
Comment 3 Pino Toscano 2012-03-11 19:01:41 UTC
(In reply to comment #2)
> As I red the poppler bug about this issue, it does not seem to be
> implemented since they appear to not want to add crypto software
> dependencies.

No, it was asked to provide a working test/example showing how to do the whole process of parsing of validation stuff from documents and validation itself.

> So, can it be done in okular in other way?

Even if the actual validation would not be done in poppler itself, poppler (and poppler-qt4 too, for qt4-based applications like okular) has to provide/export the API for it.
Comment 4 Ctibor Brančík 2016-04-11 19:50:31 UTC
With poppler 0.42.0 it is now possible to verify PDF signatures with pdfsig command. Upstream bug was closed as fixed, but further development is apparently needed:
https://bugs.freedesktop.org/show_bug.cgi?id=94376
https://bugs.freedesktop.org/show_bug.cgi?id=94377
https://bugs.freedesktop.org/show_bug.cgi?id=94378
Comment 5 Oliver Sander 2017-01-11 05:41:56 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=94378

is done now.  The other two are not relevant for okular.
Comment 6 Alexander Yavorsky 2017-10-09 14:37:40 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Albert Astals Cid 2019-01-31 19:02:12 UTC
Testing welcome https://tsdgeos.blogspot.com/2019/01/okular-pdf-signature-certificate.html