Bug 233197 - Amarok not removing empty directories after tracks move
Summary: Amarok not removing empty directories after tracks move
Status: RESOLVED DUPLICATE of bug 190881
Alias: None
Product: amarok
Classification: Applications
Component: Collections/Local (show other bugs)
Version: 2.3-GIT
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-03 21:29 UTC by Kuba Serafinowski
Modified: 2012-08-19 16:53 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kuba Serafinowski 2010-04-03 21:29:19 UTC
Version:           2.3-GIT (using KDE 4.4.2)
OS:                Linux
Installed from:    openSUSE RPMs

After move, and deletion of old files, Amarok shows a dialog with: "Could not delete file ." and indeed doesn't remove empty source directories.

the dot may indicate that it's trying to treat a directory as a file.
Comment 1 Kuba Serafinowski 2010-04-03 21:59:42 UTC
Ah, it would be great if Amarok would also remove nested directories. Like music/artist/artist2123/artistblahblah is a source directory, and we move it's content to music/%artist/, then if artistblahblah/, artist2123/, and artist/ contain only themselves all those dirs could be removed.
Comment 2 Casey Link 2010-04-04 06:16:55 UTC

*** This bug has been marked as a duplicate of bug 190881 ***