Bug 233026 - KMail, Kate, Kile: Spellchecking crash, aspell issue?
Summary: KMail, Kate, Kile: Spellchecking crash, aspell issue?
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdeui (show other bugs)
Version: 4.4
Platform: Archlinux Packages Linux
: HI crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 243601 247076 248794 250354 252552 256049 271333 319646 358248 361219 388085 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-04-02 02:23 UTC by Oscar Pereira
Modified: 2018-01-10 15:50 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0


Attachments
New crash information added by DrKonqi (5.96 KB, text/plain)
2011-04-21 21:22 UTC, Christian Trippe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oscar Pereira 2010-04-02 02:23:42 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.33-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
I was trying to reproduce the following situation:

"KMail (which I was using within Kontact) crashed while I was composing an email message. To be more specific, the spell checker highlighted a number (40), and when I right-clicked on it, the program crashed. I was composing a rather lengthy message, and I have Autosave enabled (every 1 min), but the message was *NOT* saved."

I was able to do so (again with the number 40...), and the backtrace is attached.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fdd835e0c72 in aspeller::AffixMgr::suffix_check(aspeller::LookupInfo const&, acommon::ParmString, acommon::CheckInfo&, aspeller::GuessInfo*, int, aspeller::AffEntry*) const ()
   from /usr/lib/libaspell.so.15
#6  0x00007fdd835e135f in aspeller::AffixMgr::affix_check(aspeller::LookupInfo const&, acommon::ParmString, acommon::CheckInfo&, aspeller::GuessInfo*) const () from /usr/lib/libaspell.so.15
#7  0x00007fdd835b25ed in (anonymous namespace)::Working::try_word_n(acommon::ParmString, int) () from /usr/lib/libaspell.so.15
#8  0x00007fdd835b4ecf in (anonymous namespace)::Working::try_one_edit_word() () from /usr/lib/libaspell.so.15
#9  0x00007fdd835b853a in (anonymous namespace)::SuggestImpl::suggest(char const*) () from /usr/lib/libaspell.so.15
#10 0x00007fdd835c95f1 in aspeller::SpellerImpl::suggest(acommon::MutableString) () from /usr/lib/libaspell.so.15
#11 0x00007fdd835f764f in aspell_speller_suggest () from /usr/lib/libaspell.so.15
#12 0x00007fdd8381a28e in aspell_dict_suggest () from /usr/lib/enchant/libenchant_aspell.so
#13 0x00007fdd83e30b9d in enchant_dict_suggest () from /usr/lib/libenchant.so.1
#14 0x00007fdd84037cff in QSpellEnchantDict::suggest(QString const&) const () from /usr/lib/kde4/kspell_enchant.so
#15 0x00007fdd9e030ab5 in Sonnet::Speller::suggest(QString const&) const () from /usr/lib/libkdecore.so.5
#16 0x00007fdd9e5ed32c in Sonnet::Highlighter::suggestionsForWord(QString const&, int) () from /usr/lib/libkdeui.so.5
#17 0x00007fdd9e68424f in KTextEdit::contextMenuEvent(QContextMenuEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007fdd9cfd2338 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x00007fdd9d377596 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x00007fdd9dbb8d17 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#21 0x00007fdd9cf7c5fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x00007fdd9cf82cd3 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x00007fdd9e583256 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#24 0x00007fdd9dbb98fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#25 0x00007fdd9d00212b in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007fdd9d000a4c in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#27 0x00007fdd9d02b292 in ?? () from /usr/lib/libQtGui.so.4
#28 0x00007fdd955e5da2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#29 0x00007fdd955e9c18 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#30 0x00007fdd955e9dcc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#31 0x00007fdd9dbe2d33 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x00007fdd9d02ae8e in ?? () from /usr/lib/libQtGui.so.4
#33 0x00007fdd9dbb8222 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0x00007fdd9dbb85fc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0x00007fdd9dbbc33b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#36 0x0000000000403ace in _start ()

Reported using DrKonqi
Comment 1 Björn Ruberg 2010-04-02 11:44:43 UTC
From the backtrace this much looks like a segfault in aspell
Comment 2 Christophe Giboudeaux 2010-04-02 20:56:25 UTC
Reassign to kspell, they'll know for sure if that's an aspell crash.
Comment 3 Oscar Pereira 2010-04-17 13:12:37 UTC
Even if this is a problem with kspell, is it possible to modify the KMail code that uses kspell, so as to ensure that bugs in the spell checker don't crash the entire KMail application? (not to mention the Kontact framework...)
Comment 4 Christoph Feck 2010-08-08 23:58:48 UTC
*** Bug 247076 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2010-08-09 00:00:19 UTC
*** Bug 243601 has been marked as a duplicate of this bug. ***
Comment 6 Michel Ludwig 2010-08-29 10:33:53 UTC
Could you maybe try out KDE 4.5? Numbers are no longer spell checked there.
Comment 7 otakar.trunecek 2010-08-29 10:45:03 UTC
I had similar problem, reported in Bug 243601, that was marked as duplicate of this one. With KDE 4.5 the bug seems to be gone.
Comment 8 Christoph Feck 2010-09-06 18:39:24 UTC
*** Bug 250354 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2010-09-06 18:40:44 UTC
*** Bug 248794 has been marked as a duplicate of this bug. ***
Comment 10 Christophe Giboudeaux 2010-09-29 13:23:04 UTC
*** Bug 252552 has been marked as a duplicate of this bug. ***
Comment 11 Michel Ludwig 2010-11-17 20:56:46 UTC
*** Bug 256049 has been marked as a duplicate of this bug. ***
Comment 12 Oscar Pereira 2011-01-29 02:54:46 UTC
Due to the risk of additional email loss, I had stop using spell checking in KMail; I've now upgraded to KDE 4.6 and the bug in fact to be gone.
Comment 13 Christophe Giboudeaux 2011-04-20 11:48:50 UTC
*** Bug 271333 has been marked as a duplicate of this bug. ***
Comment 14 Christian Trippe 2011-04-21 21:22:20 UTC
Created attachment 59188 [details]
New crash information added by DrKonqi

kontact (4.6 beta5) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

kmail crashes with segfault when using the automatic spell check and trying to teach specific words after creating an email. 

1. enable the spell check for email editor and use a German dictionary
2. put "1.000" into the body
3. change to a German dictionary if not done
4. the word 1.000 will be underlined/marked as probably wrong
5. right click this word to crash kmail

-- Backtrace (Reduced):
#6  key (this=0x93e0920, linf=..., word=..., ci=..., gi=0x0, sfxopts=0, ppfx=0x0) at modules/speller/default/affix.cpp:133
#7  aspeller::AffixMgr::suffix_check (this=0x93e0920, linf=..., word=..., ci=..., gi=0x0, sfxopts=0, ppfx=0x0) at modules/speller/default/affix.cpp:805
#8  0x00007ffb25085d42 in aspeller::AffixMgr::affix_check (this=0x93e0920, linf=..., word=..., ci=..., gi=0x0) at modules/speller/default/affix.cpp:843
#9  0x00007ffb250576a8 in (anonymous namespace)::Working::try_word_n (this=0x7fff997bd410, str=..., score=0) at modules/speller/default/suggest.cpp:413
#10 0x00007ffb25057b5c in try_word (this=0x7fff997bd410) at modules/speller/default/suggest.cpp:227
Comment 15 Dominik Haumann 2013-08-09 13:13:48 UTC
*** Bug 319646 has been marked as a duplicate of this bug. ***
Comment 16 Dominik Haumann 2013-08-09 13:14:49 UTC
From bug #319646 (KDE 4.9.5), spell checking in Kate:

Thread 1 (Thread 0x7fb6b291c780 (LWP 4127)):
[KCrash Handler]
#6  0x00007fb69cfe718a in aspeller::AffixMgr::suffix_check(aspeller::LookupInfo const&, acommon::ParmString, acommon::CheckInfo&, aspeller::GuessInfo*, int, aspeller::AffEntry*) const () from /usr/lib/libaspell.so.15
#7  0x00007fb69cfe799a in aspeller::AffixMgr::affix_check(aspeller::LookupInfo const&, acommon::ParmString, acommon::CheckInfo&, aspeller::GuessInfo*) const () from /usr/lib/libaspell.so.15
#8  0x00007fb69cfbf095 in ?? () from /usr/lib/libaspell.so.15
#9  0x00007fb69cfc409d in ?? () from /usr/lib/libaspell.so.15
#10 0x00007fb69cfd3020 in aspeller::SpellerImpl::suggest(acommon::MutableString) () from /usr/lib/libaspell.so.15
#11 0x00007fb69cfffa20 in aspell_speller_suggest () from /usr/lib/libaspell.so.15
#12 0x00007fb69d2233bb in ?? () from /usr/lib/enchant/libenchant_aspell.so
#13 0x00007fb69d62d4b6 in enchant_dict_suggest () from /usr/lib/libenchant.so.1
#14 0x00007fb69d857311 in QSpellEnchantDict::suggest (this=0x250d240, word=...) at ../../../../sonnet/plugins/enchant/enchantdict.cpp:63
#15 0x00007fb6b114a1e5 in Sonnet::Speller::suggest (this=0x1251938, word=...) at ../../kdecore/sonnet/speller.cpp:126
#16 0x00007fb6b114dbcd in Sonnet::BackgroundEngine::suggest (this=<optimized out>, word=...) at ../../kdecore/sonnet/backgroundengine.cpp:116
#17 0x00007fb6b114d6a0 in Sonnet::BackgroundChecker::suggest (this=<optimized out>, word=...) at ../../kdecore/sonnet/backgroundchecker.cpp:127
#18 0x00007fb6b097817b in Sonnet::Dialog::updateDialog (this=this@entry=0x1ba8c30, word=...) at ../../kdeui/sonnet/dialog.cpp:298
#19 0x00007fb6b09783eb in Sonnet::Dialog::slotMisspelling (this=0x1ba8c30, word=..., start=<optimized out>) at ../../kdeui/sonnet/dialog.cpp:422
#20 0x00007fb6b013ff5f in QMetaObject::activate (sender=0x1ba8f70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff63016f00) at kernel/qobject.cpp:3547
#21 0x00007fb6b114d783 in Sonnet::BackgroundChecker::misspelling (this=<optimized out>, _t1=..., _t2=2755) at ./backgroundchecker.moc:119
#22 0x00007fb6b013ff5f in QMetaObject::activate (sender=0x1251920, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff63017060) at kernel/qobject.cpp:3547
#23 0x00007fb6b114dc13 in Sonnet::BackgroundEngine::misspelling (this=this@entry=0x1251920, _t1=..., _t2=2755) at ./backgroundengine_p.moc:106
#24 0x00007fb6b114dcc4 in Sonnet::BackgroundEngine::checkNext (this=0x1251920) at ../../kdecore/sonnet/backgroundengine.cpp:98
Comment 17 Dominik Haumann 2013-08-09 13:17:38 UTC
Are the aspell developers aware of this? Someone who can reproduce: Can you install aspell debug packages and provide a proper backtrace?
Comment 18 Jwg716 2013-12-28 10:01:33 UTC
(In reply to comment #7)
> I had similar problem, reported in Bug 243601, that was marked as duplicate
> of this one. With KDE 4.5 the bug seems to be gone.
Comment 19 Jwg716 2013-12-28 10:07:32 UTC
(In reply to comment #18)
> (In reply to comment #7)
> > I had similar problem, reported in Bug 243601, that was marked as duplicate
> > of this one. With KDE 4.5 the bug seems to be gone.

(In reply to comment #17)
> Are the aspell developers aware of this? Someone who can reproduce: Can you
> install aspell debug packages and provide a proper backtrace?

(In reply to comment #17)
> Are the aspell developers aware of this? Someone who can reproduce: Can you
> install aspell debug packages and provide a proper backtrace?

I think I can get thru it Thanks Dom
Comment 20 Martin Sandsmark 2014-01-02 16:35:34 UTC
The improved tokenizer in Sonnet 5.0 fixes this.
Comment 21 Michael Scheffenacker 2014-10-04 23:10:08 UTC
I am using the actual KUbuntu with KDE 4.13.3 and I am still having this problem. And it is really affects my daily work.

Is to get around this? I am glad, that this is fixed in KDE 5 but, I have to find a way to work with it until KUbuntu uses it.
Comment 22 Christoph Feck 2014-10-05 00:38:28 UTC
Michael, the crash seems to be in libaspell. Can you add exact steps to reproduce this crash? Also, please show the backtrace, it might be a different crash.
Comment 23 Michael Scheffenacker 2014-10-05 01:35:57 UTC
Christoph, initially the issue appeared on with Kile on the actual Ubuntu (gnome-shell) version, so I thought it was a KDE–Gnome problem, therefore I installed Kubuntu parallel today.

The Kubuntu was absolute fresh, I installed livetex-full kile and aspell-de (and a few other packages I usually install like emacs, chromium, subversion,… nothing extraordinary). Kile crashed after spell checking a few words. After restart it crashed as soon, as I opened the spell checker. The error was a seg fault.
After that I invested about 2 hours to create a proper bug report (installation of proper -dbg packages) when I was about to finish the report, the crash reporting assistant told me, that the information is redundant an by posting the report I might be wasting developers time so I cancelled. After that I removed most of the packages to save disk space – but now I have to do it again, okay.

Backtrace:
Application: Kile (kile), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb7b3b8d7c0 (LWP 2040))]

Thread 4 (Thread 0x7fb79ccea700 (LWP 2041)):
#0  0x00007fb7afad7c6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb7ab038fe4 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7fb798003480, timeout=-1, context=0x7fb7980009a0) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:4028
#2  g_main_context_iterate (context=context@entry=0x7fb7980009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3729
#3  0x00007fb7ab0390ec in g_main_context_iteration (context=0x7fb7980009a0, may_block=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#4  0x00007fb7b13a27be in QEventDispatcherGlib::processEvents (this=0x7fb7980008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007fb7b13740af in QEventLoop::processEvents (this=this@entry=0x7fb79cce9de0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb7b13743a5 in QEventLoop::exec (this=this@entry=0x7fb79cce9de0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fb7b1270c5f in QThread::exec (this=this@entry=0x210a560) at thread/qthread.cpp:537
#8  0x00007fb7b1355823 in QInotifyFileSystemWatcherEngine::run (this=0x210a560) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007fb7b127332f in QThreadPrivate::start (arg=0x210a560) at thread/qthread_unix.cpp:349
#10 0x00007fb7ab709182 in start_thread (arg=0x7fb79ccea700) at pthread_create.c:312
#11 0x00007fb7afae4fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fb797b8e700 (LWP 2044)):
#0  0x00007fb7ab07a62a in g_mutex_get_impl (mutex=0x7fb7900009a0) at /build/buildd/glib2.0-2.40.0/./glib/gthread-posix.c:120
#1  0x00007fb7ab07a9b9 in g_mutex_unlock (mutex=mutex@entry=0x7fb7900009a0) at /build/buildd/glib2.0-2.40.0/./glib/gthread-posix.c:228
#2  0x00007fb7ab038680 in g_main_context_prepare (context=context@entry=0x7fb7900009a0, priority=priority@entry=0x7fb797b8dca8) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3350
#3  0x00007fb7ab038f03 in g_main_context_iterate (context=context@entry=0x7fb7900009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3714
#4  0x00007fb7ab0390ec in g_main_context_iteration (context=0x7fb7900009a0, may_block=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#5  0x00007fb7b13a27be in QEventDispatcherGlib::processEvents (this=0x7fb7900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007fb7b13740af in QEventLoop::processEvents (this=this@entry=0x7fb797b8dde0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb7b13743a5 in QEventLoop::exec (this=this@entry=0x7fb797b8dde0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb7b1270c5f in QThread::exec (this=this@entry=0x2747000) at thread/qthread.cpp:537
#9  0x00007fb7b1355823 in QInotifyFileSystemWatcherEngine::run (this=0x2747000) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fb7b127332f in QThreadPrivate::start (arg=0x2747000) at thread/qthread_unix.cpp:349
#11 0x00007fb7ab709182 in start_thread (arg=0x7fb797b8e700) at pthread_create.c:312
#12 0x00007fb7afae4fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fb78fdfc700 (LWP 2065)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb7add06ffb in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb7ae004f00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb7add07039 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb7ab709182 in start_thread (arg=0x7fb78fdfc700) at pthread_create.c:312
#4  0x00007fb7afae4fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fb7b3b8d7c0 (LWP 2040)):
[KCrash Handler]
#6  0x00007fb79488c2e2 in aspeller::AffixMgr::suffix_check(aspeller::LookupInfo const&, acommon::ParmString, acommon::CheckInfo&, aspeller::GuessInfo*, int, aspeller::AffEntry*) const () from /usr/lib/libaspell.so.15
#7  0x00007fb79488c99d in aspeller::AffixMgr::affix_check(aspeller::LookupInfo const&, acommon::ParmString, acommon::CheckInfo&, aspeller::GuessInfo*) const () from /usr/lib/libaspell.so.15
#8  0x00007fb794864ba7 in ?? () from /usr/lib/libaspell.so.15
#9  0x00007fb79486a775 in ?? () from /usr/lib/libaspell.so.15
#10 0x00007fb794878984 in aspeller::SpellerImpl::suggest(acommon::MutableString) () from /usr/lib/libaspell.so.15
#11 0x00007fb7948a3e0f in aspell_speller_suggest () from /usr/lib/libaspell.so.15
#12 0x00007fb794ac83e9 in ?? () from /usr/lib/x86_64-linux-gnu/enchant/libenchant_aspell.so
#13 0x00007fb7952ed2db in enchant_dict_suggest () from /usr/lib/x86_64-linux-gnu/libenchant.so.1
#14 0x00007fb7954f7c22 in QSpellEnchantDict::suggest (this=0x3394230, word=...) at ../../../../sonnet/plugins/enchant/enchantdict.cpp:62
#15 0x00007fb7b1865645 in Sonnet::Speller::suggest (this=0x334e718, word=...) at ../../kdecore/sonnet/speller.cpp:126
#16 0x00007fb7b1868d6d in Sonnet::BackgroundEngine::suggest (this=<optimized out>, word=...) at ../../kdecore/sonnet/backgroundengine.cpp:116
#17 0x00007fb7b1868850 in Sonnet::BackgroundChecker::suggest (this=<optimized out>, word=...) at ../../kdecore/sonnet/backgroundchecker.cpp:127
#18 0x00007fb7b1e0f95e in Sonnet::Dialog::updateDialog (this=this@entry=0x33bc2a0, word=...) at ../../kdeui/sonnet/dialog.cpp:298
#19 0x00007fb7b1e10876 in Sonnet::Dialog::slotMisspelling (this=0x33bc2a0, word=..., start=<optimized out>) at ../../kdeui/sonnet/dialog.cpp:422
#20 0x00007fb7b138987a in QMetaObject::activate (sender=0x35b82d0, m=m@entry=0x7fb7b1b90fa0 <Sonnet::BackgroundChecker::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffa9e7f290) at kernel/qobject.cpp:3539
#21 0x00007fb7b1868933 in Sonnet::BackgroundChecker::misspelling (this=<optimized out>, _t1=..., _t2=87) at ./backgroundchecker.moc:118
#22 0x00007fb7b138987a in QMetaObject::activate (sender=sender@entry=0x334e700, m=m@entry=0x7fb7b1b91080 <Sonnet::BackgroundEngine::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffa9e7f3d0) at kernel/qobject.cpp:3539
#23 0x00007fb7b1868db3 in Sonnet::BackgroundEngine::misspelling (this=this@entry=0x334e700, _t1=..., _t2=87) at ./backgroundengine_p.moc:105
#24 0x00007fb7b1868e5b in Sonnet::BackgroundEngine::checkNext (this=0x334e700) at ../../kdecore/sonnet/backgroundengine.cpp:98
#25 0x00007fb7b138dc1e in QObject::event (this=0x334e700, e=<optimized out>) at kernel/qobject.cpp:1194
#26 0x00007fb7b0493e2c in QApplicationPrivate::notify_helper (this=this@entry=0x2027370, receiver=receiver@entry=0x334e700, e=e@entry=0x3396320) at kernel/qapplication.cpp:4567
#27 0x00007fb7b049a4a0 in QApplication::notify (this=this@entry=0x7fffa9e803b0, receiver=receiver@entry=0x334e700, e=e@entry=0x3396320) at kernel/qapplication.cpp:4353
#28 0x00007fb7b1dbfd1a in KApplication::notify (this=0x7fffa9e803b0, receiver=0x334e700, event=0x3396320) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fb7b13754dd in QCoreApplication::notifyInternal (this=0x7fffa9e803b0, receiver=receiver@entry=0x334e700, event=event@entry=0x3396320) at kernel/qcoreapplication.cpp:953
#30 0x00007fb7b1378b3d in sendEvent (event=0x3396320, receiver=0x334e700) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1fe7670) at kernel/qcoreapplication.cpp:1577
#32 0x00007fb7b1378fe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#33 0x00007fb7b13a2f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 postEventSourceDispatch (s=0x20263c0) at kernel/qeventdispatcher_glib.cpp:287
#35 0x00007fb7ab038e04 in g_main_dispatch (context=0x2025e20) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3064
#36 g_main_context_dispatch (context=context@entry=0x2025e20) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3663
#37 0x00007fb7ab039048 in g_main_context_iterate (context=context@entry=0x2025e20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3734
#38 0x00007fb7ab0390ec in g_main_context_iteration (context=0x2025e20, may_block=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#39 0x00007fb7b13a27a1 in QEventDispatcherGlib::processEvents (this=0x2024f80, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#40 0x00007fb7b0535bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007fb7b13740af in QEventLoop::processEvents (this=this@entry=0x7fffa9e7fa30, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007fb7b13743a5 in QEventLoop::exec (this=this@entry=0x7fffa9e7fa30, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007fb7b1379b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#44 0x0000000000436912 in ?? ()
#45 0x00007fb7afa0bec5 in __libc_start_main (main=0x435720, argc=1, argv=0x7fffa9e80518, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa9e80508) at libc-start.c:287
#46 0x0000000000438d05 in _start ()
Comment 24 Christoph Feck 2014-10-06 19:36:09 UTC
This is indeed a crash deep in libaspell. Please report this issue directly to aspell authors.
Comment 25 Christoph Feck 2018-01-10 15:49:48 UTC
*** Bug 361219 has been marked as a duplicate of this bug. ***
Comment 26 Christoph Feck 2018-01-10 15:50:03 UTC
*** Bug 358248 has been marked as a duplicate of this bug. ***
Comment 27 Christoph Feck 2018-01-10 15:50:13 UTC
*** Bug 388085 has been marked as a duplicate of this bug. ***