Bug 232915 - Tray icons do not destroy themselves after the programs exit
Summary: Tray icons do not destroy themselves after the programs exit
Status: RESOLVED UPSTREAM
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-systemtray (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 232650 233333 233570 238461 239047 240021 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-04-01 01:25 UTC by LuRan
Modified: 2010-06-04 20:46 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot under 4.5 beta1 (14.05 KB, image/png)
2010-06-01 13:32 UTC, Weng Xuetian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LuRan 2010-04-01 01:25:22 UTC
Version:           svn snapshot (using Devel)
Compiler:          gcc 4.4.3 with gentoo patches
OS:                Linux
Installed from:    Compiled sources

The bug seems only happen in KDE program with a tray icon: after the program exit, no matter if it is killed by me or crashed, the tray icon still stays in the system tray. If I restart the program there will be two icon show up in the system tray. The tray icon of the dead program does not respond to mouse clicks, but if I hover the mouse on it, some help tips still pop up.
Comment 1 Dario Andres 2010-04-01 14:38:40 UTC
Which kind of KDE apps should this behaviour ? (I'm trying to notice if they use the new system tray protocol..)
Some changes were made in the underline technologies recently on trunk, so this may be a regression.
Also, what is your SVN revision/branch ?
Regards
Comment 2 LuRan 2010-04-01 15:05:33 UTC
I have tested with kopete, amarok, and knetworkmanager (the monolithic app, not the plasma applet). The pure qt client of last.fm does not have this problem. I am using svn r1109287 now, but the bug has been there for at least a week I think.
Comment 3 Dario Andres 2010-04-03 14:14:46 UTC
I have experienced this but only with the "Hidden icons" list popup.. and I think it was fixed in recent builds... May be that one fixed the bug you are mentioning too ?
Comment 4 LuRan 2010-04-04 17:47:32 UTC
I tested r1110411 yesterday but the bug still there. I am not sure what you mean by ""Hidden icons" list popup", I have the default settings, all the icons are "auto" in the autohide configuration dialog. And if I reload the systemtray, the name for the dead icon will become something like "StatusNotiferItemxxx" instead of the name of the program.
Comment 5 Dario Andres 2010-04-04 17:52:21 UTC
About "Hidden icons" list popup: When you click the "Unhide icons" arrow in  the systray, a list appears (this is a new KDE SC 4.5 behavior)
Comment 6 LuRan 2010-04-04 18:05:17 UTC
Oh, I see, when I set some icon to "hide" in the config dialog that little triangle will show up. I can hide the dead icon in this way, but it still show up in the hidden icon popup.
Comment 7 LuRan 2010-04-05 02:41:30 UTC
FYI, I removed my KDEHOME(.kde4) and tried again, the bug can still be reproduced, so it does not seems to be caused by outdated config files.
Comment 8 Dario Andres 2010-04-05 14:29:33 UTC
*** Bug 233333 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2010-04-07 14:21:51 UTC
From bug 233570:
---
Icons remain on the systray even after the application quits. Eg. start amarok,
its icon appears. Right click on it, quit -> the icon is still there. Start
amarok again, a new amarok icon appears. Same with konversation. Now do a
kquitapp plasma-desktop;plasma-desktop: the icons disappear, but their place is
still reserved in the systray, and you will have lot of "unused" place.
Removing/readding the system tray doesn't help either.
Comment 10 Dario Andres 2010-04-07 14:21:54 UTC
*** Bug 233570 has been marked as a duplicate of this bug. ***
Comment 11 Marco Martin 2010-04-20 20:05:03 UTC
SVN commit 1116963 by mart:

watch just the sevice, not the service+path
BUG: 232915


 M  +3 -2      statusnotifierwatcher.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1116963
Comment 12 LuRan 2010-04-21 04:10:31 UTC
Just tested with 1116965, the icons of kopete and amarok still stay in the systemtray after the program quitted. Cannot find a place to reopen the bug report :(
Comment 13 András Manţia 2010-04-22 15:44:11 UTC
Reopening, as the bug is still there.
Comment 14 Marco Martin 2010-04-22 15:53:47 UTC
@LuRan: are you sure you updated really everything and restared kded4? just restarting plasma won't work
the bug really is not reproducible anymore there
Comment 15 András Manţia 2010-04-22 16:00:14 UTC
I did do it...
Comment 16 LuRan 2010-04-22 17:34:23 UTC
@Marco: I removed the old binarys and reinstalled everything, and restarted kde. I did not try to remove the old config files though.
Comment 17 Mikko C. 2010-04-22 17:36:27 UTC
I can confirm it's *not* fixed here, with kde trunk.
I did not try removing the config files either.
Comment 18 Dima Ryazanov 2010-04-29 09:42:13 UTC
*** Bug 232650 has been marked as a duplicate of this bug. ***
Comment 19 András Manţia 2010-05-18 15:39:27 UTC
Still there in trunk from today.
Comment 20 Marco Martin 2010-05-22 15:12:47 UTC
*** Bug 238461 has been marked as a duplicate of this bug. ***
Comment 21 LuRan 2010-05-23 16:29:11 UTC
I have tried qt 4.7 snapshot (c12af169a157a5ba2e25289b996648a9a8e3cb9f) and the bug is gone. So maybe this bug is somehow related to qt?
Comment 22 Mikko C. 2010-05-28 17:46:05 UTC
*** Bug 239047 has been marked as a duplicate of this bug. ***
Comment 23 Vladislav Bogdanov 2010-05-30 08:58:21 UTC
*** Bug 240021 has been marked as a duplicate of this bug. ***
Comment 24 András Manţia 2010-05-31 11:38:14 UTC
The bug seems to not happen with Qt 4.6.3.
Comment 25 Weng Xuetian 2010-06-01 07:10:39 UTC
I can confirm this with KDE 4.5 beta 1, but only occurs with statusicon that use new kde tray icon(which support plasma tooltip), not with the old one like use xlib or gtk.

Maybe there is some problem with such tray icon using dbus.
Comment 26 Marco Martin 2010-06-01 09:55:31 UTC
@Weng Xuetian: what Qt version do you use?
Comment 27 Weng Xuetian 2010-06-01 13:31:28 UTC
Archlinux 
qt 4.6.2-4
KDE 4.5 beta 1 compiled from source (KDE 4.4.3 works well for me, with the same qt)

I think it maybe not cause by qt?
I can see such entry like "org.kde.StatusNotifierItem-936-1/StatusNotifierItem" in system tray setings-> entries after a tray icon with plasma support exit. Seems some none existing item is not removed. And I can not find that item from qdbus result.

And restart plasma will not fix this problem, only logout and login will work.
Comment 28 Weng Xuetian 2010-06-01 13:32:57 UTC
Created attachment 47554 [details]
Screenshot under 4.5 beta1
Comment 29 Ian Whyman (thev00d00) 2010-06-01 16:14:53 UTC
Fixed here with Qt 4.7_beta1
Comment 30 PhilC 2010-06-01 19:08:43 UTC
I had this problem with Qt 4.6.2, but it's fixed with both Qt 4.6.3 and 4.7.
Comment 31 Weng Xuetian 2010-06-02 13:21:09 UTC
You guys are right.. compile with qt 4.6-stable branck.. it fixed..
Comment 32 Marco Martin 2010-06-04 20:46:45 UTC
is a Qt bug, resolved in 4.6.3