Bug 232624 - Can't stack (sum) multiple sensor plots
Summary: Can't stack (sum) multiple sensor plots
Status: RESOLVED FIXED
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 181778 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-29 22:42 UTC by sheeettin
Modified: 2011-03-25 13:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sheeettin 2010-03-29 22:42:49 UTC
Version:           4.4.1 (KDE 4.4.1) (using 4.4.1 (KDE 4.4.1), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32-17-generic

I used to use ksysguard in in KDE 3.x, and I liked it very much. Then I switched to KDE4, and didn't like the new ksysguard, so I didn't use it.
Now, I'm trying to set it up with relevant sensor displays, but there's one crucial feature missing: the ability to stack sensors.

In KDE3, you could stack plots on top of each other (along the Y/data axis). This was perfect for graphs like memory or CPU usage (split into app/cache/buf or usr/sys/nice, respectively), as they should sum to a total.
This behavior is not present in KDE4's ksysguard. Multiple graphs are stacked along the "Z axis", i.e. they are not summed. They overlap.

This is good for sensors such as multiple temperatures, as you don't want to look at the total temperature in your case. However, as above, for some data, this makes the graph worthless.

There should probably be a per-display setting to set this behavior.
Comment 1 Manuel Amador (Rudd-O) 2010-07-23 11:58:00 UTC
I would like to see a per-display option for this too.
Comment 2 Simon Elmir 2011-03-25 06:03:35 UTC
kSignalPlotter already has support for stacked beams, "stackGraph". The default is false, so we shouldn't break anything that doesn't currently use it.
FancyPlotterSettings has an option for stacking the beams, "mStackBeams" which is currently commented out.

If I'm reading this correctly, all the work that needs to be done is to:

*Uncomment in FancyPlotterSettings.

*Expose the setting to FancyPlotter:
FancyPlotter.cpp:
In: void FancyPlotter::configureSettings()
add: mSettingsDialog->setStackBeams( mPlotter->stackGraph() );
In: void FancyPlotter::applySettings()
add: mPlotter->setStackGraph( mSettingsDialog->stackBeams() );

*Add support for the option in the handling of .sgrd files. (I don't know where to look for this in the source.)
Comment 3 John Tapsell 2011-03-25 09:08:12 UTC
*** Bug 181778 has been marked as a duplicate of this bug. ***
Comment 4 John Tapsell 2011-03-25 13:14:09 UTC
Git commit 795968a85762a4807d387f4cca1e03eb1d3d516e by John Tapsell.
Committed on 25/03/2011 at 09:34.
Pushed by johnflux into branch 'master'.

Add back support for Stacked Beams

BUG:232624

M  +5    -0    ksysguard/gui/SensorDisplayLib/FancyPlotter.cpp     
M  +2    -2    ksysguard/gui/SensorDisplayLib/FancyPlotterSettings.cpp     

http://commits.kde.org/kde-workspace/795968a85762a4807d387f4cca1e03eb1d3d516e
Comment 5 John Tapsell 2011-03-25 13:14:09 UTC
Git commit 0e0e387086ee3005c79fca09ad975f0fbc59799b by John Tapsell.
Committed on 25/03/2011 at 12:08.
Pushed by johnflux into branch 'master'.

SignalPlotter - Fix support for stacked graphs

CCBUG:232624

M  +36   -14   libs/ksysguard/signalplotter/ksignalplotter.cpp     
M  +3    -3    libs/ksysguard/tests/CMakeLists.txt     
M  +17   -0    libs/ksysguard/tests/signalplotterbenchmark.cpp     
M  +1    -0    libs/ksysguard/tests/signalplotterbenchmark.h     

http://commits.kde.org/kde-workspace/0e0e387086ee3005c79fca09ad975f0fbc59799b
Comment 6 John Tapsell 2011-03-25 13:15:58 UTC
Git commit a696f0aed05844d2281b35fdb83723aae50e15c2 by John Tapsell.
Committed on 25/03/2011 at 09:34.
Pushed by johnflux into branch 'KDE/4.6'.

Add back support for Stacked Beams

BUG:232624

M  +5    -0    ksysguard/gui/SensorDisplayLib/FancyPlotter.cc     
M  +2    -2    ksysguard/gui/SensorDisplayLib/FancyPlotterSettings.cc     

http://commits.kde.org/kde-workspace/a696f0aed05844d2281b35fdb83723aae50e15c2
Comment 7 John Tapsell 2011-03-25 13:16:00 UTC
Git commit 4798035cfb56b477dc70d6f589b97b5926acc9bd by John Tapsell.
Committed on 25/03/2011 at 12:08.
Pushed by johnflux into branch 'KDE/4.6'.

SignalPlotter - Fix support for stacked graphs

CCBUG:232624

M  +36   -14   libs/ksysguard/signalplotter/ksignalplotter.cpp     
M  +3    -3    libs/ksysguard/tests/CMakeLists.txt     
M  +17   -0    libs/ksysguard/tests/signalplotterbenchmark.cpp     
M  +1    -0    libs/ksysguard/tests/signalplotterbenchmark.h     

http://commits.kde.org/kde-workspace/4798035cfb56b477dc70d6f589b97b5926acc9bd