Bug 232480 - opening configuration of internet services makes Amarok to hang
Summary: opening configuration of internet services makes Amarok to hang
Status: RESOLVED DUPLICATE of bug 231398
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.3.0
Platform: OpenSUSE Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-28 17:02 UTC by Silver Salonen
Modified: 2010-03-28 17:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silver Salonen 2010-03-28 17:02:22 UTC
Version:           2.3.0 (using KDE 4.4.1)
Installed from:    openSUSE RPMs

Amarok runs fine, but when I open internet services in Amarok's configuration, Amarok hangs taking all the CPU it can. I don't have any internet services ticked though. When I click on 'close' button of configuration dialog and wait long enough, it gets closed and Amarok continues to run fine.

I can provide Amarok's settings if needed.
Comment 1 Silver Salonen 2010-03-28 17:05:31 UTC
When ran from command line, I see these messages, when Amarok starts hanging:

amarok(13828)/kutils (KPluginSelector) KPluginSelector::addPlugins: cfgGroup =  0xbfef1920
amarok(13828)/kdecore (KPluginInfo): found  1  offers for  "amarok_service_ampache"
amarok(13828)/kdecore (KPluginInfo): found  0  offers for  "amarok_service_jamendo"
amarok(13828)/kdecore (KPluginInfo): found  1  offers for  "amarok_service_lastfm"
amarok(13828)/kdecore (KPluginInfo): found  1  offers for  "amarok_service_mp3tunes"
amarok(13828)/kdecore (KPluginInfo): found  1  offers for  "amarok_service_magnatunestore"
amarok(13828)/kdecore (KPluginInfo): found  0  offers for  "amarok_service_opmldirectory"
QObject::connect: Cannot connect (null)::clicked() to PlaybackConfig::configureEqualizer()
Comment 2 Sven Krohlas 2010-03-28 17:16:44 UTC

*** This bug has been marked as a duplicate of bug 231398 ***