Bug 232421 - large-folders copy paste dolphin
Summary: large-folders copy paste dolphin
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-28 01:49 UTC by fairy._.queen
Modified: 2010-03-28 14:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fairy._.queen 2010-03-28 01:49:53 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was moving a large folder from Desktop to data vfat HDD with Dolphin when Plasma crashed.
No application either than Dolphin was open.

 -- Backtrace:
Application: Spazio di lavoro di Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77e7700 (LWP 1498))]

Thread 2 (Thread 0xac60eb70 (LWP 1500)):
#0  0x0048c422 in __kernel_vsyscall ()
#1  0x0028ae15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0550e87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x004dce67 in QWaitConditionPrivate::wait (this=0xa232db8, mutex=0xa232db4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0xa232db8, mutex=0xa232db4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x04351922 in QHostInfoAgent::run (this=0xa232da8) at kernel/qhostinfo.cpp:260
#6  0x004dbe32 in QThreadPrivate::start (arg=0xa232da8) at thread/qthread_unix.cpp:188
#7  0x0028680e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x055018de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77e7700 (LWP 1498)):
[KCrash Handler]
#6  0x00a1d038 in KFileItem::isDir (this=0xadebc20) at ../../kio/kio/kfileitem.cpp:969
#7  0x00a0b192 in KDirModelPrivate::removeFromNodeHash (this=0xa7701b0, node=0xadebc20, url=...) at ../../kio/kio/kdirmodel.cpp:200
#8  0x00a0c08a in KDirModelPrivate::_k_slotDeleteItems (this=0xa7701b0, items=...) at ../../kio/kio/kdirmodel.cpp:487
#9  0x00a0dd50 in KDirModel::qt_metacall (this=0xada9828, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xbfe320c8) at ./kdirmodel.moc:83
#10 0x005e2263 in QMetaObject::activate (sender=0xaec3100, from_signal_index=17, to_signal_index=17, argv=0xbfe320c8) at kernel/qobject.cpp:3113
#11 0x005e2ec2 in QMetaObject::activate (sender=0xaec3100, m=0xb8203c, local_signal_index=13, argv=0xbfe320c8) at kernel/qobject.cpp:3187
#12 0x009f0373 in KDirLister::itemsDeleted (this=0xaec3100, _t1=...) at ./kdirlister.moc:289
#13 0x009f13f9 in KDirLister::Private::emitItemsDeleted (this=0xae37d58, _items=...) at ../../kio/kio/kdirlister.cpp:2351
#14 0x00a00ee6 in KDirListerCache::itemsDeleted (this=0xa1e7500, listers=..., deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#15 0x00a02a12 in KDirListerCache::slotFilesRemoved (this=0xa1e7500, fileList=...) at ../../kio/kio/kdirlister.cpp:808
#16 0x00a02e48 in KDirListerCache::slotFilesRemoved (this=0xa1e7500, fileList=...) at ../../kio/kio/kdirlister.cpp:763
#17 0x00a03885 in KDirListerCache::qt_metacall (this=0xa1e7500, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfe323e8) at ./kdirlister_p.moc:92
#18 0x005e2263 in QMetaObject::activate (sender=0xa17c918, from_signal_index=9, to_signal_index=9, argv=0xbfe323e8) at kernel/qobject.cpp:3113
#19 0x005e2ec2 in QMetaObject::activate (sender=0xa17c918, m=0xb82294, local_signal_index=4, argv=0xbfe323e8) at kernel/qobject.cpp:3187
#20 0x00a0f4b3 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0xa17c918, _t1=...) at ./kdirnotify.moc:125
#21 0x00a0f6b5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0xa17c918, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfe3256c) at ./kdirnotify.moc:83
#22 0x08eb17b4 in QDBusConnectionPrivate::deliverCall (this=0x9f0c978, object=0xa17c918, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:891
#23 0x08eb9197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#24 0x005dc5fe in QObject::event (this=0xa17c918, e=0xaef9e80) at kernel/qobject.cpp:1111
#25 0x0103ef54 in QApplicationPrivate::notify_helper (this=0x9f11a90, receiver=0xa17c918, e=0xaef9e80) at kernel/qapplication.cpp:4056
#26 0x0104667c in QApplication::notify (this=0x9f0bac0, receiver=0xa17c918, e=0xaef9e80) at kernel/qapplication.cpp:3603
#27 0x00d5ebfa in KApplication::notify (this=0x9f0bac0, receiver=0xa17c918, event=0xaef9e80) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x005cc6cb in QCoreApplication::notifyInternal (this=0x9f0bac0, receiver=0xa17c918, event=0xaef9e80) at kernel/qcoreapplication.cpp:610
#29 0x005cd2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9e99e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9e99e48) at kernel/qcoreapplication.cpp:1247
#31 0x005cd47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#32 0x005f73ff in QCoreApplication::sendPostedEvents (s=0x9f13b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#33 postEventSourceDispatch (s=0x9f13b10) at kernel/qeventdispatcher_glib.cpp:210
#34 0x02da7e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x02dab730 in ?? () from /lib/libglib-2.0.so.0
#36 0x02dab863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x005f702c in QEventDispatcherGlib::processEvents (this=0x9f11880, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#38 0x010dfbe5 in QGuiEventDispatcherGlib::processEvents (this=0x9f11880, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#39 0x005cac79 in QEventLoop::processEvents (this=0xbfe32cd4, flags=) at kernel/qeventloop.cpp:149
#40 0x005cb0ca in QEventLoop::exec (this=0xbfe32cd4, flags=...) at kernel/qeventloop.cpp:201
#41 0x005cd53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#42 0x0103edd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#43 0x01c2980d in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#44 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9ed5608 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80511a5 "0") at ../../kinit/kinit.cpp:677
#45 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#46 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#47 0x0804fbaf in main (argc=2, argv=0xbfe33534, envp=0xbfe33540) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 217045

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-28 14:49:57 UTC
This is being tracked at bug 196695. The situation should have improved on KDE SC 4.4.
Regards

*** This bug has been marked as a duplicate of bug 196695 ***