Bug 232104 - Network Manager plasma widget wifi
Summary: Network Manager plasma widget wifi
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-25 13:51 UTC by thelanzers
Modified: 2010-03-26 13:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thelanzers 2010-03-25 13:51:27 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When kubuntu it's started, netwok-manager plasma widget doen't start. When I
restart it by hand with the command (as root):
/etc/init.d/network-manager restart
it shows a window error message with a button to restart it and send bug error.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x000000a8 in ?? ()
#7  0x0014e25e in qobject_cast<Knm::InterfaceConnection const*> (first=0x80697e0, second=0x9cbd280) at /usr/include/qt4/QtCore/qobject.h:456
#8  activatableLessThan (first=0x80697e0, second=0x9cbd280) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:184
#9  0x0014e4e2 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:384
#10 0x0014e697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x9ccd2d0, activatable=0x9cc7c10)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#11 SortedActivatableList::handleAdd (this=0x9ccd2d0, activatable=0x9cc7c10) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#12 0x0013cd03 in ActivatableList::addActivatableInternal (this=0x9c60c48, activatable=0x9cc7c10)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#13 0x0013cd9c in ActivatableList::addActivatable (this=0x9c60c48, activatable=0x80697e0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#14 0x00140767 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x9ccac68, addedConnection=0x9cd1378)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x0013e2fe in NetworkInterfaceActivatableProvider::init (this=0x9ccac68)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x0013d520 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x9cb17d0, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#17 0x00136a9b in NetworkInterfaceMonitor::qt_metacall (this=0x9cb17d0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe98aa8)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#18 0x095e0263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#19 0x095e0ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x001bb8b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#21 0x001bc346 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0x001bc3c7 in ?? () from /usr/lib/libsolidcontrol.so.4
#23 0x095e0263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#24 0x095e0ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#25 0x05835143 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0x058366a8 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x0583987d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x095e0263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#29 0x095e0ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#30 0x05845e53 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0x05846385 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#32 0x001f77b4 in ?? () from /usr/lib/libQtDBus.so.4
#33 0x001ff197 in ?? () from /usr/lib/libQtDBus.so.4
#34 0x095da5fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x01021f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#36 0x0102967c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x00947bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#38 0x095ca6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#39 0x095cb2b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#40 0x095cb47d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#41 0x095f53ff in ?? () from /usr/lib/libQtCore.so.4
#42 0x063e7e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x063eb730 in ?? () from /lib/libglib-2.0.so.0
#44 0x063eb863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x095f502c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x010c2be5 in ?? () from /usr/lib/libQtGui.so.4
#47 0x095c8c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x095c90ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x095cb53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#50 0x01021dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#51 0x08052905 in main (argc=1, argv=0xbfe99964) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-26 13:50:53 UTC
This bug is being tracked at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***