Bug 232074 - Dolphin Crashed after file transfer to Usb Drive. large file 700MB
Summary: Dolphin Crashed after file transfer to Usb Drive. large file 700MB
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-25 05:59 UTC by Skel
Modified: 2010-03-25 12:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Skel 2010-03-25 05:59:26 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Linux Mint 8 Helena LXDE

What I was doing when the application crashed:
Dolphin crashed, File transfer to Usb. It restarted afterwards. Usb was 4Gb generic. Running Kde on 4.3.1 on Linux mint 8. 

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7780920 (LWP 6887))]

Thread 2 (Thread 0xb2f81b70 (LWP 6895)):
#0  0x00f75422 in __kernel_vsyscall ()
#1  0x057a9142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x01c208d4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e709ff in ?? () from /usr/lib/libxine.so.1
#4  0x057a480e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x01c138de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7780920 (LWP 6887)):
[KCrash Handler]
#6  0x01a07829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0x006f1d89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x0022528e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x0021475f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x00e2ba36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x00e2f6bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x00e2f902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x00e309a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x01a69263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x01a69ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x01aa3667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0x01a6e9ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0x01a633bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x01096f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x0109e67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00b5ebfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x01a536cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x01a807ce in ?? () from /usr/lib/libQtCore.so.4
#24 0x01a7e0e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0x02420e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x02424730 in ?? () from /lib/libglib-2.0.so.0
#27 0x02424863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x01a7e02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x01137be5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x01a51c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x01a520ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x01a5453f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0x01096dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-25 12:05:33 UTC
Fixed in KDE SC 4.3.5 and 4.4
Regards

*** This bug has been marked as a duplicate of bug 211525 ***