Bug 231861 - What I was doing when the application crashed: logininto kubuntu
Summary: What I was doing when the application crashed: logininto kubuntu
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-23 03:21 UTC by thelanzers
Modified: 2010-03-28 00:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thelanzers 2010-03-23 03:21:54 UTC
Version:            (using KDE 4.3.2)
OS:                Linux
Installed from:    Ubuntu Packages

When kubuntu it's started, netwok-manager plasma widget doen't restart. When I restart it by hand with the command (as root):
/etc/init.d/network-manager restart
it shows a window error message with a button to restart it and send bug error.
Comment 1 Beat Wolf 2010-03-23 10:13:03 UTC
please try to recreate the crash with debug symbols installed and give us the backtrace of the crash.
This crash might also already be fixed with kde 4.4.1
Comment 2 Beat Wolf 2010-03-24 23:53:34 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When kubuntu it's started, netwok-manager plasma widget doen't restart. When I restart it by hand with the command (as root):
/etc/init.d/network-manager restart
it shows a window error message with a button to restart it and send bug error.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x00000108 in ?? ()
#7  0x004e025e in qobject_cast<Knm::InterfaceConnection const*> (first=0x80697e0, second=0x977f210) at /usr/include/qt4/QtCore/qobject.h:456
#8  activatableLessThan (first=0x80697e0, second=0x977f210) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:184
#9  0x004e04e2 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:384
#10 0x004e0697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x97281b0, activatable=0x97641c0)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#11 SortedActivatableList::handleAdd (this=0x97281b0, activatable=0x97641c0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#12 0x004ced03 in ActivatableList::addActivatableInternal (this=0x9753740, activatable=0x97641c0)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#13 0x004ced9c in ActivatableList::addActivatable (this=0x9753740, activatable=0x80697e0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#14 0x004d2767 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x97d5060, addedConnection=0x97831c8)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x004d02fe in NetworkInterfaceActivatableProvider::init (this=0x97d5060)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x004cf520 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x9779dd0, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#17 0x004c8a9b in NetworkInterfaceMonitor::qt_metacall (this=0x9779dd0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe45878)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#18 0x00cf8263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#19 0x00cf8ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x007508b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#21 0x00751346 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0x007513c7 in ?? () from /usr/lib/libsolidcontrol.so.4
#23 0x00cf8263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#24 0x00cf8ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#25 0x059b4143 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0x059b56a8 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x059b887d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x00cf8263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#29 0x00cf8ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#30 0x059c4e53 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0x059c5385 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#32 0x0084c7b4 in ?? () from /usr/lib/libQtDBus.so.4
#33 0x00854197 in ?? () from /usr/lib/libQtDBus.so.4
#34 0x00cf25fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x01073f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#36 0x0107b67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x002e2bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#38 0x00ce26cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#39 0x00ce32b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#40 0x00ce347d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#41 0x00d0d3ff in ?? () from /usr/lib/libQtCore.so.4
#42 0x04522e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x04526730 in ?? () from /lib/libglib-2.0.so.0
#44 0x04526863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x00d0d02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x01114be5 in ?? () from /usr/lib/libQtGui.so.4
#47 0x00ce0c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x00ce10ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x00ce353f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#50 0x01073dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#51 0x08052905 in main (argc=1, argv=0xbfe46734) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

Segnala a https://bugs.kde.org
Comment 3 Dario Andres 2010-03-28 00:27:24 UTC
This issue is being tracked at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***