Bug 23164 - automatic german letters replacement
Summary: automatic german letters replacement
Status: RESOLVED FIXED
Alias: None
Product: quanta
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 110 votes (vote)
Target Milestone: ---
Assignee: András Manţia
URL:
Keywords:
: 66437 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-03-28 00:03 UTC by ubq7
Modified: 2006-02-25 22:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ubq7 2001-03-28 00:01:19 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           quanta
Version:           KDE 2.1.1 
Severity:          wishlist
Installed from:    Debian Packages
Compiler:          2.2.18 (gcc 2.95.2)
OS:                Linux
OS/Compiler notes: Not Specified

It would be cool if I just type an german letter like ü à ä à ö à à (may not display correctly) and quanta would not type those in the editor window but their allowed replacements ü Ü ä Ä ö Ö ß because this is something that you forget to do very often.

HS

(Submitted via bugs.kde.org)
(Called from KBugReport dialog. Fields Application KDE Version OS Compiler manually changed)
Comment 1 Patrick Mairif 2002-11-08 13:45:50 UTC
I miss this feature, too. But it should be optional.
Comment 2 Chris Hornbaker 2003-07-17 17:31:50 UTC
Using XHTML encoded with UTF-8 will produce valid documents without the need to
use entities (ü and so on). (This is the reason UTF-8 exists.)

The following is a valid XHTML heading encoded in UTF-8.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
 <head>
  <title></title>
  <meta http-equiv="Content-Type" content="text/xhtml; charset=UTF-8"/>
 </head>
Comment 3 András Manţia 2003-07-19 16:16:59 UTC
Subject: Re: automatic german letters replacement

With the KFileReplace (global replace) plugin you can set up rules to replace 
german letters with &; strings. Alternatively you can use utf-8 encoding for 
your files and get rid of &; strings. I don't close the bug yet, but will do 
soon when the KFileReplace plugin will be easier to use.

Comment 4 András Manţia 2004-05-19 12:42:22 UTC
*** Bug 66437 has been marked as a duplicate of this bug. ***
Comment 5 András Manţia 2004-05-20 22:39:35 UTC
CVS commit by amantia: 

Solve the oldest wish in Quanta (and the wish with the most votes): add possibility of as-you-type replacing of accented chars. By default it's turned off.

CCMAIL: 23164-done@bugs.kde.org
CCMAIL: quanta@kde.org


  M +2 -1      ChangeLog   1.281
  M +48 -27    dialogs/settings/styleoptionss.ui   1.19
  M +30 -1     src/document.cpp   1.291
  M +6 -0      src/document.h   1.110
  M +3 -0      src/quanta.cpp   1.563
  M +1 -0      src/quanta_init.cpp   1.518
  M +1 -0      utility/quantacommon.h   1.73



Comment 6 Marek 2006-02-25 22:13:48 UTC
How about a special menu command for replacing accented characters to their HTML equivalents and vice versa? For example when pasting text from other sources, this would be useful.