Bug 231513 - podcast: add opml export
Summary: podcast: add opml export
Status: RESOLVED DUPLICATE of bug 126120
Alias: None
Product: amarok
Classification: Applications
Component: Podcast (show other bugs)
Version: 2.3.0
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: 2.3.2
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-21 11:06 UTC by andreaswuest
Modified: 2010-07-20 23:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreaswuest 2010-03-21 11:06:50 UTC
Version:            (using KDE 4.4.1)
OS:                Linux
Installed from:    Ubuntu Packages

Hi,

is it planned to add an opml export funtionality? i just ask, because
with each amarok update i usually have to cleanup the configuration files and
i am loosing my podcasts all the time. it would be nice if there was a 
possibility to at least create a backup file of my podcasts.

if this feature is not going to be added "natively" i will consider 
writing a amarok script that will write a backup file (this should
be possible as far as i can tell). i just do not want to implement 
a feature that is already planned for a future version.  

cheers,
andy
Comment 1 andreaswuest 2010-03-21 11:12:36 UTC
amarok version is 2.3.0
Comment 2 Sven Krohlas 2010-03-21 11:15:51 UTC
There is only an OPML import option, and I don't think anyone is working on export right now. I'd say native support for this would be very welcome. So if you want to give it a try just go ahead and do so! :)
Comment 3 Bart Cerneels 2010-03-21 18:14:41 UTC
A native export is on my todo list. Pretty far down though. It's something I could implement during the week on my daily 2 x 20 minutes train trip, so I imagine it might be a good junior job for a Qt programmer with a year or so experience.

Basically OpmlParser needs to be expanded to be able to create on OPML document instead of only parsing them. OpmlOutline already has the necessary setters.

Talk to me (stecchino) on IRC for help.
Comment 4 andreaswuest 2010-03-26 19:35:16 UTC
i planned the export as a script. however you seem to plan to add it as cpp code. at the moment i just cannot decide if it is worth spending the time on the javascript export if there will be a native export, which makes my script obsolete :-(
Comment 5 Bart Cerneels 2010-03-26 20:29:40 UTC
The way I see it OPML export in C++ will be superior because it will integrate well and be usable in other components as well.

How about you try to implement it in native code? I quickly looked at it and feel it's not to much and nicely contained as well. And you can always ask my advice by mail or irc (Stecchino).
Comment 6 Sven Krohlas 2010-04-30 13:21:56 UTC
2.3.1 is in feature freeze -> 2.3.2
Comment 7 Bart Cerneels 2010-07-20 23:34:15 UTC

*** This bug has been marked as a duplicate of bug 126120 ***