Bug 231027 - "Desktop effects" KCM freezes while filtering effects
Summary: "Desktop effects" KCM freezes while filtering effects
Status: RESOLVED DUPLICATE of bug 213068
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-16 21:25 UTC by Dima Ryazanov
Modified: 2010-03-16 22:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dima Ryazanov 2010-03-16 21:25:52 UTC
Version:            (using KDE 4.4.1)
OS:                Linux
Installed from:    Ubuntu Packages

I enabled the "Show Paint" effect under "Desktop Effects", "All Effects". Later, when I wanted to disable it, I tried typing "paint" in the "Search Plugins" textbox, but the KCM froze.
It seems to freeze consistently if "Show Paint" is enabled. It also freezes if you disable "Show Paint" and search for "paint" afterwards, without restarting the settings dialog.

Here's a backtrace:
#0  KCategorizedView::Private::highestElementInLastRow (this=0x29db2b0, block=<value optimized out>) at ../../kdeui/itemviews/kcategorizedview.cpp:351
#1  0x00007f4b5deb5f03 in KCategorizedView::Private::blockHeight (this=0x29db2b0, category=<value optimized out>) at ../../kdeui/itemviews/kcategorizedview.cpp:232
#2  0x00007f4b5deb6152 in KCategorizedView::Private::blockPosition (this=0x29db2b0, category=<value optimized out>) at ../../kdeui/itemviews/kcategorizedview.cpp:202
#3  0x00007f4b5deb6b90 in KCategorizedView::visualRect (this=0x29d5df0, index=...) at ../../kdeui/itemviews/kcategorizedview.cpp:616
#4  0x00007f4b5deb8039 in KCategorizedView::Private::rowsInserted (this=0x29db2b0, parent=<value optimized out>, start=<value optimized out>, end=<value optimized out>)
    at ../../kdeui/itemviews/kcategorizedview.cpp:289
#5  0x00007f4b5deb8df1 in KCategorizedView::slotLayoutChanged (this=0x29d5df0) at ../../kdeui/itemviews/kcategorizedview.cpp:1388
#6  0x00007f4b5deb0d71 in KCategorizedView::qt_metacall (this=0x29d5df0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2f2c12b0)
    at ./kcategorizedview.moc:82
#7  0x00007f4b5d99ec0f in QMetaObject::activate (sender=0x29dc0c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0)
    at kernel/qobject.cpp:3293
#8  0x00007f4b5d0dfc30 in QSortFilterProxyModel::qt_metacall (this=0x29dc0c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2f2c1420)
    at .moc/release-shared/moc_qsortfilterproxymodel.cpp:127
#9  0x00007f4b5d99ec0f in QMetaObject::activate (sender=0x29d3f00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0)
    at kernel/qobject.cpp:3293
#10 0x00007f4b5cf33df2 in QLineEdit::textChanged (this=0x7fff2f2c09a0, _t1=<value optimized out>) at .moc/release-shared/moc_qlineedit.cpp:238
#11 0x00007f4b5cf3772c in QLineEdit::qt_metacall (this=0x29d3f00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2f2c1610)
    at .moc/release-shared/moc_qlineedit.cpp:156
#12 0x00007f4b5dfaa2e5 in KLineEdit::qt_metacall (this=0x7fff2f2c09a0, _c=43892928, _id=-2, _a=0x0) at ./klineedit.moc:134
#13 0x00007f4b5d99ec0f in QMetaObject::activate (sender=0x29d4310, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0)
    at kernel/qobject.cpp:3293
#14 0x00007f4b5d1c72b5 in QLineControl::textChanged (this=0x7fff2f2c09a0, _t1=<value optimized out>) at .moc/release-shared/moc_qlinecontrol_p.cpp:131
#15 0x00007f4b5cf3da06 in QLineControl::finishChange (this=0x29d4310, validateFromState=1, update=<value optimized out>, edited=true) at widgets/qlinecontrol.cpp:605
#16 0x00007f4b5cf3f4af in QLineControl::processKeyEvent (this=0x29d4310, event=0x7fff2f2c23d0) at widgets/qlinecontrol.cpp:1778
#17 0x00007f4b5cf33fa1 in QLineEdit::keyPressEvent (this=<value optimized out>, event=0x29dc0c0) at widgets/qlineedit.cpp:1661
#18 0x00007f4b5dfa6503 in KLineEdit::keyPressEvent (this=0x29d3f00, e=0x7fff2f2c23d0) at ../../kdeui/widgets/klineedit.cpp:895
#19 0x00007f4b5cb801ae in QWidget::event (this=0x29d3f00, event=0x7fff2f2c23d0) at kernel/qwidget.cpp:8033
#20 0x00007f4b5cf35133 in QLineEdit::event (this=0x29d3f00, e=0x7fff2f2c23d0) at widgets/qlineedit.cpp:1474
#21 0x00007f4b5dfa782a in KLineEdit::event (this=0x29d3f00, ev=0x7fff2f2c23d0) at ../../kdeui/widgets/klineedit.cpp:1329
#22 0x00007f4b5cb2a12c in QApplicationPrivate::notify_helper (this=0x2308700, receiver=0x29d3f00, e=0x7fff2f2c23d0) at kernel/qapplication.cpp:4300
#23 0x00007f4b5cb31ee1 in QApplication::notify (this=<value optimized out>, receiver=0x29d3f00, e=0x7fff2f2c23d0) at kernel/qapplication.cpp:3763
#24 0x00007f4b5ded3d76 in KApplication::notify (this=0x7fff2f2c33f0, receiver=0x29d3f00, event=0x7fff2f2c23d0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f4b5d98be0c in QCoreApplication::notifyInternal (this=0x7fff2f2c33f0, receiver=0x29d3f00, event=0x7fff2f2c23d0) at kernel/qcoreapplication.cpp:704
#26 0x00007f4b5cbd4c1a in QKeyMapper::sendKeyEvent (keyWidget=0x29d3f00, grab=<value optimized out>, type=QEvent::KeyPress, code=65, modifiers=<value optimized out>,
    text=..., autorepeat=false, count=1, nativeScanCode=38, nativeVirtualKey=97, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#27 0x00007f4b5cbd7190 in QKeyMapperPrivate::translateKeyEvent (this=0x23491e0, keyWidget=0x29d3f00, event=<value optimized out>, grab=192)
    at kernel/qkeymapper_x11.cpp:1831
#28 0x00007f4b5cbae734 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff2f2c2fa0) at kernel/qapplication_x11.cpp:3394
#29 0x00007f4b5cbda322 in x11EventSourceDispatch (s=0x230c380, callback=<value optimized out>, user_data=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007f4b58b96bce in g_main_dispatch (context=0x230b0b0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#31 IA__g_main_context_dispatch (context=0x230b0b0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#32 0x00007f4b58b9a598 in g_main_context_iterate (context=0x230b0b0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#33 0x00007f4b58b9a6c0 in IA__g_main_context_iteration (context=0x230b0b0, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#34 0x00007f4b5d9b5333 in QEventDispatcherGlib::processEvents (this=0x22937f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#35 0x00007f4b5cbd9f0e in QGuiEventDispatcherGlib::processEvents (this=0x7fff2f2c09a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
---Type <return> to continue, or q <return> to quit---
#36 0x00007f4b5d98a732 in QEventLoop::processEvents (this=<value optimized out>, flags=DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.
) at kernel/qeventloop.cpp:149
#37 0x00007f4b5d98ab0c in QEventLoop::exec (this=0x7fff2f2c32d0, flags=DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.
) at kernel/qeventloop.cpp:201
#38 0x00007f4b5cff35fe in QDialog::exec (this=0x2509370) at dialogs/qdialog.cpp:546
#39 0x00007f4b5080cb78 in kdemain (_argc=<value optimized out>, _argv=<value optimized out>) at ../../kcmshell/main.cpp:272
#40 0x0000000000406fb8 in launch (argc=12, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=96, envs=<value optimized out>,
    reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40a499 "0") at ../../kinit/kinit.cpp:717
#41 0x0000000000407c70 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#42 0x0000000000408121 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#43 0x0000000000408df2 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1841

It gets stuck in the last frame, highestElementInLastRow.
Comment 1 Christoph Feck 2010-03-16 22:41:57 UTC

*** This bug has been marked as a duplicate of bug 213068 ***