Bug 231001 - Truncated headings in Albums plasmoids
Summary: Truncated headings in Albums plasmoids
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Context View/Albums (show other bugs)
Version: 2.3-GIT
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-16 18:20 UTC by Frank Steinmetzger
Modified: 2010-11-11 20:21 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4


Attachments
Screenshot of truncated title in album plasmoid (5.14 KB, image/png)
2010-03-16 22:33 UTC, Frank Steinmetzger
Details
Another strange Albums plasmoid caption (4.58 KB, image/png)
2010-03-16 22:46 UTC, Frank Steinmetzger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2010-03-16 18:20:48 UTC
Version:           2.3-GIT (using 4.4.1 (KDE 4.4.1), Gentoo)
Compiler:          i686-pc-linux-gnu-gcc
OS:                Linux (i686) release 2.6.31-gentoo-r10

Hi

this bug is so old, it must have been reported somewhere already, but I did not find it here (different keywords perhaps). So after months of deliberation, I finally decide to report it anyway.

The Albums plasmoid oftentimes has truncated titles. It would show for instance "Albums..." instead of "Albums of Band xyz", even though there is more than enough space available. It doesn’t occur on every occasion. Right now the full title is shown, but last time Amarok was running, it wasn’t.

I tried to find a correlation, and I found out that the Albums heading gets truncated if the applet isn’t visible on playing the first track. I have the collection browser and context area grouped together via tabs. When the next track starts, the truncation is gone though.

I’m currently running the GIT version from 15. March.
Comment 1 Myriam Schweingruber 2010-03-16 20:07:19 UTC
Waiting so long to report a bug means we weren't aware of it. Could you please provide a screenshot? I can't see any problems here with todays git version.
Comment 2 Frank Steinmetzger 2010-03-16 22:33:50 UTC
Created attachment 41700 [details]
Screenshot of truncated title in album plasmoid
Comment 3 Frank Steinmetzger 2010-03-16 22:46:12 UTC
Created attachment 41701 [details]
Another strange Albums plasmoid caption

Well since it was so old a bug (to my knowledge), I assume it’s already known but no solution was found yet. I believe to have read about it somewhere, perhaps on IRC. But anyway, here are your shots.

The previous screenshot was made today, right before I filed the bug. This one here is from a few minutes ago, I just started up Amarok, the context area was open when I closed the app a few hours ago, so it was visible upon startup.

Only this time, the caption element was right-aligned. This is the first time I see this, but I guess it’s related. My theory is that there’s some unhandled or malhandled resizing event when the plasmoid is created.

As soon as I grabbed the splitter between context area and playlist, the caption sprung back to the center.

I also tried to reproduce the originally reported issue, so we can be sure it’s not just a hickup, and I was successful at it. I opened Amarok again, this time with the collection browser in front, so the context area was not visible yet. I started playing a track, and then switched to the context tab. This produced the same "Album ..." caption. Only here, dragging the splitter does not help.
Comment 4 Myriam Schweingruber 2010-03-17 00:29:18 UTC
Thank you for your feedback. The caption is centered here, but I can't recall a recent fix since yeterday.
Comment 5 Simon ESNEAULT 2010-04-14 17:29:58 UTC
Yep, it occurs here sometimes too, and to the videoclip applet also. This is old, normally it should disapear as soon as you switch to a new artist song. Probably due to the fact that we call a getSize somewhere where the size is not correct yet, and then internally Qt doesn't update everything ...
Comment 6 Rick W. Chen 2010-10-24 07:05:45 UTC
commit d5b6260eb86f679c78754da8e34976651ea66be6
branch master
Merge: d5a209a 00a9397
Author: Rick W. Chen <stuffcorpse@archlinux.us>
Date:   Sun Oct 24 18:02:11 2010 +1300

    Merge branch 'cv-improvements'
    
    This merge includes several improvements and bug fixes to some context
    view applets. See ChangeLog for more details.
    
    BUG:187011
    BUG:249488
    BUG:215171
    BUG:220617
    CCBUG:231001

diff --cc ChangeLog
index 2455f73,9941683..7714f4a
--- a/ChangeLog
+++ b/ChangeLog
@@@ -5,9 -5,6 +5,13 @@@ Amarok ChangeLo
  
  VERSION 2.4-Beta 1
    FEATURES:
++    * Added support for all Wikipedia languages. (BR 220617)
++    * Added incremental search in the Wikipedia applet (press
++      '/' or global search key when in focus).
++    * Added "Favorite Venues" to the upcoming events applet.
 +    * Read MusicBrainz IDs of MP4 files during scanning.
 +    * Ability to hide and show the menu bar. Patch by 
 +      Valentyn Pavliuchenko <valentyn.pavliuchenko@gmail.com>.
      * Size of OSD font is now configurable. (BR 195186)
      * Musicbrainz-based mass tagging UI by Sergey Ivanov.
      * New easy to use table-based UI for Ampache server configuration. (BR 200703)
@@@ -20,9 -17,7 +24,20 @@@
        to music provided by a running local Playdar service.
  
    CHANGES:
 -    * Debugging mode (--debug) now also prints the current thread ID.
++    * Show a progress bar while loading pages in the Wikipedia applet.
++    * Added option to right-align "year" in the albums applet.
++    * Improved alignment of tracks in the albums applet.
++    * Scroll to the current album and make its tracks visible in the albums
++      applet. (BR 187011)
++    * Added ability to expand/collapse/drag disc items in the albums applet.
++      (BR 249488)
++    * Improved appearance of similar artist, upcoming events, and Wikipedia
++      applets.
++    * Improved presentation of suggested lyrics (currently only 3rd party
++      scripts use).
 +    * Use QTooltip for playlist tooltips
 +    * Changed playlist delegate margins and inline editor formating.
 +    * Add "Added This Hour" filter preset to the collection brower widget.
      * Bumped KDE dependency to version 4.4., and Qt dependency to 4.6.
      * Print message when a file can't be copied to a media player.
        Patch by Sergey Ivanov <123kash@gmail.com>. (BR 203820)
@@@ -31,6 -26,6 +46,8 @@@
        pressing SHIFT while clicking the action will bypass trash.
  
    BUGFIXES:
++    * Fixed Wikipedia applet header layout issues. (BR 215171)
++    * Fixed truncated heading in albums applet. (BR 231001)
      * Playlist sorting breadcrumb items have been untranslatable.
        Patch by Alexander Potashev <aspotashev@gmail.com>. (BR 189750)
      * Dynamic Playlist criteria were not being saved properly. (BR 243562)
Comment 7 Rick W. Chen 2010-11-10 11:49:35 UTC
Fixed.