Bug 230514 - Kubuntu 10.04
Summary: Kubuntu 10.04
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-12 23:09 UTC by florianhilgenberg
Modified: 2010-03-12 23:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description florianhilgenberg 2010-03-12 23:09:54 UTC
Application: amarok (2.2.2.90)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-16-generic x86_64
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
everytime i want to start amarok i could bet for a crash 

The crash can be reproduced every time.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2ea0268840 (LWP 12258))]

Thread 8 (Thread 0x7f2e86b10710 (LWP 12259)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007f2e8c804081 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f2e855c1710 (LWP 12260)):
#0  0x00007f2e9676a023 in ?? () from /lib/libglib-2.0.so.0
#1  0x00007f2e9676a4bc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x00007f2e9dbef4d6 in QEventDispatcherGlib::processEvents (this=0x11fbd30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#3  0x00007f2e9dbc4902 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#4  0x00007f2e9dbc4cdc in QEventLoop::exec (this=0x7f2e855c0cb0, flags=) at kernel/qeventloop.cpp:201
#5  0x00007f2e9daced69 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#6  0x00007f2e8ca85570 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#7  0x00007f2e9dad1785 in QThreadPrivate::start (arg=0x133d8a0) at thread/qthread_unix.cpp:248
#8  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f2e809af710 (LWP 12266)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2e8c814e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f2e847aa710 (LWP 12267)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2e8c814e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2e83fa9710 (LWP 12268)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2e8c814e23 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f2e82457710 (LWP 12270)):
#0  0x00007f2e9d285bd3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2e9676a0e9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f2e9676a4bc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f2e9dbef4d6 in QEventDispatcherGlib::processEvents (this=0x20d93c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f2e9dbc4902 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f2e9dbc4cdc in QEventLoop::exec (this=0x7f2e82456cd0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f2e9daced69 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f2e9dba5118 in QInotifyFileSystemWatcherEngine::run (this=0x219bea0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2e9dad1785 in QThreadPrivate::start (arg=0x219bea0) at thread/qthread_unix.cpp:248
#9  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2e7818d710 (LWP 12271)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2e9863f986 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f2e9863f9c9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f2e9b6dd9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f2e9d29238d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2ea0268840 (LWP 12258)):
[KCrash Handler]
#5  0x00007f2e9eb6a43a in qt_closestItemFirst (item1=<value optimized out>, item2=0x215f900) at graphicsview/qgraphicsitem_p.h:681
#6  0x00007f2e9eb708ff in QAlgorithmsPrivate::qSortHelper<QList<QGraphicsItem*>::iterator, QGraphicsItem*, bool (*)(QGraphicsItem const*, QGraphicsItem const*)> (start=)
    at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:351
#7  0x00007f2e9eb70a98 in qSort<QList<QGraphicsItem*>::iterator, bool (*)(QGraphicsItem const*, QGraphicsItem const*)> (start=<value optimized out>, end=<value optimized out>, lessThan=0x215f900)
    at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:187
#8  0x00007f2e9eb70101 in QGraphicsSceneBspTreeIndexPrivate::sortItems (itemList=0x7fffd0bfc2b0, order=<value optimized out>, sortCacheEnabled=<value optimized out>, 
    onlyTopLevelItems=<value optimized out>) at graphicsview/qgraphicsscenebsptreeindex.cpp:434
#9  0x00007f2e9eb70339 in QGraphicsSceneBspTreeIndex::items (this=<value optimized out>, order=Qt::DescendingOrder) at graphicsview/qgraphicsscenebsptreeindex.cpp:572
#10 0x00007f2e9eb4a99a in QGraphicsScene::items (this=<value optimized out>) at graphicsview/qgraphicsscene.cpp:1900
#11 0x00007f2e9eb51489 in QGraphicsScene::itemsBoundingRect (this=0x2318a90) at graphicsview/qgraphicsscene.cpp:1887
#12 0x00007f2e9eb58111 in QGraphicsScene::sceneRect (this=0x20951f0) at graphicsview/qgraphicsscene.cpp:1636
#13 0x00007f2e9eb7902a in QGraphicsView::sceneRect (this=<value optimized out>) at graphicsview/qgraphicsview.cpp:1625
#14 0x00007f2e9a6f5009 in Plasma::viewFor (item=0x230a650) at ../../plasma/plasma.cpp:101
#15 0x00007f2e9a79f4ac in Plasma::WebView::itemChange (this=0x2318a90, change=<value optimized out>, value=<value optimized out>) at ../../plasma/widgets/webview.cpp:492
#16 0x00007f2e9eb5aecb in QGraphicsScene::addItem (this=0x20951f0, item=0x230a650) at graphicsview/qgraphicsscene.cpp:2621
#17 0x00007f2e9eb5ae28 in QGraphicsScene::addItem (this=0x20951f0, item=0x2318a90) at graphicsview/qgraphicsscene.cpp:2608
#18 0x00007f2e9eb2a24d in QGraphicsItemPrivate::setParentItemHelper (this=0x23195f0, newParent=0x215f900, newParentVariant=0x7fffd0bfca00, thisPointerVariant=0x7fffd0bfc9e0)
    at graphicsview/qgraphicsitem.cpp:1131
#19 0x00007f2e9eb2a86a in QGraphicsItem::setParentItem (this=0x2318a90, newParent=0x215f900) at graphicsview/qgraphicsitem.cpp:1601
#20 0x00007f2e9a6b4ac5 in Plasma::Containment::addApplet (this=0x215f8f0, applet=0x2318a80, pos=..., delayInit=false) at ../../plasma/containment.cpp:941
#21 0x00007f2e9a6b4e2f in Plasma::ContainmentPrivate::addApplet (this=0x217aab0, name=<value optimized out>, args=<value optimized out>, appletGeometry=..., id=0, delayInit=false)
    at ../../plasma/containment.cpp:2284
#22 0x00007f2e6f34b66b in Context::VerticalToolbarContainment::addApplet (this=0x215f8f0, pluginName=..., loc=-1)
    at ../../../../../src/context/containments/verticallayout/VerticalToolbarContainment.cpp:148
#23 0x00007f2e6f34bbe0 in Context::VerticalToolbarContainment::loadConfig (this=0x215f8f0, conf=...) at ../../../../../src/context/containments/verticallayout/VerticalToolbarContainment.cpp:114
#24 0x00007f2e9f1ce6e2 in Context::ContextView::loadConfig (this=<value optimized out>) at ../../src/context/ContextView.cpp:224
#25 0x00007f2e9f1cff1f in Context::ContextView::showHome (this=0x21d8160) at ../../src/context/ContextView.cpp:205
#26 0x00007f2e9f5c65da in MainWindow::createContextView (this=0x1832b80, containment=0x215f8f0) at ../../src/MainWindow.cpp:409
#27 0x00007f2e9f5c867c in MainWindow::qt_metacall (this=0x1832b80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd0bfd210) at ./MainWindow.moc:156
#28 0x00007f2e9dbd8dbf in QMetaObject::activate (sender=0x20951f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x215f900) at kernel/qobject.cpp:3293
#29 0x00007f2e9a6c3c5f in Plasma::Corona::containmentAdded (this=0x215fac0, _t1=0x215f8f0) at ./corona.moc:146
#30 0x00007f2e9a6c87f7 in Plasma::CoronaPrivate::addContainment(QString const&, QList<QVariant> const&, unsigned int, bool) () from /usr/lib/libplasma.so.3
#31 0x00007f2e9f1cd260 in Context::ContextScene::loadDefaultSetup (this=0x20951f0) at ../../src/context/ContextScene.cpp:45
#32 0x00007f2e9f5c940b in MainWindow::init (this=0x1832b80) at ../../src/MainWindow.cpp:304
#33 0x00007f2e9f5cb742 in MainWindow (this=0x1832b80) at ../../src/MainWindow.cpp:182
#34 0x00007f2e9f597ff2 in App::continueInit (this=0x7fffd0bfe330) at ../../src/App.cpp:730
#35 0x00007f2e9f59cd12 in App (this=0x7fffd0bfe330) at ../../src/App.cpp:214
#36 0x0000000000408778 in main (argc=1, argv=0x7fffd0c002b8) at ../../src/main.cpp:235

This bug may be a duplicate of or related to bug 227639.

Possible duplicates by query: bug 229657, bug 229286, bug 229284, bug 228278, bug 227639.

Reported using DrKonqi
Comment 1 florianhilgenberg 2010-03-12 23:22:15 UTC
had a amarok script killing the process - solved