Bug 230433 - pdf not reder text but only image and tbale border
Summary: pdf not reder text but only image and tbale border
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Applications
Component: PDF backend (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-12 11:43 UTC by alberto fiaschi
Modified: 2010-03-22 12:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Pdf file that is not display correctly .reder image and table border but not text (113.87 KB, application/pdf)
2010-03-12 11:47 UTC, alberto fiaschi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alberto fiaschi 2010-03-12 11:43:03 UTC
Version:            (using KDE 4.3.5)
OS:                Linux
Installed from:    Ubuntu Packages

in some  pdf files i see only image and table border but not text.
i see that files in right way on windows and mac with others programs   .
Comment 1 alberto fiaschi 2010-03-12 11:47:14 UTC
Created attachment 41563 [details]
Pdf file that is not display correctly  .reder image and table border but not text

i see it in the right way on windows and mac with other programs
Comment 2 Albert Astals Cid 2010-03-12 20:49:49 UTC
Works for me, i would bet you do not have poppler-data package installed. If you have it installed or install it and the text still does not appear, please reopen the bug.
Comment 3 alberto fiaschi 2010-03-15 08:13:50 UTC
i install the package poppler-data  but i have the same result .
i do not see the text with okular and also with xpdf.
Comment 4 alberto fiaschi 2010-03-15 08:23:07 UTC
if i run okular from konsole have this error :
Error: Unknown font tag 'F1'
Error (7643): No font in show
Error (7643): No font in show
Error (7662): No font in show
Error (7664): No font in show
Error: Unknown font tag 'F0'
Error (7676): No font in show
Error: Unknown font tag 'F1'
Error (7688): No font in show
Error (7688): No font in show
Error (7700): No font in show
Error (7700): No font in show
Error (7713): No font in show
Error (7716): No font in show
Error: Unknown font tag 'F0'
Error (7720): No font in show
Error: Unknown font tag 'F0'
Error (7746): No font in show
Error (7746): No font in show
Error (7760): No font in show
Error (7760): No font in show
Error (7775): No font in show
Error (7775): No font in show
Error (7784): No font in show
Error (7784): No font in show
Error (7798): No font in show
Error (7798): No font in show
Error (7806): No font in show
Error (7806): No font in show
Error (7814): No font in show
Error (7814): No font in show
Error (7825): No font in show
Error (7825): No font in show
Error (7833): No font in show
Error (7833): No font in show
Error (7842): No font in show
Error: Unknown font tag 'F0'
Error (7867): No font in show
Error: Unknown font tag 'F1'
Error (7902): No font in show
Error (7902): No font in show
Error (7905): No font in show
Error (7905): No font in show
Error (7910): No font in show
Comment 5 Albert Astals Cid 2010-03-15 20:09:59 UTC
Which poppler and freetype versions do you have installed?
Comment 6 alberto fiaschi 2010-03-16 09:00:51 UTC
this is the output of apt-cache show

*****************************freetype :
Package: libfreetype6
Priority: optional
Section: libs
Installed-Size: 712
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Steve Langasek <vorlon@debian.org>
Architecture: i386
Source: freetype
Version: 2.3.9-4build1
Replaces: freetype0, freetype1
Depends: libc6 (>= 2.4), zlib1g (>= 1:1.1.4)
Conflicts: freetype, xpdf-reader (<< 1.00-4)
Filename: pool/main/f/freetype/libfreetype6_2.3.9-4build1_i386.deb
Size: 391148
MD5sum: a033ff1f4723ae42cf7f2026201b3ed5
SHA1: 567da2ff97b55947f75bdf699f7346b45be2b82d
SHA256: b14fec45630f2d498b63ba05661796f7f97062fa8e8f2dea2fc2d871c7363556
Description: FreeType 2 font engine, shared library files
 The FreeType project is a team of volunteers who develop free,
 portable and high-quality software solutions for digital typography.
 They specifically target embedded systems and focus on bringing small,
 efficient and ubiquitous products.
 .
 The FreeType 2 library is their new software font engine.  It has been
 designed to provide the following important features:
  * A universal and simple API to manage font files
  * Support for several font formats through loadable modules
  * High-quality anti-aliasing
  * High portability & performance
 .
 Supported font formats include:
  * TrueType files (.ttf) and collections (.ttc)
  * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
  * Type 1 Multiple Master fonts.  The FreeType 2 API also provides
    routines to manage design instances easily
  * Type 1 CID-keyed fonts
  * OpenType/CFF (.otf) fonts
  * CFF/Type 2 fonts
  * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
    the Adobe SVG viewer plugin.
  * Windows FNT/FON bitmap fonts
 .
 This package contains the files needed to run programs that use the
 FreeType 2 library.
 .
  Home Page: http://www.freetype.org/
  Authors: David Turner   <david.turner@freetype.org>
           Robert Wilhelm <robert.wilhelm@freetype.org>
           Werner Lemberg <werner.lemberg@freetype.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Task: ubuntu-desktop, print-server, tomcat-server, kubuntu-desktop, edubuntu-desktop, edubuntu-server, xubuntu-desktop, mobile-live, mobile-mid, mobile-netbook-remix, mythbuntu-backend-master, mythbuntu-backend-slave, mythbuntu-desktop, mythbuntu-frontend

*********************************poppler-data :

ackage: poppler-data
Priority: optional
Section: multiverse/misc
Installed-Size: 12276
Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
Original-Maintainer: Hideki Yamane (Debian-JP) <henrich@debian.or.jp>
Architecture: all
Version: 0.2.1-3
Recommends: poppler-utils
Suggests: libpoppler4 | libpoppler3
Filename: pool/multiverse/p/poppler-data/poppler-data_0.2.1-3_all.deb
Size: 4037056
MD5sum: f500a2b74b8d680f3bd4181d2abc6341
SHA1: c085ad011d7ace3d4973e7ac8fee46baccda3d9d
SHA256: da4dabfd86fe17b5b9b32ab59dc7369eff5ddbe956cc77606f100da01742ee61
Description: Encoding data for the poppler PDF rendering library
 This package contains the encoding data needed to view some PDF documents
 with libpoppler.
 .
 If CJK users want to view PDF files that contains their language, this package
 will help, such as cmap-adobe-{gb1,cns1,korea1,japan1,japan2}.
Homepage: http://poppler.freedesktop.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

***************************** libpopplerkit0 :

Package: libpopplerkit0
Priority: optional
Section: universe/libs
Installed-Size: 248
Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
Original-Maintainer: Hubert Chathi <uhoreg@debian.org>
Architecture: i386
Source: popplerkit.framework
Version: 0.0.20051227svn-5build2
Depends: gsfonts, libc6 (>= 2.3.4), libgcc1 (>= 1:4.1.1), libpoppler4, libstdc++6 (>= 4.1.1)
Filename: pool/universe/p/popplerkit.framework/libpopplerkit0_0.0.20051227svn-5build2_i386.deb
Size: 40240
MD5sum: 70a4b6065de93091d739703aae15a2ec
SHA1: c4aeb34984053f038b8aba6383027bf6fb838226
SHA256: 8a3b0e60a5167edc069624ad2481ca946c0142fa2f43474885f25f0f4b2a8790
Description: GNUstep framework for rendering PDF content (library files)
 PopplerKit is a GNUstep framework for accessing and rendering PDF content.  It
 is based on the poppler library.
 .
 Its features are:
   - Render PDF content.
   - Extract text from a PDF document.
   - Access a PDF document's outline.
   - Search in PDF documents.
 .
 This package contains the runtime libraries.
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Comment 7 alberto fiaschi 2010-03-16 09:08:52 UTC
i test the same file on a slackware 12.2 with kpdf and i have the same result.

on slackware libfretype is :       freetype-2.3.7-i486-1
poppler is :                       poppler-0.8.5-i486-3_slack12.2
                                   poppler-data-0.2.0-noarch-1
Comment 8 Albert Astals Cid 2010-03-16 09:31:19 UTC
Slackware versions are ancient and kpdf never depended on poppler so it's worthless data.

On Ubuntu versions you didn't give me the version of libpoppler (libpopplerkit is a "GNUstep framework" as you can read and you are not using GNUstep)
Comment 9 alberto fiaschi 2010-03-16 09:42:01 UTC
libpoppler4 and  libpoppler-qt4-3 detail :

apt-cache show  libpoppler4


Package: libpoppler4
Priority: optional
Section: libs
Installed-Size: 1820
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Loic Minier <lool@dooz.org>
Architecture: i386
Source: poppler
Version: 0.10.5-1ubuntu2.5
Depends: libc6 (>= 2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libjpeg62, libstdc++6 (>= 4.1.1), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4)
Filename: pool/main/p/poppler/libpoppler4_0.10.5-1ubuntu2.5_i386.deb
Size: 686942
MD5sum: 9dae9162ceee436b431f29695abf8b56
SHA1: 0f3855ae85cce8a93b6e1389107ec8e1d7331c06
SHA256: e201d82626968a89733f648b93095811fa0ceb75473eab5abd46496aef3d7a04
Description: PDF rendering library
 Poppler is a PDF rendering library based on xpdf PDF viewer.
 .
 This package contains the shared library.
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Task: ubuntu-desktop, print-server, kubuntu-desktop, edubuntu-desktop, xubuntu-desktop, mobile-live, mobile-mid, mobile-netbook-remix, mythbuntu-backend-master, mythbuntu-backend-slave, mythbuntu-desktop, mythbuntu-frontend

Package: libpoppler4
Priority: optional
Section: libs
Installed-Size: 1816
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Loic Minier <lool@dooz.org>
Architecture: i386
Source: poppler
Version: 0.10.5-1ubuntu2
Depends: libc6 (>= 2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), 
libgcc1 (>= 1:4.1.1), libjpeg62, libstdc++6 (>= 4.1.1), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4)
Filename: pool/main/p/poppler/libpoppler4_0.10.5-1ubuntu2_i386.deb
Size: 685272
MD5sum: 6b0ce62d53b8d4c000fe38ce636022eb
SHA1: 070cb518dc4b7770a390ceaecffd5b49eafa2b2f
SHA256: ebff132508f1ba1dfcdb884e74baede4efaa4520b6ec4638b64c54c8a31fe680
Description: PDF rendering library
 Poppler is a PDF rendering library based on xpdf PDF viewer.
 .
 This package contains the shared library.
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Task: ubuntu-desktop, print-server, kubuntu-desktop, edubuntu-desktop, xubuntu-desktop, mobile-live, mobile-mid, mobile-netbook-remix, mythbuntu-backend-master, mythbuntu-backend-slave, mythbuntu-desktop, mythbuntu-frontend



apt-cache show  libpoppler-qt4-3

Package: libpoppler-qt4-3
Priority: optional
Section: libs
Installed-Size: 520
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Loic Minier <lool@dooz.org>
Architecture: i386
Source: poppler
Version: 0.10.5-1ubuntu2.5
Depends: libc6 (>= 2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libjpeg62, libpoppler4, libqt4-xml (>= 4.5.0~+rc1), libqtcore4 (>= 4.5.0~+rc1), libqtgui4 (>= 4.5.0~+rc1), libstdc++6 (>= 4.1.1), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4)
Filename: pool/main/p/poppler/libpoppler-qt4-3_0.10.5-1ubuntu2.5_i386.deb
Size: 164416
MD5sum: 5a3ae1a124e10c879cc3fe833b76fc86
SHA1: a7d42332618e70be8a9deebfdecadecb6082f923
SHA256: 67b0927734deb95d6d5963b5cebea7f457e56bc2e669da7c324901f477676aa8
Description: PDF rendering library (Qt 4 based shared library)
 Poppler is a PDF rendering library based on xpdf PDF viewer.
 .
 This package provides the Qt 4 based shared library for applications
 using the Qt 4 interface to Poppler.
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Task: kubuntu-desktop, edubuntu-desktop-kde

Package: libpoppler-qt4-3
Priority: optional
Section: libs
Installed-Size: 516
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Loic Minier <lool@dooz.org>
Architecture: i386
Source: poppler
Version: 0.10.5-1ubuntu2
Depends: libc6 (>= 2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libjpeg62, libpoppler4, libqt4-xml (>= 4.5.0~+rc1), libqtcore4 (>= 4.5.0~+rc1), libqtgui4 (>= 4.5.0~+rc1), libstdc++6 (>= 4.1.1), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4)
Filename: pool/main/p/poppler/libpoppler-qt4-3_0.10.5-1ubuntu2_i386.deb
Size: 164412
MD5sum: fe55e63fd3a04e425203e4649afee29a
SHA1: 97559a2ec01322e3deebee2b547f93490eca8894
SHA256: d7b2bffd8d34b48699bd34c2b1061c7f38bd34bb520ea8690b90ab44a3a59e24
Description: PDF rendering library (Qt 4 based shared library)
 Poppler is a PDF rendering library based on xpdf PDF viewer.
 .
 This package provides the Qt 4 based shared library for applications
 using the Qt 4 interface to Poppler.
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Task: kubuntu-desktop, edubuntu-desktop-kde
Comment 10 Pino Toscano 2010-03-16 15:57:28 UTC
Poppler 0.10 is old, please update to Poppler 0.12; ask your distro for packages to install.
Comment 11 alberto fiaschi 2010-03-22 12:35:00 UTC
yes with poppler 0.12 all ok , i see the file in the right way.
Thanks and sorry .