Bug 230375 - kde plasma workspace bug when updating some packages
Summary: kde plasma workspace bug when updating some packages
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-11 22:42 UTC by Rubens de Souza Matos Júnior
Modified: 2010-03-11 22:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rubens de Souza Matos Júnior 2010-03-11 22:42:17 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-1-amd64 x86_64
Distribution: Debian GNU/Linux 5.0.4 (lenny)

What I was doing when the application crashed:
When I updated some packages, through adept, and after through aptitude, I received an error:

Error: "/var/tmp/kdecache-rubens" is owned by uid 1000 instead of uid 0.  

Then I changed the owner from rubens (uid 1000) to root (uid 0).

A few seconds after this, I received an error window reporting that kde plasma workspace had crashed. But I didn't noticed any real effect, besides this window. Some minutes after this (while I was filling this bug report), Kopete also crashed.

 -- Backtrace:
Application: Espaço de trabalho do Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 0 (LWP 2094)]

Thread 2 (Thread 0x7f5a68578910 (LWP 2100)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f5a87650499 in QWaitCondition::wait (this=0xc64c80, mutex=0xc64c78, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  0x00007f5a83a3e3b4 in QHostInfoAgent::run (this=0xc64c60) at kernel/qhostinfo.cpp:260
#3  0x00007f5a8764f4a5 in QThreadPrivate::start (arg=0xc64c60) at thread/qthread_unix.cpp:188
#4  0x00007f5a8437a73a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#5  0x00007f5a84f4369d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5a87c0f750 (LWP 2094)):
[KCrash Handler]
#5  QDataStream::operator>> (this=0x0, i=@0x7fff4385e90c) at io/qdatastream.cpp:661
#6  0x00007f5a8729d003 in KServiceGroupFactory (this=0x1520a60) at ../../kdecore/services/kservicegroupfactory.cpp:43
#7  0x00007f5a8729d26a in KServiceGroupFactory::self () at ../../kdecore/sycoca/ksycocafactory.h:200
#8  0x00007f5a87296dab in KServiceGroup::root () at ../../kdecore/services/kservicegroup.cpp:712
#9  0x00007f5a87296e65 in KServiceGroup::group (relPath=@0x7fff4385edd0) at ../../kdecore/services/kservicegroup.cpp:718
#10 0x00007f5a6f63e271 in ?? () from /usr/lib/libkickoff.so
#11 0x00007f5a6f640711 in Kickoff::ApplicationModel::reloadMenu () from /usr/lib/libkickoff.so
#12 0x00007f5a6f6407e1 in Kickoff::ApplicationModel::qt_metacall () from /usr/lib/libkickoff.so
#13 0x00007f5a87749df2 in QMetaObject::activate (sender=0x99aeb0, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#14 0x00007f5a8733614d in KSycoca::notifyDatabaseChanged (this=0x99aeb0, changeList=@0x153ab60) at ../../kdecore/sycoca/ksycoca.cpp:359
#15 0x00007f5a873361f9 in KSycoca::qt_metacall (this=0x99aeb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4385f030) at ./ksycoca.moc:74
#16 0x00007f5a83768b83 in QDBusConnectionPrivate::deliverCall (this=0x71d940, object=0x99aeb0, msg=@0x15a8498, metaTypes=@0x15a84a0, slotIdx=6) at qdbusintegrator.cpp:891
#17 0x00007f5a8377035f in QDBusCallDeliveryEvent::placeMetaCall (this=0x0, object=0x7fff4385e90c) at qdbusintegrator_p.h:101
#18 0x00007f5a877446c8 in QObject::event (this=0x99aeb0, e=0x15a8450) at kernel/qobject.cpp:1110
#19 0x00007f5a856b401d in QApplicationPrivate::notify_helper (this=0x7250d0, receiver=0x99aeb0, e=0x15a8450) at kernel/qapplication.cpp:4065
#20 0x00007f5a856bc07a in QApplication::notify (this=0x71c160, receiver=0x99aeb0, e=0x15a8450) at kernel/qapplication.cpp:4030
#21 0x00007f5a8630bde6 in KApplication::notify (this=0x71c160, receiver=0x99aeb0, event=0x15a8450) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x00007f5a87734c9c in QCoreApplication::notifyInternal (this=0x71c160, receiver=0x99aeb0, event=0x15a8450) at kernel/qcoreapplication.cpp:610
#23 0x00007f5a877358e4 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6ab950) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 0x00007f5a8775d7d3 in postEventSourceDispatch (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#25 0x00007f5a845cb13a in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x00007f5a845ce998 in ?? () from /lib/libglib-2.0.so.0
#27 0x00007f5a845ceb4c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x00007f5a8775d39c in QEventDispatcherGlib::processEvents (this=0x724580, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#29 0x00007f5a8574af1f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#30 0x00007f5a87733562 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1132854112}) at kernel/qeventloop.cpp:149
#31 0x00007f5a87733934 in QEventLoop::exec (this=0x7fff4385fba0, flags={i = 1132854192}) at kernel/qeventloop.cpp:201
#32 0x00007f5a87735ba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#33 0x00007f5a7ca3b2bf in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#34 0x0000000000406e9e in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a057 "0") at ../../kinit/kinit.cpp:677
#35 0x0000000000407aad in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#36 0x0000000000407f91 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#37 0x00000000004086c6 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Christoph Feck 2010-03-11 22:51:24 UTC
Looks like bug 211401 that is fixed in KDE SC 4.3.5. If you can reproduce it with that or a later version, please reopen.

*** This bug has been marked as a duplicate of bug 211401 ***