Bug 230090 - Kile crashed after documents on disk had been changed by other application
Summary: Kile crashed after documents on disk had been changed by other application
Status: RESOLVED DUPLICATE of bug 208486
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
: 241190 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-09 14:15 UTC by Thomas Dreibholz
Modified: 2010-06-09 14:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2010-03-09 14:15:23 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Some LaTeX documents had been opened in Kile. The documents have been managed in an SVN repository. When committing the changed documents to the SVN server, SVN has updated the $Id$ tag within the documents. Kile has been notified about the modified files on disk => crash.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x42588a8) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QList (this=0x42588a8) at /usr/include/qt4/QtCore/qlist.h:111
#7  QForeachContainer (this=0x42588a8) at /usr/include/qt4/QtCore/qglobal.h:2054
#8  KDirWatchPrivate::Entry::propagate_dirty (this=0x42588a8) at ../../kio/kio/kdirwatch.cpp:399
#9  0x00007f0f9e5c946b in KDirWatchPrivate::Entry::propagate_dirty (this=<value optimized out>) at ../../kio/kio/kdirwatch.cpp:404
#10 0x00007f0f9e5d0b27 in KDirWatchPrivate::slotRescan (this=0x287f440) at ../../kio/kio/kdirwatch.cpp:1275
#11 0x00007f0f9e5d16f4 in KDirWatchPrivate::qt_metacall (this=0x287f440, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff99235510) at ./kdirwatch_p.moc:73
#12 0x00007f0f9c126ddc in QMetaObject::activate (sender=0x287f4a8, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x3) at kernel/qobject.cpp:3113
#13 0x00007f0f9c120d83 in QObject::event (this=0x287f4a8, e=0x0) at kernel/qobject.cpp:1075
#14 0x00007f0f9cca6efc in QApplicationPrivate::notify_helper (this=0x26699d0, receiver=0x287f4a8, e=0x7fff99235b10) at kernel/qapplication.cpp:4056
#15 0x00007f0f9ccae1ce in QApplication::notify (this=0x7fff99235e60, receiver=0x287f4a8, e=0x7fff99235b10) at kernel/qapplication.cpp:4021
#16 0x00007f0f9db35f46 in KApplication::notify (this=0x7fff99235e60, receiver=0x287f4a8, event=0x7fff99235b10) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f0f9c111c2c in QCoreApplication::notifyInternal (this=0x7fff99235e60, receiver=0x287f4a8, event=0x7fff99235b10) at kernel/qcoreapplication.cpp:610
#18 0x00007f0f9c13c862 in QCoreApplication::sendEvent (this=0x266cfa0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QTimerInfoList::activateTimers (this=0x266cfa0) at kernel/qeventdispatcher_unix.cpp:572
#20 0x00007f0f9c13a25d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#21 0x00007f0f983b2bce in g_main_dispatch (context=0x266c120) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#22 IA__g_main_context_dispatch (context=0x266c120) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#23 0x00007f0f983b6598 in g_main_context_iterate (context=0x266c120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#24 0x00007f0f983b66c0 in IA__g_main_context_iteration (context=0x266c120, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#25 0x00007f0f9c13a1a6 in QEventDispatcherGlib::processEvents (this=0x2643110, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f0f9cd3b4be in QGuiEventDispatcherGlib::processEvents (this=0x42588a8, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f0f9c110532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f0f9c110904 in QEventLoop::exec (this=0x7fff99235db0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f0f9c112ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x00000000005e6872 in _start ()

Reported using DrKonqi
Comment 1 Michel Ludwig 2010-03-09 14:23:33 UTC

*** This bug has been marked as a duplicate of bug 208486 ***
Comment 2 Nicolas L. 2010-06-09 14:56:12 UTC
*** Bug 241190 has been marked as a duplicate of this bug. ***