Bug 229962 - plasma-desktop crashes on desktop switching
Summary: plasma-desktop crashes on desktop switching
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-08 17:14 UTC by Denis Zalewsky
Modified: 2010-03-09 05:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Zalewsky 2010-03-08 17:14:29 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-trunk-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
Switching desktop using keyboard shortcut sometimes causes plasma-desktop to crash.

Additional information: nvidia binary driver with Twinview option switched on (2 monitors 1900x1200 each)

 -- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f12fd82b7a0 (LWP 12926))]

Thread 2 (Thread 0x7f12d73b8910 (LWP 12929)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f12fa3b7499 in QWaitConditionPrivate::wait (this=0x1e7f600, mutex=0x1e7f5f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x1e7f600, mutex=0x1e7f5f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f12f718d3b4 in QHostInfoAgent::run (this=0x1e7f5e0) at kernel/qhostinfo.cpp:260
#4  0x00007f12fa3b64a5 in QThreadPrivate::start (arg=0x1e7f5e0) at thread/qthread_unix.cpp:188
#5  0x00007f12f4a7073a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f12fd23c69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f12fd82b7a0 (LWP 12926)):
[KCrash Handler]
#5  Tasks::itemTopMargin (this=0x2373900) at ../../../../plasma/applets/tasks/tasks.h:92
#6  AbstractTaskItem::basicPreferredSize (this=0x2373900) at ../../../../plasma/applets/tasks/abstracttaskitem.cpp:100
#7  0x00007f12ded984f5 in TaskItemLayout::preferredColumns (this=0x1e858d0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:211
#8  0x00007f12ded9925d in TaskItemLayout::gridLayoutSize (this=0x1e858d0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:227
#9  0x00007f12ded992f0 in TaskItemLayout::layoutItems (this=0x0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:250
#10 0x00007f12ded99bdb in TaskItemLayout::insert (this=0x1e858d0, index=<value optimized out>, item=0x22b3fe0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:129
#11 0x00007f12ded99dd0 in TaskItemLayout::addTaskItem (this=0x1e858d0, item=0x22b3fe0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:82
#12 0x00007f12deda56b8 in TaskGroupItem::itemAdded (this=0x1e86430, groupableItem=0x22bb580) at ../../../../plasma/applets/tasks/taskgroupitem.cpp:477
#13 0x00007f12deda6614 in TaskGroupItem::qt_metacall (this=0x1e86430, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff21e5fff0) at ./taskgroupitem.moc:113
#14 0x00007f12fa4b0df2 in QMetaObject::activate (sender=0x1e85060, from_signal_index=<value optimized out>, to_signal_index=21, argv=0x0) at kernel/qobject.cpp:3112
#15 0x00007f12defded8f in TaskManager::TaskGroup::itemAdded (this=0x0, _t1=0x22bb580) at ./taskgroup.moc:145
#16 0x00007f12defdf67f in TaskManager::TaskGroup::add (this=0x1e85060, item=0x22bb580) at ../../../libs/taskmanager/taskgroup.cpp:138
#17 0x00007f12defc8fb4 in TaskManager::GroupManagerPrivate::addTask (this=0x1e67cb0, task=) at ../../../libs/taskmanager/groupmanager.cpp:290
#18 0x00007f12defc98ab in TaskManager::GroupManagerPrivate::actuallyReloadTasks (this=0x1e67cb0) at ../../../libs/taskmanager/groupmanager.cpp:155
#19 0x00007f12defcb0f9 in TaskManager::GroupManager::qt_metacall (this=0x1a83c10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff21e60260) at ./groupmanager.moc:108
#20 0x00007f12fa4b0df2 in QMetaObject::activate (sender=0x1e67d18, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#21 0x00007f12fa4ab353 in QObject::event (this=0x1e67d18, e=0x0) at kernel/qobject.cpp:1074
#22 0x00007f12fabdf01d in QApplicationPrivate::notify_helper (this=0x150f350, receiver=0x1e67d18, e=0x7fff21e60910) at kernel/qapplication.cpp:4065
#23 0x00007f12fabe707a in QApplication::notify (this=0x14fd3e0, receiver=0x1e67d18, e=0x7fff21e60910) at kernel/qapplication.cpp:4030
#24 0x00007f12fbcc3de6 in KApplication::notify (this=0x14fd3e0, receiver=0x1e67d18, event=0x7fff21e60910) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f12fa49bc9c in QCoreApplication::notifyInternal (this=0x14fd3e0, receiver=0x1e67d18, event=0x7fff21e60910) at kernel/qcoreapplication.cpp:610
#26 0x00007f12fa4c82c6 in QCoreApplication::sendEvent (this=0x1512880) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QTimerInfoList::activateTimers (this=0x1512880) at kernel/qeventdispatcher_unix.cpp:580
#28 0x00007f12fa4c4658 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#30 0x00007f12f4cc1a7e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f12f4cc5438 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f12f4cc5560 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f12fa4c439c in QEventDispatcherGlib::processEvents (this=0x14e4070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#34 0x00007f12fac75f1f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f12fa49a562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f12fa49a934 in QEventLoop::exec (this=0x7fff21e60bc0, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f12fa49cba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x00007f12fd5022bf in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/shells/desktop/main.cpp:50
#39 0x00007f12fd18fabd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff21e60ec8) at libc-start.c:222
#40 0x0000000000400649 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 217209

Reported using DrKonqi