Bug 229833 - cash at clicking some in kdevelop preferences
Summary: cash at clicking some in kdevelop preferences
Status: RESOLVED DUPLICATE of bug 240509
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-07 16:20 UTC by Christoph Thielecke
Modified: 2010-12-06 11:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2010-03-07 16:20:38 UTC
Application: kdevelop (3.9.97 (using KDevPlatform 0.9.97))
KDE Platform Version: 4.4.66 (KDE 4.4.66 (KDE 4.5 >= 20100303)) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.33-rc8 i686
Distribution: Debian GNU/Linux 5.0.3 (lenny)

-- Information about the crash:
- What I was doing when the application crashed:
I opened the preferencesdialog and clicked at the modules list. Some seconds later kdevelop crashed.

 -- Backtrace:
Application: KDevelop (kdevelop.bin), signal: Aborted
[Current thread is 0 (LWP 26627)]

Thread 3 (Thread 0xb025cb70 (LWP 26777)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5ea43d2 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:179
#2  0xb5f3312a in QWaitConditionPrivate::wait (this=0x82da0d8, time=200000) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qwaitcondition_unix.cpp:85
#3  0xb5f32c43 in QWaitCondition::wait (this=0x82e1044, mutex=0x82e1048, time=200000) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qwaitcondition_unix.cpp:159
#4  0xb496b555 in KDevelop::DUChainPrivate::CleanupThread::run (this=0x82e1038) at /home/kde-devel/kdesvn/extragear/sdk/kdevplatform/language/duchain/duchain.cpp:286
#5  0xb5f326a4 in QThreadPrivate::start (arg=0x82e1038) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qthread_unix.cpp:248
#6  0xb5ea0585 in start_thread (arg=0xb025cb70) at pthread_create.c:300
#7  0xb4fa62be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xab0fdb70 (LWP 27022)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5ea40a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb4d5eb51 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb4e53560) at /home/kde-devel/kdesvn/qt-copy/src/3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#3  0xb4d5ebdd in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb4e53560) at /home/kde-devel/kdesvn/qt-copy/src/3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#4  0xb5ea0585 in start_thread (arg=0xab0fdb70) at pthread_create.c:300
#5  0xb4fa62be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb3e7f710 (LWP 26627)):
[KCrash Handler]
#7  0xffffe424 in __kernel_vsyscall ()
#8  0xb4f018e0 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb4f04e15 in *__GI_abort () at abort.c:88
#10 0xb5f260b7 in qt_message_output (msgType=QtFatalMsg, buf=0xa4f1690 "ASSERT: \"asciiCache\" in file /home/kde-devel/kdesvn/qt-copy/src/corelib/tools/qstring.cpp, line 1104")
    at /home/kde-devel/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2250
#11 0xb5f262c1 in qt_message (msgType=QtFatalMsg, msg=0xb60e3c64 "ASSERT: \"%s\" in file %s, line %d", ap=0xbf835f04 "Q�\017�\024�\017�P\004")
    at /home/kde-devel/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2296
#12 0xb5f2632f in qFatal (msg=0xb60e3c64 "ASSERT: \"%s\" in file %s, line %d") at /home/kde-devel/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2479
#13 0xb5f26584 in qt_assert (assertion=0xb60fff51 "asciiCache", file=0xb60fff14 "/home/kde-devel/kdesvn/qt-copy/src/corelib/tools/qstring.cpp", line=1104)
    at /home/kde-devel/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2013
#14 0xb5f8c2f8 in QString::free (d=0xb1e27d8) at /home/kde-devel/kdesvn/qt-copy/src/corelib/tools/qstring.cpp:1104
#15 0xb5f8d4d6 in QString::operator= (this=0xbf83624c, other=@0x8443fac) at /home/kde-devel/kdesvn/qt-copy/src/corelib/tools/qstring.cpp:1282
#16 0xadf16909 in AStylePlugin::setStyle (this=0xbf836228, style=@0x8443fa4) at /home/kde-devel/kdesvn/extragear/sdk/kdevplatform/interfaces/isourceformatter.h:33
#17 0xa90e13c8 in SourceFormatterSettings::load (this=0xb101300) at /home/kde-devel/kdesvn/extragear/sdk/kdevplatform/shell/settings/sourceformattersettings.cpp:116
#18 0xa90e3176 in SourceFormatterSettings::qt_metacall (this=0xb101300, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xb1c6260)
    at /home/kde-devel/kdesvn/build/extragear/sdk/kdevplatform/shell/settings/sourceformattersettings.moc:85
#19 0xb6064401 in QMetaObject::metacall (object=0xb101300, cl=QMetaObject::InvokeMetaMethod, idx=37, argv=0xb1c6260) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#20 0xb6071a37 in QMetaCallEvent::placeMetaCall (this=0xad9b8e8, object=0xb101300) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:561
#21 0xb6073a93 in QObject::event (this=0xb101300, e=0xad9b8e8) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:1248
#22 0xb53c5e21 in QWidget::event (this=0xb101300, event=0xad9b8e8) at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qwidget.cpp:8455
#23 0xb5346184 in QApplicationPrivate::notify_helper (this=0x80881f0, receiver=0xb101300, e=0xad9b8e8) at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:4300
#24 0xb534929f in QApplication::notify (this=0xbf8384bc, receiver=0xb101300, e=0xad9b8e8) at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:4265
#25 0xb641e63d in KApplication::notify (this=0xbf8384bc, receiver=0xb101300, event=0xad9b8e8) at /home/kde-devel/kdesvn/kdelibs/kdeui/kernel/kapplication.cpp:302
#26 0xb605ca84 in QCoreApplication::notifyInternal (this=0xbf8384bc, receiver=0xb101300, event=0xad9b8e8) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:704
#27 0xb69a3801 in QCoreApplication::sendEvent (receiver=0xb101300, event=0xad9b8e8) at ../../../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:215
#28 0xb605d00e in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8056140) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1345
#29 0xb605d2a3 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1238
#30 0xb6099110 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:220
#31 0xb60980ef in postEventSourceDispatch (s=0x808c338) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:276
#32 0xb444d098 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#33 0xb4450823 in ?? () from /lib/libglib-2.0.so.0
#34 0x0808c488 in ?? ()
#35 0x00000000 in ?? ()

Reported using DrKonqi
Comment 1 Andreas Pakulat 2010-03-07 17:43:33 UTC
fixed in beta8 and beta9.
Comment 2 Milian Wolff 2010-12-06 11:38:58 UTC
not fixed apparently, many people still report this bug

please provide a proper valgrind log, see bug 240509

*** This bug has been marked as a duplicate of bug 240509 ***