Bug 229773 - Dolphin crashed during renaming folder on samba network share
Summary: Dolphin crashed during renaming folder on samba network share
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-07 08:56 UTC by svenkettner
Modified: 2010-03-12 20:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description svenkettner 2010-03-07 08:56:02 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
renaming with german umlaut

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x071be829 in QUrl (this=0xbff4d91c, other=...) at io/qurl.cpp:3936
#7  0x0093a0f9 in KUrl (this=0xbff4d91c, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0x0022688e in KFileItem::url (this=0xbff4d928) at ../../kio/kio/kfileitem.cpp:1271
#9  0x00d18432 in KFilePreviewGenerator::Private::updateIcons (this=0x90bedd8, topLeft=..., bottomRight=...) at ../../kfile/kfilepreviewgenerator.cpp:548
#10 0x00d18c9f in KFilePreviewGenerator::qt_metacall (this=0x90becc0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbff4da54) at ./kfilepreviewgenerator.moc:88
#11 0x07220263 in QMetaObject::activate (sender=0x908d448, from_signal_index=4, to_signal_index=4, argv=0xbff4da54) at kernel/qobject.cpp:3113
#12 0x07220ec2 in QMetaObject::activate (sender=0x908d448, m=0x72fb4f8, local_signal_index=0, argv=0xbff4da54) at kernel/qobject.cpp:3187
#13 0x07259b29 in QAbstractItemModel::dataChanged (this=0x908d448, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:126
#14 0x0021536d in KDirModelPrivate::_k_slotRefreshItems (this=0x9084268, items=...) at ../../kio/kio/kdirmodel.cpp:571
#15 0x00217340 in KDirModel::qt_metacall (this=0x908d448, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0xbff4dc98) at ./kdirmodel.moc:84
#16 0x07220263 in QMetaObject::activate (sender=0x908ced8, from_signal_index=18, to_signal_index=18, argv=0xbff4dc98) at kernel/qobject.cpp:3113
#17 0x07220ec2 in QMetaObject::activate (sender=0x908ced8, m=0x80b7410, local_signal_index=14, argv=0xbff4dc98) at kernel/qobject.cpp:3187
#18 0x001f8733 in KDirLister::refreshItems (this=0x908ced8, _t1=...) at ./kdirlister.moc:296
#19 0x001f994a in KDirLister::Private::emitItems (this=0x908d3e8) at ../../kio/kio/kdirlister.cpp:2373
#20 0x0020d406 in KDirListerCache::slotFileRenamed (this=0x8a46858, _src=..., _dst=...) at ../../kio/kio/kdirlister.cpp:936
#21 0x0020dc1c in KDirListerCache::qt_metacall (this=0x8a46858, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbff4def4) at ./kdirlister_p.moc:94
#22 0x07220263 in QMetaObject::activate (sender=0x89f96b8, from_signal_index=5, to_signal_index=5, argv=0xbff4def4) at kernel/qobject.cpp:3113
#23 0x07220ec2 in QMetaObject::activate (sender=0x89f96b8, m=0x38b294, local_signal_index=0, argv=0xbff4def4) at kernel/qobject.cpp:3187
#24 0x00218c09 in OrgKdeKDirNotifyInterface::FileRenamed (this=0x89f96b8, _t1=..., _t2=...) at ./kdirnotify.moc:97
#25 0x00218d54 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x89f96b8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbff4e07c) at ./kdirnotify.moc:79
#26 0x004a47b4 in QDBusConnectionPrivate::deliverCall (this=0x89443b8, object=0x89f96b8, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:891
#27 0x004ac197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#28 0x0721a5fe in QObject::event (this=0x89f96b8, e=0x8a48e88) at kernel/qobject.cpp:1111
#29 0x049c5f54 in QApplicationPrivate::notify_helper (this=0x89625d0, receiver=0x89f96b8, e=0x8a48e88) at kernel/qapplication.cpp:4056
#30 0x049cd67c in QApplication::notify (this=0xbff4e88c, receiver=0x89f96b8, e=0x8a48e88) at kernel/qapplication.cpp:3603
#31 0x0105125a in KApplication::notify (this=0xbff4e88c, receiver=0x89f96b8, event=0x8a48e88) at ../../kdeui/kernel/kapplication.cpp:302
#32 0x0720a6cb in QCoreApplication::notifyInternal (this=0xbff4e88c, receiver=0x89f96b8, event=0x8a48e88) at kernel/qcoreapplication.cpp:610
#33 0x0720b2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x892de48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x892de48) at kernel/qcoreapplication.cpp:1247
#35 0x0720b47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#36 0x072353ff in QCoreApplication::sendPostedEvents (s=0x895b310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 postEventSourceDispatch (s=0x895b310) at kernel/qeventdispatcher_glib.cpp:210
#38 0x06d58e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#39 0x06d5c730 in ?? () from /lib/libglib-2.0.so.0
#40 0x06d5c863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#41 0x0723502c in QEventDispatcherGlib::processEvents (this=0x892da30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#42 0x04a66be5 in QGuiEventDispatcherGlib::processEvents (this=0x892da30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#43 0x07208c79 in QEventLoop::processEvents (this=0xbff4e7e4, flags=) at kernel/qeventloop.cpp:149
#44 0x072090ca in QEventLoop::exec (this=0xbff4e7e4, flags=...) at kernel/qeventloop.cpp:201
#45 0x0720b53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#46 0x049c5dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#47 0x0807a6f5 in main (argc=6, argv=0xbff4ea64) at ../../../../apps/dolphin/src/main.cpp:94

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-12 20:37:54 UTC
Fixed in KDE SC 4.4.0+
Regards

*** This bug has been marked as a duplicate of bug 211525 ***