Bug 229058 - New tab in konsole with applications like VIM and MC behaves incorrectly
Summary: New tab in konsole with applications like VIM and MC behaves incorrectly
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-01 19:50 UTC by Sameer Naik
Modified: 2011-08-05 14:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sameer Naik 2010-03-01 19:50:52 UTC
Version:           4.4 (using KDE 4.4.0)
OS:                Linux
Installed from:    Fedora RPMs

If i launch konsole and create a new tab.
In the new tab if i open a file in vim editor, the vim editor does not occupy the entire konsole window are, and instead takes only about half the area. Similar is the behaviour with applications like mc.
After closing the vim editor. Konsole too stops occupying the entire konsole area.

This issue is a little hard to explain, so i have uploaded a screen capture of the issue available here - http://download.damagehead.com/bug-visuals/konsole-issue.ogg

I hope you guys find it useful.

P.S. I am using Fedora 12 with KDE 4.4 installed via the official fedora updates repository.
Comment 1 Sameer Naik 2010-04-05 11:53:00 UTC
I noticed that this issue is only visible if the konsole window is maximized vertically and konsole width is 80 characters (both conditions need to be true).
Comment 2 Sameer Naik 2010-04-05 12:35:01 UTC
Further i have noticed that this issue only shows up if the konsole window size is 80x40.
Comment 3 Jekyll Wu 2011-07-30 17:34:35 UTC

*** This bug has been marked as a duplicate of bug 176902 ***
Comment 4 Kurt Hindenburg 2011-08-05 14:47:41 UTC
Git commit 7e00edd5166096feb59ffa694b6a6ff858fe1924 by Kurt Hindenburg.
Committed on 05/08/2011 at 16:40.
Pushed by hindenburg into branch 'master'.

Make sure pty device has right size before terminal process queries it.

Whenever TeminalDisplay is resized, konsole tells the underlying
pty device its new size by calling Pty::setWindowSize(). However,
current code can't guarantee when the terminal process starts and
queries the pty device about its size, the pty device already has the
right info. This has caused some long known bugs, such as #176902.

This patch tries to guarantee that important assumption. It currently
uses a hard-coded small delay, which works pretty well in practice
although not that elegant.

Patch by Jekyll Wu <adaptee@gmail.com>

I think this is better than leaving the situation as it is.  This may
be backported if no issues are found.
BUG: 173999
BUG: 176902
BUG: 203185
BUG: 229058
REVIEW: 102061
FIXED-IN: 4.8

M  +7    -0    src/Emulation.h
M  +0    -1    src/Application.cpp
M  +1    -0    src/Session.cpp
M  +30   -6    src/Emulation.cpp

http://commits.kde.org/konsole/7e00edd5166096feb59ffa694b6a6ff858fe1924